Question about 2007 Ford Edge

1 Answer

Trans will pull at higher than normal rpms , vehicle just turn 100k , 2007 edge , could be the trans filter

Was driving fine until a week ago , had trouble with the shift lock solenoid when my sister first bought it but i replaced that already and the symptom isnt the ssame as before

Posted by on

  • Mike Mathis Apr 21, 2014

    I would take it to a trans shop and have them replace the filter and flush the fluid before doing any repairs that may not be necessary

×

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Top Expert:

    An expert who has finished #1 on the weekly Top 10 Fixya Experts Leaderboard.

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

  • Ford Master
  • 75,066 Answers

Do you have any warning lights on like the check engine?

Posted on Apr 20, 2014

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

dddsouve
  • 64 Answers

SOURCE: 1996 TBird 4.6 auto/overdrive trans problem

Your transmission fluid contain water,thats why the colour of the fluid changed to pink.And of such the clutch is slipping causing the engine to reve up before shifting - Check transmission cooler.

Posted on Aug 21, 2008

jonbrown725
  • 73 Answers

SOURCE: 1994 ford ranger extended cab 6 cyl fuel injected 2 wheel drive automatic

This year of ranger had a few flaws, In one case, a break power booster was robbing the vacumm, you can test this by plugging it off and seeing the differance, but you will have limited brakes. This model year had a problem with a vacuum leak on the manifold. You can check these in many ways, but please don't use starting fluid. The rear of the manifold usually on the drivers side where it seals to the block.
Also, in 2 other cases a cracked head has gave me the same problem. It is caused from a loss of vacuum.

Posted on Jan 15, 2009

  • 1509 Answers

SOURCE: 2003 Ford Focus: Pulls Codes P0751, Shift Solenoid

Sounds like you need to cover basics first. The battery cables are clean and tight? Are all the wires in the battery cable at the battery making a good connection? Sounds like a common problem and is in the service bullitins is that the ground wire attached to the battery cable end that goes to the body and then to the transmission case bolt has failed to provide a good ground and the acuators and servos and even the switches have'nt a good path to ground ( their is one but it's though other controllers and the power isn't strongly grounded. I f you were following a dianostic tree of good and bad the ground is the number one cause of your problem. Don't fix the old grounds just add new ones. and then clear codes and test it again. Oil leaks near the transmission to engine connection were found by me everytime that I was assigned to this set of problems. Ground corrected and the car was fixed.

Posted on Aug 09, 2010

  • 1 Answer

SOURCE: E40d trans will not shift into 3rd or 4th gear, only rev. 1+2

check or replace your thottle position sensor tps that trans needs to know where the throttle is to shift if it is bad it will do as you say wont shift to third
another telltale is it will act like it goes into lockup when shifting into reverse and stall the engine

Posted on Feb 19, 2011

  • 1 Answer

SOURCE: 2003 Ford Focus: Pulls Codes P0751, Shift Solenoid

i have hard time shifting from 1st gear to 2nd gear please help me

Posted on Apr 20, 2011

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

When driving if i push the gas pedle to the floor what would cause the car to slow down and the RPMs to go up ?


automatic i assume? the trans could be slipping if trans fluid is brownish red and smells kinda like burnt catpiss that is an indacation . if someone tells you its slipping and needs to be replaced put new trans filter and fluid change first i have had alot of success with tranies just doing that and its relatively cheap

Jan 03, 2015 | Cars & Trucks

1 Answer

We have a 2007 Honda Odyssey, with a VTEC engine. A little over a year ago, the Check Engine light came on. When this happened, the engine lost power. It sputtered. It had not acceleration at higher...


Have you checked the throttle body? That requires an annual cleaning and could very well be the cause of the issues you have with your Honda.

-Alex K.

Nov 03, 2013 | 2007 Honda Odyssey LX

1 Answer

Chevy 1500 silverado 5.3 4x4 transmition slip


Most likely need a trans rebuild
When you continue to use a vehicle with a trans
that doesn't work properly,you ruin it in about 10 miles of driving
When they slip,they have been abused for days or weeks & your done.

Jul 08, 2013 | 2007 Chevrolet Chevrolet Silverado 1500

1 Answer

What is normal rpms for a 1997 chev blazer to shift in


Hv u changed yr trans oil in the pass year? If not then that is what I would do first. If this is not the problem then it may be the trans needs a full service of the filters. cheers

Aug 04, 2012 | Chevrolet Blazer Cars & Trucks

1 Answer

1993 Chevy Cavalier 2.2l engine auto trans. While driving up hills, sounds like torque convertor is locking/unlocking too often. Condition is only noticed as a slight increase/decrease of engine rpm...


try unplugging the torque lock solenoid on the front of the transmission, the RPMs will be a little higher and you will lose a little bit of fuel mileage but it should solve the issue until you can get the solenoid replaced

Sep 20, 2011 | Chevrolet Cavalier Cars & Trucks

1 Answer

Stalling/Idle Issues


Do you have a check engine light coming on?

Jun 27, 2010 | 1994 Toyota Camry

1 Answer

Replaced the trans filter about a week ago. 100K


sticky valve in the trany... they have a conditioner for this problem./......you pour it in and in 2 days u should notice a difference make sure you get tranny conditioner.. nothig else

Jul 07, 2009 | 2005 Pontiac Grand Prix

1 Answer

02 saturn sl1, auto trans slips/leaks


already answered this... check your profile

Feb 06, 2009 | 2002 Saturn L-Series

1 Answer

Transmission


It is most likely a plugged filter. I would try performing a transmission service on it and change the filter. What is happening is that the pump will only **** for a bit until a greater demand is on it. Once the pump is stopped ( shutting engine off) the fluid migrates back into the filter and fills it up. Engine is started and trans will work ok until all fluid is exhausted out of filter and it "gives out". Try this out first, it is a cheap start, and most likely is the problem.

Feb 03, 2009 | 1996 GMC Jimmy

1 Answer

98 Ford Explorer wont move in reverse or overdrive


Probably low oil pressure in the transmission or worn clutches.

Mar 09, 2017 | 1998 Ford Explorer

Not finding what you are looking for?
2007 Ford Edge Logo

82 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

75066 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

fordexpert

Level 3 Expert

5470 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...