Question about 1986 BMW 3 Series

1 Answer

Throttle problem I have an 1986 325 bmw, I can drive it for a bout a mile then as I apply pressure on the gas it simple gives the car spurts looses power and wants to die... I changed the throttle possitioning sensor a while ago and adjusted the throttle body..... the car doesn't have an oxygen sensor in it right now could that be the issue? thanks for any help.

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • BMW Master
  • 3,433 Answers

Sounds like your MAF sensor needs servicing

Posted on Jun 19, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

1993 Isuzu NPR when taking off transmission shifts good but after bout 1/4 mile downshifts out of overdrive and will not shift into of again until it sits and cools for a little while


Many of todays cars have a mode called Limp Mode. The Motor and Computer talk to each other and if faults are found? The Limp Mode (( Short for Limp on home mode )) will be set in the Computer. Go to your local Auto Zone and ask them to Scan the OBD 2 fault codes with their reader. Or pay the dealer. It may be something really simple. My Check Engine light was on the other day because the Gas Cap was loose. This Scanner told us the problem and we tightened the Gas Cap. After 3 times driving the car with it tight .... The Check Engine light went off.

Aug 17, 2014 | Cars & Trucks

2 Answers

P0742 2001 Buick Regal. Constantly seem to be fixing something on this car, prob because it has over 200k miles! Lol. Right now it does not drive/shift right. If you are gentle with the throttle it's...


Sounds like the torque converter is slipping. Have you check the oil level in the transmission? Also burnt oil can sometimes cause this problem.

May 07, 2014 | Cars & Trucks

1 Answer

Car starts sometimes and when u give it gas it wants to die or u try to drive it it wont go


CLEAN the throttle body. the flap is getting stuck. google search how to clean the throttle body on your car.

Here is the quick and dirty: Your gas pedal is hooked up to a wire or motor that turns a flap open and closed and various degrees of open and closed as you apply and take pressure off of the pedal. this flapper gets gunked up and sticks. it is the sticking that causes your car to choke and die :)

Go buy CRC Throttle Body Cleaner and remove the throttle body and spray that in there and wipe clean with a towel.

Search forums for vehicle specific instructions on how to remove the throttle body and clean it. Guaranteed you are not the only person with this issue.

May 23, 2011 | 1999 Dodge Stratus

1 Answer

Drives fine for about 5 miles then starts to lose power then eventually dies. pull over alongside the road, cycle the key about 6 times, then it drives fine for bout 1 mile and does it all over again


This could be due to a fuel system problem, perhaps a clogged fuel filter. Since any debris in your gas tank would be settled to the bottom for the initial startup, the fuel pump picks up clean gas and has no problem supplying the injectors. As you drive, the circulation of the gas from the tank through the filter could cause the filter to plug up with debris, gradually losing power until fuel pressure is not sufficient to keep the car running. Try replacing the fuel filter and running some fuel injector cleaner through with your next fill-up.

Mar 07, 2011 | 1995 Oldsmobile Aurora

1 Answer

I have a 2002 bmw z3 w/20000 miles . occasionally all the cluster pointers i.e. speedometer, fuel,oil pressure fail to actuate when the car is started. it doesn't affect the operation of the car as my wife...


The problem is likely inside the cluster. There are no service parts available for the cluster ... hence BMW telling you that you need a new cluster. i would suggest that you find one on ebay and see if this cures the issue. Note that the coding plug that is plugged into the rear of the cluster will need to be swapped to the new cluster in order for it to read your cars info.

Nov 01, 2009 | 2002 BMW Z3

1 Answer

Im going to buy a '77 chevy silverado. i dnt no much bout cars let alone one older than me. i no it has a 350 edelbrock engine n carb. n a new auto-trans. less than 500 miles on each. well the guy said it...


The cable he is talking about is a Throttle Valve or Kick down cable. What it does is it increases pressure to the clutches on hard acceleration and tells the trans when to downshift.

It could be that your idle is set too low, try giving it a little gas and easing it into gear. If it still kills then you will need to start looking at possible engine / Trans problems.

I assume it's a TH350 trans?

Sep 13, 2009 | Chevrolet Silverado Cars & Trucks

2 Answers

1989 Nissan Pickup spurting and cuts out


sound like a tps (throttle position sensor) to me. is it idling high?

May 30, 2009 | 1989 Nissan Hardbody King

1 Answer

Auto lost drivr


thats the water radiator light .... check water and pressure test the water hose

May 15, 2009 | 2001 BMW 330

1 Answer

BMW


Hi

It sounds as though you either have a faulty O2 sensor, or there is a fuel pressure issue, which from your description, could be due to a worn fuel pump.

If the car performs ok under full acceleration, but plays up at either part throttle or no throttle, then you may well have a faulty O2 sensor.

Very best regards

Geordie

Jun 08, 2008 | 1999 BMW 323 Series

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

160 people viewed this question

Ask a Question

Usually answered in minutes!

Top BMW Experts

Anthony Jones
Anthony Jones

Level 2 Expert

128 Answers

Frankie B

Level 2 Expert

65 Answers

Doberman

Level 2 Expert

254 Answers

Are you a BMW Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...