Question about Chevrolet Express

1 Answer

I have a 2000 gmc cargo van with a 5.0

I just fixed a broken wire and the van started but stopped running because the ecm-b fuse blew. Now the fuel pump will kick on sometimes and sometimes it won't can someone please explain or tell me what to do or where to start please

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    MVP:

    An expert that got 5 achievements.

    New Friend:

    An expert that has 1 follower.

    Cheetah:

    An expert who has answered 20 or more questions within one hour.

  • Contributor
  • 42 Answers

Check all fuses again. Make sure your wire isnt touching anything it shouldnt. Remove negative battery cable. wait a few minutes. reattach cable, restart & go from there

Posted on Apr 19, 2014

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

fixincars
  • 335 Answers

SOURCE: HARD STARTING PROBLEM

Fuel Filters need to be changed EVERY 15,000 Mi and oil changes once a year maybe,maybe every two years
Common Problem for the cargo is that the distributor gets moisture in it due to the vent being plugged up, And the Cap and rotor have been Known to cause your symptoms use only GENUINE dELCO PARTS IN YOUR VAN TO ASSURE THE PROPER PERFORMANCE

Posted on Aug 10, 2008

  • 2 Answers

SOURCE: 2000 GMC Jimmy will not start

The oil presure switch does have some bearing on the problem but my suggestion is to change the coil. I had a the same problem with an astro van. I changed everything that you have described and it fixed the problem just for a little while and then all of a sudden did it again. I changed the coild and the cold start swithch and never had the problem again.

Posted on Nov 29, 2008

fingaz22
  • 1068 Answers

SOURCE: why?,...you'll just ask me for $!...OK, sorry,...this sites free?

sounds like the pump died after that filet being clogged! fuse and relay are in the fuse block under the hood drivers side fender wall. ecm-b fuse g12 - f11 is what is said the location was! hopefully this helps

Posted on Sep 18, 2009

alicantecoli
  • 22095 Answers

SOURCE: Van will not start. It Cranks and the fuel pump

wont turn over??sounds like the timing belt has broke and pistons hitting the valves

Posted on Nov 20, 2009

  • 6 Answers

SOURCE: Engine will not start. Checked the relays, fuses,

89 pathfinder wont start getting fuel to the throttle body but nothing from the injectors it was running great untill i shut it off

Posted on Feb 27, 2011

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Why does my ECM-I fuse keeps blowing?


Did you check the crank sensor wire, it may be hitting the hot exhaust. does the wire going to fuel pump have a problem and is shorting out. ECM 1 ..... then there are 5 components that this fuse feeds
1-crank sensor
2- all injectors
3- ECM
4- electronic ignition control module
5- ignition coil - check for a bad wire in these areas. Hope this helps.

May 21, 2014 | 1997 Chevrolet Astro

1 Answer

1990 Asrto van blew aECM fuse I replaced the fuse van started but has no power and will not stay running unless gas is pushed


I would suspect the fuel pump is defective. It is located inside the gas tank, the tank must be removed from the truck to replace the pump.

Jul 22, 2012 | Cars & Trucks

1 Answer

I have a fuse blowing constantly on my van


you are on a search and destroy mission, i recommend you buy a manual with wiring diagram, at least it will tell you what is hooked on that circuit, thenits a matter of testing wiring, i suspect you have a short somewhere

May 24, 2010 | 2000 Chevrolet Express Cargo

1 Answer

Why?,...you'll just ask me for $!...OK, sorry,...this sites free?


sounds like the pump died after that filet being clogged! fuse and relay are in the fuse block under the hood drivers side fender wall. ecm-b fuse g12 - f11 is what is said the location was! hopefully this helps

Sep 17, 2009 | 2000 GMC Savana

3 Answers

Ecm fuse keeps blowing


just fixed this problem, change your fuel pump module, fuel sending unit shorts out on fuel level swing arm blue wire... unfortinately you must replace it as unit because of the design, fuel pump and tank guage fuel level sending unit are a one peice item, fuel tank has to come out to change unit, about a $ 700.00 repair too... fuel pump module runs about 350 to 700 $ depending on aftermarket or factory, try to find one with a lifetime warranty even if it is $ 50.00 more worth it..labor is about $ 250 to $ 400 depending on shop labor rate... definate problem though I ahve no doubt, common problem on GM... please rate my help, thanks...

Aug 06, 2009 | 2002 GMC Yukon XL

2 Answers

I have a 1995 GMC safari, as i was driving the van stopped running. It does turn over but will not start. Has new fuel injector, distributor cap and rotor, plug and wires. When I prime it gas does come...


If you have not fixed this yet, let me suggest something. I have a 91 Safari and the same thing happened. It turned out that the "computor" blew a fuse. No known reason why either. I replace the fuse and the thing started right up. So, if not a fuel problem, check every fuse with some type of tester. Visual can sometime fool ya. Good luck.

Jun 14, 2009 | 1995 GMC Safari

2 Answers

2000 GMC Jimmy will not start


The oil presure switch does have some bearing on the problem but my suggestion is to change the coil. I had a the same problem with an astro van. I changed everything that you have described and it fixed the problem just for a little while and then all of a sudden did it again. I changed the coild and the cold start swithch and never had the problem again.

Oct 27, 2008 | 2000 GMC Jimmy

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

55 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

75197 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

7782 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...