Question about 1985 Toyota Tercel

1 Answer

2000 S10 L4-2.2L runs rough on acceleration 50 mph on up

Starts great, idles great

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Toyota Master
  • 1,108 Answers

Change your air filter and fuel filters.It's either not getting enough air or gas,or possibly both,but JUST enough to run.

Posted on May 29, 2014

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

mrgreenz
  • 962 Answers

SOURCE: while driving fine at low speed it shook and

get a trouble code from Autozone or other store for free. It sounds like a sensor problem to me. The Idle Position sensor for example.

Posted on Dec 09, 2009

Testimonial: "thanks, no sparkplug or fuel injection problems?"

  • 118 Answers

SOURCE: 1990 Toyota Pickup

carb or Fuel injected try cleaning either one of these bad distributor cap or rotor or distributor good luck

Posted on Sep 24, 2009

  • 8 Answers

SOURCE: high idle and running a little rough, sluggish in 2006 sequoia

Check the throttle body and see if it has build up around the butterfly. If so, clean the butterfly with throttle body cleaner. This may be it. There are other possibilities but this is a simple inspection.

Posted on Jan 11, 2010

  • 53 Answers

SOURCE: 2000 sienna stalls, loses power and engine sounds

After about 100K + miles the idle air control valve (IAC) begins to collect carbon deposits that interfere with the movement of the spring-loaded valve. You will not be able to clean this without removal and dissembly of the IAC body. Use an emory cloth or fine sandpaper to remove the build up around the valve. This should free it up to rotate without binding. This is a temporary fix, of course, and will either require cleaning again or replacement of the valve. Getting to the IAC requires removal of most of the intake upto, but not including, the intake manifold. Total time is approximately 3-4 hours, but worth it. Good luck, and I hope this helps.

Posted on Feb 21, 2010

  • 235 Answers

SOURCE: 2001 toyota sienna ce, runs good at idle, takes

I would change the transmission filter.if clogged it will slip and loose power on steep upgrades try that it is inexpensive. If that don't help you may need a new transmission.

Posted on Sep 13, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Hello i have a 2000 olds silhouette ,and anyhow we have had to replace the tension er and pulley etc recently. then when i was driving my van around town i was making a turn around the corner and my van...


Many GM cars have a TIMING SENSOR under the pully, if you DID'T remove the sensor FIRST you May have damaged it or dis lodge it from it grooves. Look into this sensor idea, before spending too much $$$.

Mar 20, 2011 | Oldsmobile Silhouette Cars & Trucks

1 Answer

My 2000 bonneville idles rough. 3.8 liter. it even


Mine did this at one time, and it was only a bad plug wire. Give it a tune up and see if it works. 170k miles is awesome, I have 145k now and it runs great, but had to have ac replaced this week :( Good Luck!!

Feb 26, 2010 | 2000 Pontiac Bonneville

1 Answer

93 Lincoln Conti. Runs rough in gear


Probably a bad idle air motor, it controls idle electronicaly

Aug 30, 2009 | 1993 Lincoln Continental

1 Answer

2000 Chevy s10 2.2L very rough idle at low rpm


run a fuel pressure test, if that checks out fine it may be a faulty coil pack or ignition control module

Jul 28, 2009 | 2000 Chevrolet S-10

1 Answer

1996 buick LeSabre runs rough at 50 mph


Sounds like low fuel pressure. i.e. fuel pump, fuel pressure regulator, or fuel filter.

Jun 02, 2009 | 1996 Buick LeSabre

1 Answer

The 2000 mountianeer starts and runs fine but shuts off


CHECK THE COLD START ENRICHMENT VALVE AND OR THE IDLE CONTROL VALVE. I AM ASSUMING THAT YOUR VEHICLE IS FUEL INJECTED. ONE OF THOSE HAVE GONE BAD.

Jan 24, 2009 | 2000 Mercury Mountaineer

1 Answer

Rough idle, and rough in the 50 - 65 mph


code 12 is start

13** No difference recognized between the engine MAP reading and the barometric (atmosphereic) pressure reading at start-up

Code 55 is end so 13 is all you need , basically your map isnt working
its an easy fix if thats all , take one off , put new one on

Dec 11, 2008 | 1998 Jeep Cherokee Grand 2WD

Not finding what you are looking for?
Cars & Trucks Logo

85 people viewed this question

Ask a Question

Usually answered in minutes!

Top Toyota Experts

yadayada
yadayada

Level 3 Expert

75197 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

7782 Answers

Are you a Toyota Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...