Question about Toyota 4Runner

1 Answer

Bad gas? or maybe fuel filter?

My 2006 4runner Sport v6 started vibrating in gears 1-2 last week. Sometimes is doesn't, sometimes it does. I ran to old tank of gas out yesterday and refilled. But the problem still persists. It runs fine after you get in higher gears, just the vibrations while switching from 1 to 2 and 2 to 3. Any suggestions?

Posted by on

  • Casey Taylor
    Casey Taylor Apr 18, 2014

    And no "check engine" lights have came on.

×

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Top Expert:

    An expert who has finished #1 on the weekly Top 10 Fixya Experts Leaderboard.

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

  • Toyota Master
  • 42,042 Answers

Check engine mounts especially the rear box mount because under high torque situations (1-2) gears there may be mis-alignment of the drive shaft occurring and the vibration is from "U" joints behind the gear box getting out of alignment and phase angle.. Check slip joints for lubrication and wear.

Posted on Apr 19, 2014

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

hiseyj
  • 99 Answers

SOURCE: fouled fuel injector

If that is truly what he told you then you need a second opinion. You can't foul a fuel injector. The computer won't tell you there is water in a cylinder, they aren't that good. Did he give you a print out of codes or anything? You could have some bad fuel in the tank since you said it gets worse when the fuel is low. Get a second opinion or look at your paperwork from the first guy and tell me what he really said.

Posted on Nov 28, 2008

mecanica03
  • 881 Answers

SOURCE: Vibration on acceleration

when some vheel missing weight , the vibration begins at 40-45 mph, now if begins at any moment of acceleration ,check inner drive shafts , no outer joints

Posted on Apr 20, 2009

  • 41 Answers

SOURCE: 99 olds bravada. just replaced fuel pump 2 weeks

Aftermarket fuel pump failure? Try "thepartsladi" store on eBay for low price GM OEM parts. Could also be wiring harness to fuel pump.

Posted on Feb 06, 2010

  • 105 Answers

SOURCE: Help. 2000 Avalon Toyota upon starting,

  1. toyota has an idle air valve
  2. locate the valve on the throttle body
  3. unplug and remove it as an assembly
  4. off the car it can be disassembled into 2 pieces
  5. one has the wiring connection
  6. the other is the air valve shuttle
  7. clean the shuttle and actuate the valve manually until it moves freely.
  8. install and retest

Posted on Aug 19, 2010

  • 1 Answer

SOURCE: 1989 Z24, 2.8v6 intermittent stalling while

89 chev cavalier 4 cyl auto 2.0 when going down road 50 mph slam on breaks car stalls start car put it in gear it stalls what is wrong it seems to do it when its hot only why

Posted on Apr 11, 2011

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I had a starting issue with my 93 t100 3.0 v6 last week. Changed the fuel pump and then it started first crank every time. Ran great for a week and then yesterday it died on the freeway and would not start...


Have you had the catalytic converter changed ever? Have you the owner manual? Are there any new lights in the dashboard? Some vehicle are computer programmed to stall after a certain number of miles to prevent further damage. That is what it sounds like is happening to you.

Feb 27, 2015 | Cars & Trucks

4 Answers

2002 Cavalier starts then dies. Started about 1 week ago. Let sit overwrite started fine next afternoon. Ran great for several hrs. Started dying again. Replaced fuel filter, Ran great for a day. Now it...


Had a 89 cavalier did that start then die it map sensor. Also check ground wires if the become too corroded they won't start sometimes just run weird

Jan 21, 2015 | 2002 Chevrolet Cavalier

1 Answer

Possible Fuel filter/fuel pump issues


Your car does not have an inline fuel filter. Do you have a check engine warning light on.

Mar 17, 2014 | 1998 Chrysler Cirrus

3 Answers

Car will not start


When it was transported (driven?) to miss. they could have gotten some bad ( water and/or dirt) in the gas.
Change the fuel filter.
Sometimes de-natured alcohol will absorb water.

Hope this helps.

Jan 24, 2014 | 1998 Honda Civic

1 Answer

2004 Chevy Cavalier - car cranks over but doesn't start


Ignition module or crankshaft postion sensor . Test it in the vehicle , test light , volt meter . Videos on youtube .
2004 Saturn Ion 2 2 Misfire Case Study P0300

Mar 25, 2017 | 2004 Chevrolet Cavalier

1 Answer

1996 camaro it's a v6- standard. The car has 79k


EGR Valve?
TPS Sensor?
Vacuum Leaks

You know it is a throttle actuated issue

May 23, 2012 | 1996 Chevrolet Camaro

2 Answers

Ran out of gas last week and know the check engine lite comes on 1 & while but the prop. is when going 45 and trying to speed up it sputters until i kick in the passing gear


Possible fuel filter, but it could possibly be that when you ran the tank down to nothing you ruined the electric fuel pump in the gas tank. Given the age of the vehicle it's very possible. The fuel that the pump sits in basically cools the motor. If you run it really low all the time allowing the motor to heat up, it will eventually fail. If pump replacement is necessary, replace the fuel filter and the fuel sock all at the same time.

Jul 12, 2009 | 1994 Pontiac Grand Am

3 Answers

1995 Chevy K1500 4.3L V6. Engine has inconsistant idle


Have you changed the fuel pump yet?I had the same exact problem.I replaced my fuel pump with an AUTOZONE PIECE OF JUNK fuel pump.That pump lasted almost 2 days.The second day i had it the truck didnt want to start but it did and it ran like ****,and when i put it in gear it ran as long as I didnt touch that gas pedal.You could go get a fuel pressure test or just replace it,your call.You might want to check your filter too but im sure its the pump.Good luck

Apr 13, 2009 | 1997 Chevrolet K1500

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

95 people viewed this question

Ask a Question

Usually answered in minutes!

Top Toyota Experts

yadayada
yadayada

Level 3 Expert

75797 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22114 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8152 Answers

Are you a Toyota Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...