Question about 1985 Toyota 4Runner

Open Question

4-runner is running too rich?

Engine starts for a few seconds and then cuts off...will start after ten minutes of effort??

Posted by Anonymous on

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

ourhowse
  • 2007 Answers

SOURCE: will run for a few seconds but then it stops

mass air flow sensor

Posted on Apr 29, 2009

jmgldsmth
  • 1869 Answers

SOURCE: Camry hard to start and runs rich

check your WOT switch this is attached to a flap inside your engine manifold tube and sends a signal to the engine computer telling it how much air is entering the engine

Posted on May 22, 2009

  • 123 Answers

SOURCE: 1992 previa is hard to start only when cold. It

try to change the coolant temp sensor.

Posted on Nov 22, 2010

  • 7 Answers

SOURCE: engine cuts out , dash light shape of an engine lights up leave a few minutes engine fires up runs a few minutes then cuts out again.

check throttle ign. sensor

Posted on Nov 20, 2012

  • 1 Answer

SOURCE: Toyota Corolla AE110 1996 model

Check your computer box. There may be a problem with it. Repair or change it.

Posted on Nov 26, 2012

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Engine running rich


Most likely throttle positioning sencer

May 08, 2016 | Cars & Trucks

1 Answer

I have a 2001 4.0 ford ranger 4x4 burning to rich on driver bank replaced maf and injector what eles can cause this runs bad when cold not bad when it warms up


More than 1 reason. Each may take an independent corrective action. The cold start problem can be a failure of the "Cold start cycle" which uses a temperature sensor to set a rich fuel mix and speed up the idle.
You would need to replace one of 2 sensors. The second sensor operates the dash gauge or light.

Air leak- The side having a rich mix is compensating for excess air entering the engine on that bank of cylinders. With the engine running, use a spray water bottle and wet the seams of the intake and vacuum lines for that bank of cylinders. The rpm will change or stall the engine.

Manifold runners. Some models have manifold runners for the intake. These change airflow and they can stick in the wrong position. This requires removal of the intake, so try the easiest reasons first.

Please rate my info.

Mar 05, 2013 | 1997 Ford Explorer AWD

1 Answer

I have a vn commodore on start up when it is cold it will idle but if u give it a little rev it will die after 30 seconds it wont then drive down the road ten minutes it will die note running fine and just...


Hi Daniel, The problem sounds to me as if it has to do with the temperature sensor which sends signals to the ECU. The sensor is nothing to do with the gage on the instrument panel, but instead signals the the ECU to increase fuel richness for cold start and cold running. Have a diagnostic scan carried out, and check for disconnections or broken cables, if the connections and cables are good the defect may not show on the scan, but replace the sensor anyway. I think that will solve your problem. Regards John

Oct 17, 2012 | Holden VN Cars & Trucks

1 Answer

My 1995 jimmy start die over and over


Josh, same problem with my suburban, very frustrating. Two issues to check.
Underneath your distributor cap and ECM module there is the pickup coil. The reluctor is most likely corroded really bad. It is about one hour work but you would be surprised how dirty and corroded that area gets. The reluctor is a fixed part of the distributor shaft and the little nubs break magnetic field which is
processed by your onboard computer. If the pulses are not correct the computer is telling your TBI injectors to spray which will flood out your engine. Ten of fifteen minutes later, it will start up again and then die shortly after. Have a new pick up coil on hand too ($10.00) since your in there. My reluctor looked like it was in Vavy Jones locker it was so crusty. Second- the fuel relay. Nororious for developing little cracks on the mini circuit breaker which get wider as voltage and amps increase due to resistance (dirt,moisture). The relay will shut off the fuel pump if the oil pressure signal gets cut, and if your breaker/circuit board is
bad the board heats up and trips off your fuel. When the board cools off in ten or fifteen minutes, starts up and then dies when engine gets warm/hot. It really had me stumped for quite some time. Hope ths cuts your wrench time down considerably.

Jul 27, 2012 | 1994 GMC Jimmy

1 Answer

516 Cdi sprinter sudden blue smoking for few minutes and after OK


somthing in the ignition is causing a weak spark--or fuel inject circuit is running to rich----------all causes improper burning---------get a computer diagnostic done

Apr 07, 2012 | Cars & Trucks

1 Answer

I just put a new steering column in my 200 saturn sl2 because my ignition lock was messed up. Now when whe try to start the car, it will start up but immediately shut off and then the security light...


Hello: Will try to give you instructions: Attempt to start car, leave key on (security light flashing) let set for 10 minutes, After 10 minutes security light out. Turn key off for ten seconds, turn key on, let set for 10 minutes, turn key off for 10 seconds. turn key back on let set 10 minutes, turn key off for ten seconds, the engine should now start and stay running.

Jan 14, 2011 | Saturn SL2 Cars & Trucks

1 Answer

Replaced ignition lock cylinder and new key has no chip so it will turn over but now wont start. what to do?


CHARGE BATTERY / TURN KEY TO RUN POSITION FOR TEN MINUTES
SECURITY LIGHT SHOULD GO OUT / TURN KEY OFF FOR 3-5 SECONDS
TURN BACK TO RUN FOR TEN MINUTES / REPETE / USALLY TAKES
3 TEN MINUTE CYCLES / THAN TURN OFF / TURN ON SECURITY LIGHT
SHOULD GO OUT AND ENGINE START AND RUN

Dec 08, 2010 | 1996 Oldsmobile Cutlass Supreme Coupe

1 Answer

When starting from cold car runs ok for few seconds then hunts/missfire can cuts out.re starts ok but will do the same again ubtill you get a bit of heat into engine then its ok!


i advice you to change the spark plugs,this is cause because at cold start the engine needs a rich mixture in order to maintain a smooth idle,before driving the car,when starting from cold ,what you have to do is to accelerate up to 2000 rpm for 3 minutes then you drive it,then it should be ok

Sep 02, 2009 | 1992 Volkswagen Fox

1 Answer

New ignition switch now car security system locked


ok here you go
make sure the battery is fully charged befor starting
turn ignition to run
attempt to start once then release the key in the run position
let vehicle sit with the key on for ten minutes
the security light should turn off
turn igniton switch off
wait 5 seconds
turn key to run position
let vehicle sit for 10 minutes
turn key off
wait 5 seconds
turn key to run position
let vehicle sit for ten minutes
turn key off
wait more than 6 seconds
and start engine

Jun 14, 2009 | 2001 Chevrolet Monte Carlo

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

18 people viewed this question

Ask a Question

Usually answered in minutes!

Top Toyota Experts

yadayada
yadayada

Level 3 Expert

75066 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

7754 Answers

Are you a Toyota Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...