Question about Hyundai Elantra

1 Answer

I change coil pack,transmission speed sensor but the engine still in rough idle

Rough idle,and when i shift to reverse or drive the engine more rough,i change the coil pack and transmission speed sensor but still the problem excess

Posted by on

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that hasĀ over 10 points.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 13 Answers

Would search first inlet air leak in between air box and engine - all hoses on, clamps tight no cracks
then disconnect idler control - about where the engine accelerate cable comes in / most probably opposite. Problem still there?
look for ignition - plugs, check leads with multimeter, connections

Posted on Apr 18, 2014

Ad

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad
leetamara
  • 702 Answers

SOURCE: transmission won't engage/ no drive or reverse at all

It's definitely cheaper to buy a trans from a wrecking yard than to have yours rebuilt. Before you do anything though. Did you make sure that the trans fluid level is full? I know this may be a stupid question, but I had to ask. The speed sensors job is to tell the speedometer how fast you're going...not related to your problem.

Posted on Jul 03, 2008

  • 3 Answers

SOURCE: Chevy 1/2 ton 2wd 4.3 vortec rough idle tried everything I know

I had the same problem with my 96 Chevy 4.3. It idled rough enough to shake the truck at a stop. It revved up fine but sputtered on take off. My truck did not want to stay in overdrive because of the low rev. I changed cap, rotor, plugs, wires and this did nothing. Finally I took the intake off and found corrosion on the side intake gaskets near the rear of the engine causing a vacuum leak.

Posted on Nov 11, 2008

  • 11 Answers

SOURCE: 02 Neon won't shift out of second gear in Drive

Sounds like the valve body is loose, warped or blown

Posted on Apr 07, 2009

  • 18 Answers

SOURCE: Volvo S60 sensor ?

Sounds like an oxygen sensor (there are two). I had a recent problem where I had a rough idle and my S60 continued to stall out. Turned out to be the rear oxygen sensor. After replacement, car idles nicely and car drives normally.

Posted on Jun 30, 2009

  • 1 Answer

SOURCE: own a 1996 Grand AM GT 2.4 quad 4..manual...engine

engine missfire won't start

Posted on Dec 13, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

2005 Dodge Ram 1500 4.7 Engine. Starts fine, Idles fine, but when engine shifts into high gear and RPM lowers engine runs really rough under load


Have you checked for a broken valve spring. Repaired a dodge engine with the same running issue as you have described and it was a broken intake valve spring.

Feb 22, 2015 | 2005 Dodge Ram 1500

1 Answer

Is there a Fuse for a/t shifting, 2000 vw jetta


From the tear of the car I guess you have the 4-speed automatic. That transmission is not one of the most reliable ones...it has an internal wiring harness with relays attached to it, that are in control of what gear to select, based on input from an internal speed sensor, engine speed sensor and wheel speed sensor. There is also an issue with VW claiming that the transmission "is filled for life", which is absolute B.S. You have to change the transmission fluid and the filter at least every 60K or you will face an expensive rebuild. Have your mechanic scan the computer for fault codes related to the transmission and change the fluid and filter when the problem got fixed.

Nov 09, 2014 | Volkswagen Jetta Cars & Trucks

1 Answer

2000 ford excursion. OD light blinks, shifts hard, idles rough, kills some times. Turn off, restart and it clears until stop at red light or go in reverse then light blinks again. Changed both sensors on...


If you've changed the sensor and still getting the code, then the problem is either a wiring harness issue OR, you really do have an internal transmission problem.

Jan 01, 2018 | 2000 Ford Excursion

1 Answer

I have a 1997 lumina with 3.1L. the problem started with loss of power under load and p0300 code. check coils and vacuum leaks both OK.change spark plugs and wires.[same problem] check compression OK.


Since you changed the sensor we will assume it is working. When you disconnect it you put the computer in limp mode which stops it from using sensor values. If code 300 is the only code we will assume the coolant temp sensor and others are ok.
I would check fuel pressure with a gauge next.

Aug 21, 2012 | 1997 Chevrolet Lumina

2 Answers

1998 Grand Marquis. Start goods. idols low. put in gear, stalls out. Changed fuel filter & had injectors serviced. Problem remains. Could it be the Transmission modulator valve?


I would check the operation of the idle speed control valve, it is what changes the idle speed when a load like the transmission is put on the engine, without it the engine will idle slow and stall out, this is even more apparent when reverse gear is selected or drive or the AC is tuned on. The ISC valve is located on the side of the throttle body top of upper intake manifold. Below is a picture of the ISC (idle speed control valve)
11_11_2011_10_58_29_pm.jpg

Sep 30, 2011 | 1998 Mercury Grand Marquis

1 Answer

Recently I had my 2000 gmc 2500 6.0 liter truck start running rough. I changed the spark plugs, checked the coil packs and replaced the fuel pumpand fuel filter. Still no change....Any suggestions?


ROUGH IDLING CAN BE CAUSE BY MANY THINGS.I AM LOOKING AT LEAKING VACUUM HOSES OR INTAKE MANIFOLD GASKET LEAK.DIRTY FUEL INJECTORS AND WORN ENGINE VALVES WILL CAUSE ROUGH IDLING.ALSO LOW IDLE SPEED CAUSE ENGINE TO RUN ROUGH.

Apr 18, 2010 | 2000 GMC New Sierra 1500

1 Answer

02 Neon won't shift out of second gear in Drive


Sounds like the valve body is loose, warped or blown

Apr 07, 2009 | 2002 Dodge Neon

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

111 people viewed this question

Ask a Question

Usually answered in minutes!

Top Hyundai Experts

yadayada
yadayada

Level 3 Expert

79865 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22326 Answers

Jeffrey Turcotte
Jeffrey Turcotte

Level 3 Expert

8836 Answers

Are you a Hyundai Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...