Question about 1989 Ford Econoline

1 Answer

Runs until it warms up

Already changed sensors plugs and wires and vacuum leak

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that hasĀ over 10 points.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 9 Answers

Does it have a catalytic converter? I had to have mine changed.

Posted on Apr 16, 2014

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 5 Answers

SOURCE: 1987 F150 rough idle, stalls, smells rich

graphic.aspx?mod=reptiff&module_id=1&session_id=%7b42f14894-9aa8-441f-8d1b-0146757f530d%7d&image_guid=95d12578&print_bw=0&

Posted on Jun 02, 2009

  • 47 Answers

SOURCE: 1990 f150 sputters after warmed up.

Replace the fuel filter.

Posted on Jun 25, 2009

wyatt1582
  • 453 Answers

SOURCE: 1998 FORD CONTOUR CHECK ENGINE

sounds like EGR valve and sensor this controls idle speed when at a stop. the po171 is a burn lean or rich code need to know what bank 1 or 2. also check for a vacuum leak from one of the hoses.

Posted on Aug 07, 2010

  • 1565 Answers

SOURCE: engine runs rough and will quit running at stop

your idle air control valve may be the problem. This device controls the idle speed. It may be gummed up with deposits. this is what it the part looks like; http://www.rockauto.com/catalog/moreinfo.php?pk=382734

you can remove it and spray it with carb cleaner to loosen up the valve or replace the assembly.
A faulty EGR valve and/or PVC valve will cause similar symptoms.

Posted on Sep 10, 2010

johnjnail
  • 1702 Answers

SOURCE: 1989 Bronco runs rich. I've replaced Map sensor,

check that there is no fuel in the vacuum hose that is going to the fuel pressure regulator, if there is fuel in the vacuum hose replace the regulator.

Posted on Mar 17, 2011

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

3 Answers

Starts and runs fine.....rough runs, when you restart after warmed up


Sorry - I didn't see the vehicle information the first time.

Let me research this - i will get back to you soon.

Aug 03, 2014 | 1999 Subaru Legacy

1 Answer

02 jag v6 shakes and sputter


first check for vacuum leaks, rubber vacuum lines can dry out and crack especially after sitting for a while

Apr 13, 2014 | 2002 Jaguar S-Type

1 Answer

Runs rough until engine warms up


could be your temperature sensor or a vacuum leak somewhere.

Dec 28, 2011 | 1995 Jaguar XJ6

2 Answers

I have a 1998 GMC Sonoma 4.3 4x4, and its running pretty rough, if it starts, it runs like out of timing and backfires as it warms up, changed rotar, distributor,cap, set timing about fifteen times. i even...


Based on what you have already replaced and the fact you keep having to rest the timing tells me the problem is the Timing Belt/Chain has stretched or the Tension assembly for the timing has become inoperative. Your going to have to inspect these and repair them as needed.

Feb 17, 2011 | GMC Sonoma Cars & Trucks

1 Answer

1998 FORD CONTOUR CHECK ENGINE CODES P1131 AND PO171. REPLACED 1 OF THE OXYGEN SENSORS, CHANGED PLUGS, PLUG WIRES, OIL AND FILTER, ALSO REPLACED AIR FILTER AND CLEANED PCV FILTER, RESET PC AND IT RAN GOOD...


sounds like EGR valve and sensor this controls idle speed when at a stop. the po171 is a burn lean or rich code need to know what bank 1 or 2. also check for a vacuum leak from one of the hoses.

Aug 07, 2010 | 1998 Ford Contour

3 Answers

Random misfire once warmed up.


really not much to go on there

You could run some injector clean in the fuel for a couple tanks. Make it strong.

You might have weak coil pack but I don't suspect that as much

You might have an intake leak ( vacuum leak ).

The crank sensor could be dropping out at times.

You could have a valve issue

Or if your luckey you may just need a tuneup which I'm sure you have done already since your here.

Nov 24, 2009 | 1998 Saturn SL

1 Answer

Runs rough till warmed up. Hesitates. I put a new


Ok, you got new 02 sensors, that is good, Now check timing, vacuum hoses for leaks, check for headgasket leak with compression test, Check or change fuel filter and plug wires. If fuel injected, try using injector cleaner and you can also remove one injector at a time to make sure it is not leaking or plugged. You can also test throttle position sensor and idle position sensor with an ohmmeter to see if they are good.

Nov 17, 2009 | 1992 GMC Sierra

2 Answers

My 1985 nissan 300zx 2+2 run crappy when engine is


PROBABLY IS TIME TO DO A TUNEUP SPARK PLUGS AND WIRES

Aug 04, 2009 | 1985 Nissan 300ZX

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

31 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

75005 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

fordexpert

Level 3 Expert

5470 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...