Question about 1999 Ford Mondeo

1 Answer

Car engine cold but thermostat goes onto red!

We replaced the switcher unit (I think that's what you call it) and now the car has immediately gone onto the red even though the engine is cold! Any ideas please because this is ridiculous and becoming a real pain in the you know what!

Posted by on

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 17 Answers

Some cars have more than one sending unit for the temperature. You probably bought the wrong one.

Posted on Jun 09, 2014

Ad

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
New users get 2 Free calls (no credit card required) and instant help on almost anything you can think of (from cars to computers, appliances, handyman, and even pets).
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad
  • 1 Answer

SOURCE: 200 Ford Focus 1.6, temperature gauge at full, even on ignition

is it your impeller, got a ford st24 and had the same problem,could only drive a short way before it got too hot again but the felt cold.

Posted on Dec 15, 2008

  • 2 Answers

SOURCE: fiesta mk 5 heater problem

the heater control valve on the fiesta mk5 are common to fail ...ebay £15 find two thin hoses going from the engine to the scuttle panel and youll see it .easy changeover

Posted on Dec 30, 2008

motor1258
  • 6674 Answers

SOURCE: location of thermostat

Did you run the engine with rad cap off & heater (not defrost) on while topping up the coolant. If not, do it & let it run that way until your rad fan comes on & off about 3 times, then top rad up to a inch or 2 from top, and put cap back on, & check level in return bottle.

Posted on Jan 16, 2009

  • 4 Answers

SOURCE: 1996 ford tarus location of coolant temperatue sensor?

I doubt if it is the temperature sensor if the gauge is working. Check to see if the fans are coming on when the engine is hot. The fans have two speeds and should come on in low speed and change to high speed as temperature gets hotter or when air conditioner is turned on. If they are working correctly. I would guess the radiator is partially plugged up between the air conditioner condensor and the radiator. These cars are bad about getting dirt, lint, and what ever trapped in this area.

Posted on Mar 01, 2009

  • 11 Answers

SOURCE: temp guage keeps pegging out to high side.....

listen u need to replace the water pump! if u have under drive pullys u need a high performance water pump wich a regular or high performance which u want one that is still pully driven dont get the all elictrial unless ur going a 1/4 mile at a time. go to jegs.com also burp ur system had the same problem not now

Posted on Apr 03, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Why does thermostat guage got to RED within 1 minute of turning over engine?


i would say the temp sender unit is earthing out , so could be the unit its self , not sure if you've changed the correct one , or a wiring fault ,

Jun 09, 2014 | 1999 Ford Mondeo

1 Answer

Overheating but not into the red


i have 2005 phaeton that is doing the same thing . i am going to change the temp sending unit and the coolant cap. hopefully that will fix it if not then i really don't know i am puzzled like you. i will post later if this fix mine or not.my car only act like it will over heat once you start it from cold in about 20 mints after that it runs fine for the rest of the day with no problems temp steady at 200 oil temp goes up and down but never past 220.so i think the engine is ok but still cant take a chance.

Jun 13, 2013 | 2004 Volkswagen Phaeton

3 Answers

What is the symbol with the stick with water under it mean on the Vw beetle dash


That is an over temperature indicator. It means your car is running hot.

Jun 05, 2011 | 2000 Volkswagen Beetle

1 Answer

The coolant is low, I refilled it. I replaced the thermostat. The heat gauge goes all the way to high when I am driving fast, but at idle it cools down to the temperature it should be. I stop at a red...


first thing i think is that when you changed the thermostat you didnt get all that air bubbles out of the cooling system. 2nd yes it would be the water pump. really simple as long as you havent overheated it head gasket would be fine

Jan 20, 2011 | 1999 Ford Escort

1 Answer

The temperature gauge goes to the High and basically makes like a dinging sound, then it goes back down almost immediately. The car has not overheated but does make a gurgling sound when we shut the car...


before you think the thermostat is bad, first look in the fuse/relay box. lift the lid and look inside the lid for the correct location for the cooling fan fuse/relay. also if that is ok then unplug the cooling fan and use jumper wires to jump from the fan to the battery. if the fan runs then the relay maybe bad or the coolant temperature sensor may be going bad. rule of thumb if the car has run for awhile and got hot u can touch the upper radiator hose, if its hot then the water is circulating. if the upper hose feels cold then the thermostat is stuck open. replace the thermostat.

Apr 21, 2010 | 2005 Dodge Neon

1 Answer

Thermosat goes from cold to warm back to cold


That thermostat needs to be replaced immediately before it blows up. This might cause some other worst effect to your car.

Take good care next time dear.

Jan 08, 2010 | 1999 Chevrolet Lumina

3 Answers

Temp gauge up and down


It is IMPORTANT That you Correct This ,as Engine Temp is Important. I Recomend the Coolant Temperture Sensor Be Replaced to Correct this.

Sep 11, 2009 | 2003 Dodge Stratus

1 Answer

Replaced thermostat - still getting red light


sounds like a faulty sender unit not passing the right voltage which is causing the gauge to read high

May 30, 2009 | 2001 Oldsmobile Intrigue

1 Answer

Blows ice cold air out of deforst


Will not be the thermostat. Most likely you are low on antifreeze (coolant). This may be caused by a leak in the head gasket or manifold. If so major problem. Check your oil to see if there is water getting into the engine. It will appear as white milky substance. If so fix immediately or lose the engine.
The other problem may be the water pump has failed. If you look at the engine you may see a lot of water (coolant) on the left side of the engine which is where the water pump is located. ( left side if you are looking into the engine compartment) If it is the waterpump you are looking at app. $200-$250 parts and labour taxes in Canadian.
I had the same problem mine was the waterpump.
*************************************WARNING*****************************************
Do not let the engine go into the red. If you do you are in danger of warping the head and then bigger problems

Nov 19, 2008 | 2003 Chevrolet Venture Passanger

Not finding what you are looking for?
1999 Ford Mondeo Logo

Related Topics:

19 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

76630 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22219 Answers

fordexpert

Level 3 Expert

5537 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...