Question about 2001 Chevrolet Express

1 Answer

2004 chevy express looses power dramaticaly on hils and has poor accleration. runs fine down hill. 175000 miles with a slight rattling on acceleration

Posted by on

  • jaybyrdn91 May 11, 2010

    Have you tried cleaning the Mass Airflow Sensor?

×

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Sniper:

    An expert who has posted more than 50 answers, of which 90% or more were rated as helpful.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

  • Expert
  • 84 Answers

Fuel supply issue or restricted exhaust? Step on throttle while someone feels amount of pressure out of tailpipe.

Posted on Jun 22, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
A 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
The service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Good luck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a 1/2 ton chevy pickup 350 carburated


Sounds like the fuel filter needs changed. Depending on your crab It is between the pump and carb, or in the carb where the fuel line goes in.

Aug 31, 2014 | Cars & Trucks

1 Answer

2004 Endeavor stalling at light


USUALLY AT 100 K CAR NEEDS TO REPLACE THE TIMING BELT
BETTER HAVE IT CHECKED B4 IT SUCKS YOU POCKET

Aug 30, 2012 | 2004 Mitsubishi Endeavor

1 Answer

Why is there a rattling noise when i mash the gad in my 1995 nissan maxima?


Your cataylic conveter is likely on the way out They rattle before they plug up . It may take 6 month or a year before it dose but it sounds like its going .However it also could also be a loose heat sheild on it so get under it and look look for anything loose that could rattle and even if it is the cataylic conveter you still have some time before it goes

Apr 19, 2012 | 1995 Nissan Maxima

1 Answer

I have a 2004 Buick Rendezvous,lately when I go uphill I loose engine power, I tried changing the oil and I took it for a terst drive, gave me no problems then an hour later I started going up hill again...


The oil change would have done nothing other than helping the engine last longer, but the poor running you describe sounds like a fuel problem. You do not mention any check engine light, but if the engine computer is scanned it might reveal a pending code since it ran poorly-that would provide a clue. Short of a pending code though, I'd check the fuel pump pressure and if you haven't replaced the fuel filter, do that too.

May 30, 2011 | 2004 Buick Rendezvous

1 Answer

Loud instant 2-3 second rattle around the under


Check all braces under your car. Not just visually, put hands on each and every brace. Sounds like one might be loose or broken. Hope it's as easy a fix as mine was.

May 03, 2017 | 2004 Ford F150

3 Answers

TRUCK SHUDDERS WHILE CRUISING 40-45MPH 2004 SILVERADO 120,00 MILES WHATS UP???


Most likely slight engine miss when engine is in overdrive on slight accel or load like small hills. replace plugs & wires & happy driving

Sep 12, 2009 | 2004 Chevrolet Silverado 1500 Crew Cab

1 Answer

My car is at a lost for power going up hills


Have you ignition timing checked. It seems you have a retarted ignition timing.

May 29, 2009 | 1989 Toyota Corolla 2 Door

1 Answer

Rattling nosie from engine


I would say that you have run it out of anti freeze and done internal damage to the motor by the sound of it.

May 11, 2009 | 2004 Chevrolet Silverado

4 Answers

Loosing power


Wow, I just went through the same problem and guess what it was a clogged converter and a bad oxyegen sensor. The garaged fixed it up for me by putting an eco converter on it and a new O2 sensor. I have a 2003 Chevy Impala,V6 3.8 engine. Good Luck!!!!

Aug 18, 2008 | 2003 Chevrolet Impala

Not finding what you are looking for?
2001 Chevrolet Express Logo

Related Topics:

244 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

78267 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22326 Answers

Ronny Bennett Sr.
Ronny Bennett Sr.

Level 3 Expert

6927 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...