Question about 2003 Ford Expedition

Open Question

2003 ford expedition cuts off while driving - 2003 Ford Expedition

Posted by Anonymous on

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 5 Answers

SOURCE: 2003 Ford Expedition radio will not work

whats the radio serial number

Posted on Jul 03, 2008

  • 2 Answers

SOURCE: 2003 ford expedition

P0300 Random/Multiple Cylinder Misfire Detected
See all 300-series codes here: http://www.ford-trucks.com/article/idx/7/241/article/Ford_OBDII_Diagnostic_Trouble_Codes__P0300P0399__Ignition_System_or_Misfire.html

Posted on Dec 23, 2008

co7196
  • 3433 Answers

SOURCE: My 2003 Ford Expedition continues to sputter, miss

MAF SENSOR NEEDS CK AND OR REPLACE. 1ST SENSOR COMING OUT OF AIR FILTER

Posted on Jun 14, 2009

  • 34 Answers

SOURCE: 2003 Ford Expedition, low idle, no power while driving.

sounds like water in gas. add gas line antifreeze. 2 bottleshould do it.

Posted on Oct 27, 2009

  • 310 Answers

SOURCE: how to change the hub on a 2003 ford expedition 2

you need a hub asembly

Posted on Jan 27, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

Where is the gas filter on 2003 ford expedition


if it is not on the frame in the back it is in the tank

Jul 12, 2015 | 2003 Ford Expedition

1 Answer

My 2003 ford expedition drives fine, until it warms up, after it warms up, it cuts off in drive. But stay running in reverse, what's wrong? Somebody told me it could be my torque converter might be locking...


have you checked your tranny levels
if the oil is low when it warms up the torque converter will slip
but as soon as you put it in reverse there will be enough oil in the finns to move you backwards .

Mar 23, 2015 | 2003 Ford Expedition

1 Answer

My 2003 Ford expedition cuts off while drivin ... But I can start it back up


Have u put it in Park and press and hold accelerator to see if it still cuts off. How long of a drive before it cuts off

Aug 30, 2014 | 2003 Ford Expedition

1 Answer

WhAT MAKES FORD 2003 EXPEDITION SHUT OFF AND SMOKE FROM FUSE PANEL


TUrn off your vehicle; first I suggest check in the fuse panel what fuse is causing this problem, if the fuses ar ok, then you will need to take off the entire fuse panel to check harnesses connections and wires attached there.

Keep in mind that, if you stay driving or testing in a ON condition, cpould damage other components, systems or devices.

Hope this helps.

Feb 07, 2012 | 2003 Ford Expedition

1 Answer

MY 2003 EXPEDITION SEEMS TO RUN FINE WHILE DRIVING IT BUT IF I STOP IT CUTS OFF, IF THE TRUCK IS IN PARK IDLING IT SOUNDS LIKE IT IS SKIPPING.


Inside the distributor....change the module ...will solve your problem ..usually two screws to make it come out ,the wires that lead to the distributor ...the module is attached to it ...

Jan 01, 2010 | 2003 Ford Expedition

1 Answer

2003 Ford Expedition, low idle, no power while driving.


sounds like water in gas. add gas line antifreeze. 2 bottleshould do it.

Oct 26, 2009 | 2003 Ford Expedition

1 Answer

My 2003 Ford Expedition continues to sputter, miss


MAF SENSOR NEEDS CK AND OR REPLACE. 1ST SENSOR COMING OUT OF AIR FILTER

Jun 14, 2009 | 2003 Ford Expedition

1 Answer

2003 Expedition jerking/cutting out.


Had same problem: cutting out at low rpm, jerking, a huge clunk or shudder at higher speed (like transmission was going out), and rough idle. All these symptoms were intermittent.

CHECK THE FUEL FILTER!! Changed the fuel filter and thing runs fine!!

PS mine 2003 expedition has 105k

Nov 07, 2008 | 2003 Ford Expedition

Not finding what you are looking for?
2003 Ford Expedition Logo

Related Topics:

11 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

75077 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

fordexpert

Level 3 Expert

5471 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...