Question about 2000 Ford Ranger SuperCab

1 Answer

Could a map sensor cause lack of power under acceleration on a 2001 chevy impala with a 3.4 engine

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that hasĀ over 10 points.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 7 Answers

Yes, but it's not the only culprit.

Posted on Apr 13, 2014

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

RAV 4 2001 MODEL Noticed that when driving on fast lane and have to slow down then pick up acceleration again car does not immediately respond and is slow. Eventually picks up acceleration. Help!


This problem is often caused by a failed MAP sensor. Is your engine light on? If yes, have the computer scanned. If the scan indicates a fault with the MAP sensor, replace the sensor. If not or not engine light, you can run some tests on the sensor using a volt/ohmmeter.
Here is a procedure I found at autozone.com:

Manifold Absolute Pressure Sensor

Fig. MAP Sensor power input testing-2.0L (3S-FE) VIN P
  • Turn the ignition switch to LOCK.
  • Reconnect the MAP sensor connector.
  • Turn the ignition switch ON.
  • Disconnect the vacuum hose on the air intake chamber
  • Connect a voltmeter to terminals PIM and E2 of the ECM, and measure the output voltage under ambient atmospheric pressure.


    Fig. MAP Sensor power output testing-2.0L (3S-FE) VIN P
  • Apply vacuum to the MAP sensor in 13.3 kPa (100 mmHg, 3.94 in.Hg) segments to 66.7 kPa (500 mmHg, 19.69 in.Hg). (my personal note here: you can just leave the vacuum line connected to the engine and start the engine to apply vacuum.)
  • Measure the voltage drop from step above for each segment.
  • If operation is not as specified, replace the MAP sensor.
  • Reconnect the vacuum hose to the air intake chamber.


    Fig. Vacuum/voltage table-2.0L (3S-FE) VIN P

  • 0996b43f802047b9-ki3dkuhcuzq12lfcumwzb1n3-4-0.gif

    0996b43f8020481f-ki3dkuhcuzq12lfcumwzb1n3-4-2.gif

    0996b43f8020481e-ki3dkuhcuzq12lfcumwzb1n3-4-5.gif

    0996b43f80204821-ki3dkuhcuzq12lfcumwzb1n3-4-9.gif

    Jun 17, 2017 | Cars & Trucks

    1 Answer

    No power under acceleration 2001 chevy impala,ive added injector cleaner , cleaned maf,also checked cat ,seemed good, also replaced map sensor


    well it is a chevy, its always had that problem. Haha, just kidding. But, seriously, it can be something as simple as a clogged air filter. I did all that you did on a car I had, and then, I replaced the air filter that I thought was good (reusable K&N) and it ended up being that. Try the air filter. Either replace, or clean it.

    Apr 14, 2014 | 2001 Chevrolet Impala

    1 Answer

    I did try unhooking the egr valve tube to see if relieving pressure that way would make a difference , but it still had lack of powerupon acceleration in my 2001 chevy impala


    that hole is not big enough to relieve the back pressure if your catalytic convertor is restricted.the best way to tell is by using a backpressure gauge installed where the front oxygen sensor is located.pressure should be under 1-2 psi under heavy acceleration.The front oxygen sensor is in the exhaust manifold on the back side of the engine.

    Apr 13, 2014 | 2001 Chevrolet Impala

    1 Answer

    My chevy impala lacks power and acts very bad sluggish while accelerating


    Any check engine/service engine soon light? Could be a clogged catalytic convertor, search for cleaning a catalytic convertor. Try cleaning the mass air flow sensor, it is before the throttle plate. If you are losing coolant, your engine is prone to this, it could be leaking intake gaskets.

    Dec 21, 2013 | 2001 Chevrolet Impala

    1 Answer

    Does a 2001 chevy impala come with a map sensor or just a mass air flow sensor ?


    They have both. If you have a 3.1/3.4L, the map sensor is located at the rear of the engine compartment directly beside the ignition coils. If you have a 3.8L, I believe it is located at the front of the engine (right side of engine bay).

    Feb 07, 2013 | 2001 Chevrolet Impala

    1 Answer

    Mazda 323 bj not exccelerating


    ENGINE HESITATES WHILE ACCELERATION

    LOSS OF ACCELERATION


    It can be fuel pressure issue or it's the problem with accelerator pedal or its clogged filters causing there.

    There are many other possibilities. I suggest you to go through the list of help links mentioned below, these will help you to confirm where the actual fault lies: -------

    Jerks and Hesitates During Acceleration?

    http://technoanswers.blogspot.in/2012/07/2004-dodge-town-country-jerks-and.html

    -----------

    Loss of acceleration?

    http://technoanswers.blogspot.in/2012/02/loss-of-acceleration.html

    ---------

    Headlights flickering and car hesitates to start?

    http://howtobyme.blogspot.in/2012/02/headlights-flickering-and-car-hesitates.html

    --------

    How exactly the Vehicles Accelerator Cable works?

    http://repairhelpcenter.blogspot.com/2011/11/how-exactly-vehicles-accelerator-cable.html

    -------------

    How exactly Vehicles Accelerator Pump Diaphragm Works?

    http://repairhelpcenter.blogspot.com/2011/11/how-exactly-vehicles-accelerator-pump.html

    --------

    2000 Toyota Avalon: Engine Lean Codes and Knock Sound on Acceleration?

    http://whatisbyme.blogspot.in/2012/05/2000-toyota-avalon-engine-lean-codes.html

    ---------

    2004 Toyota Avensis: Acceleration And Deceleration makes noise on Front End?

    http://whatisbyme.blogspot.in/2012/05/2004-toyota-avensis-acceleration-and.html

    ---------

    Wheel hop under hard acceleration?

    http://technoanswers.blogspot.in/2012/04/wheel-hop-under-hard-acceleration.html

    --------

    2009 Chevy impala accelerator pedal sensor?

    http://technoanswers.blogspot.in/2012/02/2009-chevy-impala-accelerator-pedal.html

    ---------

    Nissan Pathfinder stalls and bucks on Acceleration?

    http://technoanswers.blogspot.in/2012/02/nissan-pathfinder-stalls-and-bucks-on.html

    --------

    Acceleration lag problem?

    http://repairhelpcenter.blogspot.com/2012/01/acceleration-lag-problem.html

    -------------

    These details will help.

    Thanks.

    Dec 31, 2012 | Mazda 323 Cars & Trucks

    3 Answers

    When maintaining speed of about 50mph,2004 pacifica hesitates and will cut off while in park sometimes.check engine light is not on


    ENGINE HESITATES WHILE ACCELERATION

    LOSS OF ACCELERATION


    It can be fuel pressure issue or it's the problem with accelerator pedal or its clogged filters causing there.

    There are many other possibilities. I suggest you to go through the list of help links mentioned below, these will help you to confirm where the actual fault lies: -------

    Jerks and Hesitates During Acceleration?

    http://technoanswers.blogspot.in/2012/07/2004-dodge-town-country-jerks-and.html

    -----------

    Loss of acceleration?

    http://technoanswers.blogspot.in/2012/02/loss-of-acceleration.html

    ---------

    Headlights flickering and car hesitates to start?

    http://howtobyme.blogspot.in/2012/02/headlights-flickering-and-car-hesitates.html

    --------

    How exactly the Vehicles Accelerator Cable works?

    http://repairhelpcenter.blogspot.com/2011/11/how-exactly-vehicles-accelerator-cable.html

    -------------

    How exactly Vehicles Accelerator Pump Diaphragm Works?

    http://repairhelpcenter.blogspot.com/2011/11/how-exactly-vehicles-accelerator-pump.html

    --------

    2000 Toyota Avalon: Engine Lean Codes and Knock Sound on Acceleration?

    http://whatisbyme.blogspot.in/2012/05/2000-toyota-avalon-engine-lean-codes.html

    ---------

    2004 Toyota Avensis: Acceleration And Deceleration makes noise on Front End?

    http://whatisbyme.blogspot.in/2012/05/2004-toyota-avensis-acceleration-and.html

    ---------

    Wheel hop under hard acceleration?

    http://technoanswers.blogspot.in/2012/04/wheel-hop-under-hard-acceleration.html

    --------

    2009 Chevy impala accelerator pedal sensor?

    http://technoanswers.blogspot.in/2012/02/2009-chevy-impala-accelerator-pedal.html

    ---------

    Nissan Pathfinder stalls and bucks on Acceleration?

    http://technoanswers.blogspot.in/2012/02/nissan-pathfinder-stalls-and-bucks-on.html

    --------

    Acceleration lag problem?

    http://repairhelpcenter.blogspot.com/2012/01/acceleration-lag-problem.html

    -------------

    These details will help.

    Thanks.

    Nov 28, 2012 | Chrysler Pacifica Cars & Trucks

    1 Answer

    2001 Chevy Impala


    If you have done this already,then bleed the cooling system,this is all you lack,just get the air out of the system,two bleed ports,one on the thermostat housing,and one on the engine near the water pump,just bleed them out as the car warms up,the thermostat bleeder last,if this was at all helpful,please rate,thank you.

    Jul 04, 2010 | 2001 Chevrolet Impala

    2 Answers

    2003 Impala with 3.8L engine idles OK, but looses power when accelerating. Also fails to shift properly. No vacuum leaks (plenty of neg pressue). Disconnecting MAP sensor (unplugging wire) has no effect on...


    Sounds like its not getting enough fuel there should be a inline fuel filter given what you said when you try to accelerate. dissconecting map sensor is what you disconect when you set timming it wouldn`t have had any affect.

    Jan 02, 2010 | 2003 Chevrolet Impala

    Not finding what you are looking for?
    2000 Ford Ranger SuperCab Logo

    53 people viewed this question

    Ask a Question

    Usually answered in minutes!

    Top Ford Experts

    yadayada
    yadayada

    Level 3 Expert

    75822 Answers

    Colin Stickland
    Colin Stickland

    Level 3 Expert

    22156 Answers

    fordexpert

    Level 3 Expert

    5501 Answers

    Are you a Ford Expert? Answer questions, earn points and help others

    Answer questions

    Manuals & User Guides

    Loading...