Question about 1990 Chevrolet Lumina

2 Answers

At Idle Runs Fine, 50% throttle runs like ****

1990 Chevrolet Lumina 3.1L Euro 134000 miles. When started and idling car runs fine when you drive for short distances it still runs fine, But when you throttle into it as if to accelerate onto the freeway car bogs and while foot is on throttle it intermittently goes and bogs goes and bogs goes and bogs etc, and continues to do so until shut off and left alone for a while, its not as if its overheating because it does so even if driving a block then back. I Have checked all vaccum lines, changed fuel filter, cat was replaced 15000 miles ago, plugs and wires within 10000 miles, Fuel Filter within 20000, someone mentioned possible egr issue? THANK YOU VERY MUCH FOR YOUR TIME

Posted by on

Ad

2 Answers

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 462 Answers

I WOULD HAVE THE FUEL PRESSURE TESTED. SOUNDS TO ME LIKE THE PUMP CANT KEEP UP WITH THE DEMAND.

ALSO CHECK THE INSIDE OF THE THROTTLE BODY FOR A CARBON PLUG WHERE THE EGR PORT ENTERS THE INTAKE MANIFOLD.

Posted on Jun 18, 2009

Ad
  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Master
  • 957 Answers

It could be a lot of things, if you can run some component testing. You should be able to narrow it down. Test the TP, EGR, IAC sensor, Look, does the car act up at high throttle while in neutral or just when its in gear? You may want to check the timing and look inside the distributor for any signs of water, rust, or carbon build-up.

Posted on Jun 18, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

1993 Chevrolet Lumina APV hesitates and dies when in gear


When it stops running and will not start back up, you'll need to figure out if you are lacking spark or fuel pressure to proceed with testing.

May 12, 2013 | 1993 Chevrolet Lumina APV

1 Answer

What problems are caused by a bad crank sensor or ignition control module on a 96 lumina?


Try the throttle position sensor, or the idle air control valve. If crank sensor is bad it won't start at all. Does it have the check engine light on? What are the codes???

Oct 13, 2017 | Chevrolet Lumina Cars & Trucks

1 Answer

I have a 1990 chevy lumina euro that has a high idle when started and tends to die when coming to a complete stop. What could this problem be?


have you disconected or changed the battery lately- the idle needs to be reset.
my 89 regal had to be started cold -put in drive with your foot on the brake - then wait untill radiator fan turns on (open the hood first to be able to hear the electric fan kick on :)
this somehow set the warm idle speed and the problem was gone :)

Mar 04, 2011 | 1990 Chevrolet Lumina

1 Answer

1992 Lumina Backfire - I have a 1992 Lumina Euro, 77K miles, 3.1 V-6. Under moderate to hard acceleration the engine will backfire and you can smell gas. The spark control module, coils, wires, plugs,...


I know you mentioned the EGR valve has been replaced, but you may have a bad 'new' part. I know the car is electronic, but has anyone checked its ignition timing (timing belt been looked at, I know it only has 77k on it). Is the fuel pressure regulator OK and it vacumm supply?

Nov 15, 2010 | Chevrolet Lumina APV Cars & Trucks

2 Answers

1990 chevy lumina apv - pickup coil -runs ok 15 mi & stalls


I'm assuming you have the distributor out? You will need to, as the shaft has a gear on the bottom end that has a roll pin. Make sure ALL is marked so that you re-assemble it the same way. You also need to mark the rotor position, and the base of the distributor so you can put it back where it was, or you will have to re-align and time everything!

Jul 10, 2009 | 1990 Chevrolet Lumina APV

1 Answer

1990 Sierra, runs fine then just dies and will not start till pri


Did you change the fuel presure regulator located in the throttle body?

Nov 01, 2017 | 1990 GMC Sierra

1 Answer

Starts fine, Idles fine, Drives Fine for a while


you might want to chk. the crank sensor and or cam sensor. sounds more to me that it could be fuel problem. chk. fuel pressure. pump could be on its way out. don't be fooled by hearing the pump running as they sound like they are pumping but there not, at least not enought pressure to keep it running. pressure should be around 50 p.s.i.

Jan 06, 2009 | 1990 Buick Century

1 Answer

Corvette 1990 5.7L Slow Idle Automatic


i had almost the same problem i changed my fuel pump and fuel filter and it worked u mite try that first.

Jun 25, 2008 | 1990 Chevrolet Corvette

Not finding what you are looking for?
1990 Chevrolet Lumina Logo

242 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

Marvin
Marvin

Level 3 Expert

81424 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22359 Answers

Ronny Bennett Sr.
Ronny Bennett Sr.

Level 3 Expert

6927 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...