Question about 2003 Isuzu Rodeo

2 Answers

Holden rodeo 2003, wont rev over 3000rpm

Wont rev over 3000rpm, starts fine, idles fine as soon as i touch the accelerator, the engine light comes on. engine light turns off if the engine is turned off

Posted by on

Ad

2 Answers

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

I have a 06 rodeo, today when i started the engine it stopped right away, it restarted but would nod rev over 3000 (limp home mode) no warning lights were on ,when i got home i disconnected the battery earth cable for 30 seconds , reconnected it and the problem has gone, the same cure for when the electric windows stop working but for this fault disconnect the battery for 2 days, it works, try it before you take it to the garage.

Posted on Aug 05, 2014

Ad
  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Master:

    An expert who has achieved Level 3.

  • Isuzu Master
  • 987 Answers

Run a scanner on the system to determine codes to diagnos problem

Posted on Apr 13, 2014

Ad

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

ginko
  • 19396 Answers

SOURCE: Fast Idle Problem With 99 Isuzu Rodeo V6

Hi.

If problem is only on startup and when idleing, then the problem is likely IAC system, also a vacuum leak will cause the same problem.

If problem is not only on startup and idle, but also when driving, then MAP sensor and EGR system must be checked.

Check also accelerator cable state and setting.


0f04b3c.jpg

The first thing to do is pulling out the OBDII fault codes stored in the ECM. This is done connecting a code reader to the ECM diagnostic port. The job can be done for a small fee at any local garage, and it is done for free at AutoZone.

The codes will help locating the problem.

About possible faults:

Problem is stalling when idling and during startup, but engine idling fast all the time. Problem not starting at times it is due to the fact that the wrong mixture is being sprayed, this is probably causing flooding and misfire. Since the CEL is on, one of the codes returned is probably misfire.

Check accelerator.

Check IAC system. This is composed by a valve and a solenoid that check and control amount of extra air air when the engine is idling. The IAC valve is located on top of the throttle body.

Check the vacuum system and try cranking with gas tank cap off. Vacuum system is tested using an hand tool gauge onvacuum lines while spraying card cleaner on the hoses (or heating them with a torch). If there is a leak, pressure will go up. A big leak will also do hissing noise, and will often result in a lean code when doing an OBD code scanning.

This kind of symptoms can also be caused by weak wiring to MAP/MAF sensor (MAP in this engine).

If the car also drives very rough and is revving up and down in a weird way, check the EGR valve.

As first thing I would do a code scanning. This car is OBDII. The scan can be done for free at the nearest Autozone, or for a small fee at any garage.

If you get any OBDII code from the scan, report it here, so that we can individuate the possible reason for the problem.

If you repute my solution helpful, then please take some times to accept the solution. Providing good repair tips requires time and skills, and your feedback is important for us.

Regards.

Ginko.

Posted on Oct 26, 2010

snownbird33
  • 120 Answers

SOURCE: Holden 94 rodeo petrol

Good Day
Vale clearance cold
intake .006 in (.15 mm)
exhaust .010 in (.25 mm)

Timing
1. With transmission in Neutral or park, start engine and warm to normal operating temp. turn eng,and all accessories off. connect Tachometer. Connect timing light to no 1 spark plug wire.

2. Disconnect and plug fuel vapor canister purge hose and EGR vacuum hose. Start and ensure idle is 900 RPM. adjust idle as required. Check ignition timing ( 12 @ 900)

3. If adjustment is required, loosen distributor hold down bolt and turn until timing is within specification. Tighten distributor hold down bolt and recheck timing. adjust idle speed as required.

hope this helps

Cheers

Posted on Sep 30, 2008

  • 396 Answers

SOURCE: 2001 Isuzu Rodeo Check Engine Light flashes when accelerating.

I would change the trans flter, trans fluid, and have the linkage on the trans adjusted.

Posted on Jul 21, 2009

  • 1 Answer

SOURCE: holden rodeo turbo diesel 2007

I KNOW SOMEONE WITH EXACT PROBLEM.
CONTACT ME ON 0400432502 U CAN SHARE YOUR INFOS.
TA21

Posted on May 07, 2009

  • 881 Answers

SOURCE: Unleaded Fuel in a Diesel Engine

THERE is 2 ways to do it 1 take the tank out and drain it OR get a small 12volt pump as they fitted to a lot of English cars (Morris Minor Jag ) etc and fit a small fuel pipe 3/16" to both in let and out let and put the one with arrow to tank into tank and other end to a fuel drum (about same size as tank)and plug into 12v battery and let tank pump dry,

When you refill tank with Diesel add 1 ltr of petrol to full tank of Diesel it starts and runs 30% better.

If your dad tried to start it on petrol then undo INJECTOR pipes and spin over till Diesel comes out before you tighten injectors feed and starting engine.

Posted on Sep 21, 2009

Testimonial: "Quite helpful, think we might take the tank completly out, but whats the easiest way?"

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Holden rodeo is idling very high


Spray aero start around manifold while idleing. if revs pick up there is a leak. repair the leak

Oct 03, 2012 | Holden Rodeo Cars & Trucks

1 Answer

Rodeo petrol starts but wont rev


Holden Rodeo 1989 2.6mpi , start and only runs for 2 or so seconds themselves stalls, after putting on a fuel peesure gauge, fuel looked okay and slowly dropping, found the ECM relay was intermittently switching on and off, gave it a tap and the engine kept on running, relay not repairable, replace with new part. Located in the fuse and relay box on the right hand side of engine bay next to battery. Hope this helps.

May 24, 2012 | Holden Rodeo Cars & Trucks

1 Answer

What is the ignition timing settings for 1992 rodeo 2.6mpi


hi have holden 2.6lt isuzi engine system is engine wont idle wont rev correctly has flat spots and lens out check light doesnt come on checked fuel pressure engine was running rough found blown head gasket changed when i done the valve timing with the dowl pin at twelve oclock no four valves where closed not rocking which doesnt gel with the specs thought head must be off a later model engine not sure if the valve degrees might be different than my original head this motor i bought from a wrecker im thinking there might be some differences in the degrees causing the fuel and ignition timing to be slightly different can you throw any light on this problem please as its doingmy head in

Apr 03, 2012 | Holden Cars & Trucks

1 Answer

Hi iv lost power on my a4 1.9 tdi. I start the engine and it idles fine. Then soon as i touch the accelerator pedal a light starts to flash on the dash and also the epc light comes on. At this point the...


i think the computer chip in your key is bad or going bad.
You might have to replace the battery in the key or the chip depending what you have

Dec 04, 2010 | 2002 Audi A4

1 Answer

Lincoln started to miss and the check engine light came on . The car will not accelerate in neutral


It is designed to cut out around 3000rpm in park, so you don't over rev it.

Jun 18, 2009 | 2003 Lincoln LS

3 Answers

1998 Rodeo TF Series 2WD 5-speed manual


vacuum leak......bad tps.......bad mass airflow meter system........any of those are suspect...... also check for bad ground at battery to be sure all is not computer freak out from bad readings ...good luck

Oct 24, 2008 | 1998 Isuzu Rodeo

1 Answer

1998 Holden Rodeo TR series 5-speed manual 2WD


run the fault codes
look for ambient temp sensor or baro sensor problems

Jun 30, 2017 | 1992 Isuzu Rodeo

Not finding what you are looking for?
2003 Isuzu Rodeo Logo

974 people viewed this question

Ask a Question

Usually answered in minutes!

Top Isuzu Experts

yadayada
yadayada

Level 3 Expert

76691 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22219 Answers

Thomas Perkins
Thomas Perkins

Level 3 Expert

14381 Answers

Are you an Isuzu Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...