Question about 2003 Chevrolet Monte Carlo

1 Answer

Acceleration problem I am also having a similar problem (started today). From dead stop or while accelerating, it revs and slow response. When I take my foot off gas and reapply, I get some acceleration, however, not what it should be. I was just at dealership on Monday of this week for latest safetly recall, no issues prior to. I also filled up with gas today, thought I might have filled with bad batch of gasoline...

Posted by on

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 2 Answers

Brought to dealership and they replaced catalytic converter.

Posted on Jun 20, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Vs commodore lossing revs under quick accelaration. Not spark plugs, not leads, not coil pack, not engine computer and not fuel system because it happens on both gas and fuel


there is no mention of a fault code reading ( very important as you will see)
you have covered everything and in doing so are overlooking logic
you have a dead spot on acceleration so by looking at possible areas of concern , there are 5 not mentioned
One is the accelerator position sensor
Quick acceleration may be causing a problem in that unit but the quick movement
next is the throttle control position sensor Problems there can be from faulty voltage from the APP , wiring or even a sticky throttle e action
Next is the ECM or a section of the ECM
The ECM controls the fuel/gas to the engine and you state that there is not a fuel/gas supply problem, the ECM gets its air /fuel ratio settings from the heated oxygen sensor in the exhaust manifolds before the cat converters, mass air flow sensors, volume air flow sensors, barometric sensor and ambient temp sensors
So logically if any of those sensors are not reporting in a timely period then the ECM becomes a bit confused and the dead spot will occur until it gets a second to recheck the parameters set in the CPU
Slow acceleration , is ok as the ECM is continually tuning to the throttle position but fast acceleration is throwing the system out
Lastly , in the Ignition control module there is an electronic advance / retard program that adjust the timing to exactly the correct rpm and throttle setting and if that unit has a fault , that is as if the timing is being retarded initially under the acceleration
another unit that has input into the ECM that reports on engine timing is the knock sensors that stop detonation ( pinging)under heavy acceleration by reporting the engine noise to the ECM which adjusts , timing and air / fuel ratio to prevent engine damage from the detonation

Apr 29, 2018 | Cars & Trucks

1 Answer

2001 325i Car will Crank but not turn over. If I wait a couple days will turn over. I drove around today and began to lose power in acceleration. Puttering after coming to a stop. Accelerator slow in...


Sounds like a fuel delivery problem.
Check the fuel pressure at the fuel rail with a fuel pressure testing gauge to see if it meets spec.

Nov 02, 2013 | 2001 BMW 325

3 Answers

The car will run fine for about 10 minutes then it will stop accelerating???


ENGINE HESITATES WHILE ACCELERATION

LOSS OF ACCELERATION


It can be fuel pressure issue or it's the problem with accelerator pedal or its clogged filters causing there.

There are many other possibilities. I suggest you to go through the list of help links mentioned below, these will help you to confirm where the actual fault lies: -------

Jerks and Hesitates During Acceleration?

http://technoanswers.blogspot.in/2012/07/2004-dodge-town-country-jerks-and.html

-----------

Loss of acceleration?

http://technoanswers.blogspot.in/2012/02/loss-of-acceleration.html

---------

Headlights flickering and car hesitates to start?

http://howtobyme.blogspot.in/2012/02/headlights-flickering-and-car-hesitates.html

--------

How exactly the Vehicles Accelerator Cable works?

http://repairhelpcenter.blogspot.com/2011/11/how-exactly-vehicles-accelerator-cable.html

-------------

How exactly Vehicles Accelerator Pump Diaphragm Works?

http://repairhelpcenter.blogspot.com/2011/11/how-exactly-vehicles-accelerator-pump.html

--------

2000 Toyota Avalon: Engine Lean Codes and Knock Sound on Acceleration?

http://whatisbyme.blogspot.in/2012/05/2000-toyota-avalon-engine-lean-codes.html

---------

2004 Toyota Avensis: Acceleration And Deceleration makes noise on Front End?

http://whatisbyme.blogspot.in/2012/05/2004-toyota-avensis-acceleration-and.html

---------

Wheel hop under hard acceleration?

http://technoanswers.blogspot.in/2012/04/wheel-hop-under-hard-acceleration.html

--------

2009 Chevy impala accelerator pedal sensor?

http://technoanswers.blogspot.in/2012/02/2009-chevy-impala-accelerator-pedal.html

---------

Nissan Pathfinder stalls and bucks on Acceleration?

http://technoanswers.blogspot.in/2012/02/nissan-pathfinder-stalls-and-bucks-on.html

--------

Acceleration lag problem?

http://repairhelpcenter.blogspot.com/2012/01/acceleration-lag-problem.html

-------------

These details will help.

Thanks.

Nov 28, 2012 | 1999 Mercury Cougar

1 Answer

Slow acceleration from stop and when driving (trying to pass)


I have the same car. So far no problems with the Transmision. I had the Trans oil change out every 60 K Sure sounds like you need to get the Transmision checked. Is the fault light on. I have invested ina fault code reader sure is worth it. 
Good luck.  Vilmos

Feb 28, 2009 | 2001 Ford Focus

1 Answer

1998 Altima Acceleration Problems


i would say your problem is in the timing

Jan 24, 2009 | 1998 Nissan Altima

Not finding what you are looking for?
2003 Chevrolet Monte Carlo Logo

Related Topics:

207 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

Marvin
Marvin

Level 3 Expert

81400 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22326 Answers

Ronny Bennett Sr.
Ronny Bennett Sr.

Level 3 Expert

6927 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...