Question about 2002 Jeep Grand Cherokee

1 Answer

I have a 2002 Jeep Grand Cherokee 4.7, I have 3 different ECM's and they all are having the same issue. I am not getting ground from the ECM to the Map sensor.

New map sensor, new speed sensors(both)and wiring is good.

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Jeep Master
  • 20,706 Answers

On most PCMs the PCM passes ground (input to PCM) out to the sensors. so if that ground is bad all are.
this is done on purpose, so the PCM can measure ground errors
and adjust sensor readings accordingly.
now Ill look yours up. since you stated its a 4.7L , most poster here
have not a clue to what is under hood.
my guess is the map is reading wrong?????????????
HINT1: when measuring ground attach your DMM to the battery minus
post and it will read 0 to 0.5v max for ground.
what did you read, as you said its not GETTING ground.
so what was the reading? 12v?
i take it you work with FSM/s and its schematics.
see chapter 8w-30 (wiring , Fuel-------) page 16-18
http://www.jeep4x4center.com/knowledge-base/index.htm?utm_source=cj#service

see that page.? page 17 is best.
see the 3 pins?
PCM pin 4 is ground to MAP pin 1. 0volts
PCM pin 17 is 5vdc power supply to Map and most be 5v (+- .25v)
PCM pin 27 is map out sig to PCM, (baro measurements)


the PCM master grounds (input)
are C1 pin 31 and 32.
they must read 0v to battery minus. KEY ON. or running.

page 8w30-6 see that.

wish i had the full symptoms. , no start, runs bad. what?






Posted on Apr 13, 2014

Testimonial: "thanks for input,yes it does start by holding throttle to floor wont idle plugs foul fuel to rich ecm not getting map sensor input no single have power 5 volts ,but only if i ground to battery,or other ground source,Haynes book says + lead #1termonal&-lead#3 i get-3mlivolts thanks for your time and appreciate your help"

  • 41 more comments 
  • Troy Lehto
    Troy Lehto Apr 15, 2014

    I have a '93 GC with simiular problems. Turned out that the female pins expanded over time. You can replace the MAP sensor pin. Chrysler dosent make it for mine, but they have replacement pins.

  • _-__-___-_
    _-__-___-_ Apr 16, 2014

    Troy, he never posted the DTC or any volts yet on any pin, just general statemments that DONT HAVE voltage here, vague. Sure , any sensor with with a bad pin fails. but the voltmeter reading tell all that in 1min. flat. tell the readings, and not be vague. eg, pin orange is 1v... BAM. easy, huh? .

  • _-__-___-_
    _-__-___-_ Apr 16, 2014

    i see he is throwing parts. there is no reason to do that. 5min with a voltmeter and we find it. the map is very simple easy sensor, it just measure, the plenum air pressure (absolute) its and analog output, and varies with vacuum per the FSM tables. A BARO sensors it is.

  • cody hess
    cody hess Apr 26, 2014

    when checking spark at,put plug in coil and crank over as iam cranking i see spark getting weeker,how do i check to see if ASD is working properly

  • _-__-___-_
    _-__-___-_ Apr 26, 2014

    the ASD drops out for many reasons, but when you crank, the ASD closes. and stays closed for 2 seconds, IF all tests pass, (ECU logic) then the relay stays closed and engine runs, if the tests fail the ECU drops the ASD relay, in 2 seconds flat , this kills spark and injectors,

  • _-__-___-_
    _-__-___-_ Apr 26, 2014

    http://www.fixkick.com/Jeeps/ASD.html

  • _-__-___-_
    _-__-___-_ Apr 26, 2014

    Back to map, the cranking engine will produces 10 inches of vacuum cranking. at least. and the MAP output drops down to 3v crankiing (at least) if it does, the MAP is OK.

  • _-__-___-_
    _-__-___-_ Apr 26, 2014

    that weaker spark is a low battery, use the shop charger to keep it fully charged, or you will weak spark. The ASD kills spark , it kills spark for any time the PCM suspects weak or no spark ,preventing fuel fires. or hydralocking.

  • _-__-___-_
    _-__-___-_ Apr 26, 2014

    have you tried running the engine on test fuel>? spray can? why not do that.? what i do (after all its flooding) is I disconnec the fuel pump then try to run the engine on test fuel , if it dont run on test fuel, then fix THAT first. (hint, the map is useless , in this tests, only takes good spark and good engine to run on test fuel)

  • _-__-___-_
    _-__-___-_ Apr 26, 2014

    maybe we start at ground zero, day 1, no start? and that is , engine compression at spec, , then ASD ok. then spark is ok. and runs on test fuel? then whan that works we proceed to fueling . in that order, or we look like a dog chasing tail. fuel can not burn with bad spark or bad engines. fueling rates are LAST on the list ( as is MAP)

  • _-__-___-_
    _-__-___-_ Apr 26, 2014

    let me see if i can find you a short cut to this. step.

  • _-__-___-_
    _-__-___-_ Apr 26, 2014

    the fuel pump kill is tricky, on jeeps, first off there are 2 fuse 24s, silly huh? one is PDC other is in Cab JB. junction box. the pump runs off engine bay PDC fuse 24. the problem , is that some newer jeeps, kill spark if you pull the fuelpump relay, in fact some PCMs kill spark 2 ways, if the fuel pump relay fails in 2 ways, missing or out put dead. so.... we must dance with the fat crazy jeep engineer. no problem. pull fuse 24 in PDC. pump is now dead. the relay and 24 are in same PDC box. pull 24 and crank the motor dry, (make sure spark is good in this mode) now when engine not flooded, (it can not, pump dead, and is my goal) you then introduce test fuel . (spray 3 seconds, ) and crank. the engine must run, verroommmmmmmm 3 seconds and die.

  • _-__-___-_
    _-__-___-_ Apr 26, 2014

    http://www.youtube.com/watch?feature=pla...

  • _-__-___-_
    _-__-___-_ Apr 26, 2014

    any gas engine car can be run on test fuel, with the gas tank dry, bone dry, like the above video, or the fuel pump disconnected. all engines. this video is worst case my next video shows Mr. Scotty doing it like all mechs do.

  • _-__-___-_
    _-__-___-_ Apr 26, 2014

    http://www.youtube.com/watch?v=064Ilsz8F...

  • _-__-___-_
    _-__-___-_ Apr 26, 2014

    this simple tests proves to you, the engine is good, (viable) and that spark is good, you can hear run, then stall but sounds NORMAL and perfect. once we get past this, we attach fueling LAST !

  • _-__-___-_
    _-__-___-_ Apr 26, 2014

    he pulled the IAT sensor off the main intake pipe. to spray fuel

  • _-__-___-_
    _-__-___-_ Apr 26, 2014

    no smoking please.

  • _-__-___-_
    _-__-___-_ Apr 26, 2014

    keep and open mind, and do the tests in the correect order and you will save a fortune not guessing on parts. there is a test for each failure path.

  • _-__-___-_
    _-__-___-_ Apr 26, 2014

    edit, attach = attack.

  • _-__-___-_
    _-__-___-_ Apr 26, 2014

    please do ask lots of questions, we are pulling for you and car. for sure 100% and all the way to the end. Don't be shy , some problems can be hard, like flat cam lobe. (id not wish that on anyone)

  • cody hess
    cody hess Apr 26, 2014

    hey its me again,just checked map sensor with jeep running,have 5vdc at pin 1,have o vdc at pin 2,have 4.79 when idling,and 3.47 when giving throttle,then it starts going wacky,1sensor brand new other sensor used,both doing same,when jeep running,it runs rich and fouls plugs,when i checked spark,skark is good but as i contiue to crank it gets week, un hooked battery ground,and key imoblizer like said too ,and tryed other key reattached no difference. when checking codes fromm switch check engine light doesn't blinkand only code that appears is po700 for tranny

  • cody hess
    cody hess Apr 26, 2014

    i do have lifter taping on # 2 cylinder but goes away,checked cam lobe doesn't appear to be any different from others, could it be possible crank shaft sensor could be the problem

  • cody hess
    cody hess Apr 26, 2014

    i know u said do fuel tests,and i will, u stated good spark good battery, i have 12.43 and good charing,when i road test misses real bad at idle not as bad when driving but not much power it loads up

  • _-__-___-_
    _-__-___-_ Apr 26, 2014

    12.43 is bad, totally, ever seen an SOC table, if not in alaska , here is the table. 12.43 is 75% charge , 12.63 is 100% , so that is ok, but its not charged. unless ambient temps are well below 0 degrees F. -20C. , the scan tool reports even ONE misfire from 10 , of the CKP sensor, (crank) the PCM is real smar there, i trust it. let it tell you when it is bad. and for sure looking on the pending screen, of the OBD2 scan too. you do have one right?

  • _-__-___-_
    _-__-___-_ Apr 26, 2014

    loads up. on all cylinders or just one. (read spark tips for great clues, its old school but works 100%)

  • _-__-___-_
    _-__-___-_ Apr 26, 2014

    this forum does not show all post. what a shame, and i cant post your comments then comment. pain 2. ,have 5vdc at pin 1,have o vdc at pin 2,have 4.79 when idling,and 3.47 when giving throttle,then it starts going wacky,1sensor brand new other sensor used,both doing same,when jeep running,it runs rich and fouls plugs,when i checked spark,skark is good but as i contiue to crank it gets week, un hooked battery ground,and key imoblizer like said too ,and tryed other key reattached no difference. when checking codes fromm switch check engine light doesn't blinkand only code that appears is po700 for tranny

  • _-__-___-_
    _-__-___-_ Apr 26, 2014

    http://www.youtube.com/watch?v=vh3Z-F6KG...

  • _-__-___-_
    _-__-___-_ Apr 26, 2014

    see duane do vacuum. i can send you the paper , next.

  • _-__-___-_
    _-__-___-_ Apr 26, 2014

    in a shop,. we check compression, then vacuum if the vacuum is low on a hot 800 rpm engine we work that, (this is called Basics) we then check the vacuum for fluttering, (many cause but valves bad is most)

  • _-__-___-_
    _-__-___-_ Apr 26, 2014

    ill try this way, pin 1. your idle voltage wrong, do you have a vacuum gauge, attach it to the plenum , do you have 20 inches of vacuum at idle, your MAP SAY NO YOU DON"T ,pin to should read 1.5v at idle for the huge VACUUM, find out why. its NOT POWER or ground, id use a gage. vacuum most not bounce either. or the MAP will go nuts and the PCM 10x worse. That enigne pulls a steady hard vacuum at idle about 20inches, and tad less on very old tired engine, at 800 rpm, not 400. sure it will run rich 4v at idle tells the ECU the ENGINE IS WIDE OPEN THROTTLE ! that is DEAD WRONG, it is at IDLE with the butterfly throttle dead closed, and only ISC air supply, sure the spark gets weak, the starter sucks 200 Plus amps and weakens any battery fast. the ECU tries to help here, it uses a longer dwell time with low battery but its not 100% effective, its only help. this battery weak is a side show. very normal for engines that dont start or stall over and over. btw 2 the ASD drops if the crank sensor messes up. Keep in mind the MAP read the total vacuum all a cylinder sucking air. all at once, so if you burn an inake valve and vacuum goes low , the ECU adds fuel. ever see the paper that comes with all vacuum gages. telling you , the good , bad and the ugly?

  • _-__-___-_
    _-__-___-_ Apr 26, 2014

    watch Duane gauge carefully , that is a good engine. yours may not be, the PCM can not run engine that are bad, only weak and good. Not engines with extreme low vacuum or bouncing. leak valve, sticking valves, broken valve springs, jammed lifter. lots of things but all are bad valves in one way or other. (parts)

  • _-__-___-_
    _-__-___-_ Apr 26, 2014

    video 2

  • _-__-___-_
    _-__-___-_ Apr 26, 2014

    http://www.youtube.com/watch?v=NrnzD7Pgo...

  • _-__-___-_
    _-__-___-_ Apr 26, 2014

    here is the Paper most gauges come with, even the junky harbor fright $20 gage.

  • _-__-___-_
    _-__-___-_ Apr 26, 2014

    http://www.austincc.edu/wkibbe/vacuumtes...

  • _-__-___-_
    _-__-___-_ Apr 26, 2014

    the videos are way better, , this is first. part of basics, under good engine and tests to prove it it. (then spark then fueling) for all I know you have this massive air leak some where in the plenum.

  • _-__-___-_
    _-__-___-_ Apr 26, 2014

    for all I know, the MAP is telling the truth, both of them. in fact , id believe them. and use a real gauge.

  • _-__-___-_
    _-__-___-_ Apr 26, 2014

    if you had a real scan tool , you can plot the MAP output, and would see, its wrong, or see it going nuts. because vacuum is bouncing. the plot of the map would look like a kid on a pogostick.

  • _-__-___-_
    _-__-___-_ Apr 26, 2014

    your DC meter wil not show that. it will average that bouncing output pin and fool you . anyone.

  • _-__-___-_
    _-__-___-_ Apr 26, 2014

    whats nice about Duanes video is he actually breaks a valve to show what it looks like. best of best there.

  • cody hess
    cody hess Apr 27, 2014

    hey fossil its me again, i found the problem its a broken valve,wiring harness was bad also,hey really want to thank u for all your time and help,and support your the best,if there's anything u need help on drop a line,and again appreciate everything,thanks man.

  • _-__-___-_
    _-__-___-_ Apr 27, 2014

    your welcome , i hope its and easy fix.

×

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Get 1988 jeep cherokee out of 4 wheeldrive


one of your tires is probably lower than the other. for a blessed red than the other tires. causative to turn at different speeds. the easiest way to get it out is to raise the vehicle up so all 4 tires off the ground.

happens with me all the time in my 97 Grand Cherokee

Mar 07, 2015 | 1988 Jeep Cherokee

1 Answer

Trans over temp and over drive light comes on in 2002 jeep grand cherokee


I would want to know what the code is first. You may have to go to an independent garage for help. Auto parts stores can scan the ECM but not always the body computer.

Aug 30, 2012 | 2002 Jeep Grand Cherokee

1 Answer

2002 Jeep Grand Cherokee Limited P0846 code



Trouble Code: P0846

A/T 2/4 Pressure Switch Circuit Malfunction
Possible Causes:


2/4 pressure is incorrect, or internal transmission faults exist 2/4 pressure switch circuit is open, shorted to ground or power 2/4 pressure switch is damaged or it has failed TCM relay power circuit to L/R switch is open (loss of B+) PCM/TCM has failed

May 16, 2012 | 2000 Jeep Grand Cherokee

2 Answers

I have a jeep grand cherokee i have a code p1296. voltage missing at throttle position sensor.explanation engine running and the ecm detected map sensor voltage less than expected. probable cause open or...


I would change the TPS throttle position sensor and the Map/MAF are you sure its not the mass air flow?. I think your computer is fine it could be have a loose ground issues but computers dont go bad.

Sep 12, 2011 | 1997 Jeep Grand Cherokee

1 Answer

2002 Jeep Grand Cherokee handbrake indicator light on dash does not work. How do I troubleshoot this and repair this?


easy check the switch at the base of the handle it simply grounds the wire to the light bulb when handle is oicked up.so get to the switch and ground the wire. if light comes on then clean/adjust/or replace switch

Mar 23, 2010 | 2002 Jeep Grand Cherokee

1 Answer

2002 jeep grand laredo blower sw not working


Have you checked the ground side of the switch?

Oct 14, 2009 | 2002 Jeep Grand Cherokee

1 Answer

My rear lights and brake lights do not work. Turn,


well first check all fuse make sure builbs are good this jeep has bcm on the back fuse panel they are very commen to have issue you can try to see if local shop can reprogram this or it may be bad hope this helps

Sep 28, 2009 | 2002 Jeep Grand Cherokee

2 Answers

Replaced TPS sensor 4 times in 3 months, still runs like s.......


I would let your dealer look at it. There may be somthing wrong with wiring harness for the TPS. Bad Ground? The ECM may be going out as well. I remember 1997-99 had a similar issue.

Aug 28, 2009 | 2001 Jeep Grand Cherokee

Not finding what you are looking for?
2002 Jeep Grand Cherokee Logo

Related Topics:

198 people viewed this question

Ask a Question

Usually answered in minutes!

Top Jeep Experts

yadayada
yadayada

Level 3 Expert

75822 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Kevin Daniels

Level 3 Expert

1455 Answers

Are you a Jeep Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...