Question about 2005 Chevrolet TrailBlazer

1 Answer

Replaced battery and now SUV skips?

We changed a dead battery out today and now it acts like it's skipping. Unhooked the cables to see if the computor would reset, but it still acts like its skipping. It will drive down the road???????

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 52 Answers

When you replaced the battery, you erased the computer memory. Drive it for awhile until the computer learns how to run again, it will be fine.

Posted on Jun 16, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

2000 Lincoln LS had dead battery. Put in new one now the horn blares, radio blasts, lights go down. Pressed button on FOB to reset. turned car off and on; didn't work. Unhooked battery and left it.


How much is this going to cost? ????? Without testing to find out what the problem is , no idea . Your best bet , take it to a qualified repair shop an have it diagnosed .

Mar 07, 2018 | Lincoln Cars & Trucks

1 Answer

What could cause 2004 Ford Focus to suddenly quit as described below?


Bad connection at battery cable ends, bad alternator. Low voltage can make entire system go dead. Test battery and check all main cable and ground connections. Yes this can happen while driving down the road.

Feb 22, 2015 | Ford Cars & Trucks

1 Answer

No power to car


check to make sure the battery cables are tight and you have a good connection. make sure the ground wire is tightly secure to a solid metal ground.
Can it be jumped off?
If so, have the alternator checked at your local part store.

Apr 06, 2014 | 2003 Pontiac Sunfire

1 Answer

Check oil level light comes on and the warning triangle, I have topped up the oil and checked other levels all ok, it is a 09 plate


accross the board from factory, nortorius for these issues. The check oil light is a sensor issue, such as possible sending unit or oil pump which ever you would like to call it. Also, the oil velosity is major player, proper oil grade for motor and a parts house can help you with that. A thinner oil will act asthis, due to the higher mobility features of this jetted motor and fast paced dynamic sleek proby car. the downfall is the sensors and/or a possible breach in simple connected wires, or perhaps a simple oil change needed. the triangle light represents generally, a airbag issue. the fords are famous for deregulations when a computor rift travels the circuit boards. stering column thrashing, hitting or intergrated alrm such s auto theft, connects to your battery supply and can interfere with dash light accomadations,especially if the battery is recently chaged out and the wires were not properly reconnected due to the persay extra trick wire that these fords have from the gate, the date of build, its tricky. However, another Ford resolution would be to disconnect your positive battery cable (s0 only, post cable, count to 30 then reconneect this cable, properly tighten, however, key must be off intially, then when cable is pulled for count 30, the key must be in the on position in the ignition, then turn key to off, reconnect this battery post, start motor and drive, try to drive approx. twenty minutes, this should reset your computor components and alliviate the signals of akwards that are most likly associated with the computor relays, and the restting need, If the egr plug on the firewall in rear of engine compartment, almost located just under the front windsheild is loose, ajar this can cause the triangle light to malfunction, and properly snapping the plug assembly together can resolve this, however, you still may need to reset computor by way of battery, and also resolve oil defient grade, and seek airbag revenge which could happen from a simple applied pressure to steering column with resting feet, or trusting jolts fromfoot rest placement, or front end activity.good luck

Jan 04, 2014 | Peugeot 207 Cars & Trucks

1 Answer

Changed plugs and wires but it still acts like its skipping


That was a good first shot, but I would suggest that fuel injection might be the source of your "Skipping" problem?

Aug 19, 2013 | 1999 GMC Yukon

2 Answers

Error code p062b 2012 equinox


Had the same problem on our 2012 Equinox today. Threw codes P026B and P062F. Appears to be a bad battery. Replaced battery and all seems ok now...keeping fingers crossed. My suspicion is that the faulty, dying battery caused a low voltage situation in the injector control module and thus those errors. Will see if the check engine light returns in the next 48 hours.

Apr 20, 2013 | 2012 Chevrolet Equinox LS 4dr SUV 2.4L...

1 Answer

SUV won't start, nothing happens when I turn the key


Very likely bad battery. Most places that sell them will install for free.

Dec 27, 2012 | Suzuki XL7 Cars & Trucks

1 Answer

Changed sensor 1 bank 1 and found I have four on 96 Yukon makes noise like putting underneath. Now want start. Wuts wrong


tell me did, did skipping start after you replace oxygen sensor or did vechicle already have skip before sensor change if so skipping can be caused by intake leak,bad spark plugs and wires,could have restricted fuel filter, weak fuel pump or weak ignition coil. if skipping occur after you replaced oxygen sensor could have loose sensor or cross thread sensor threads causing exhaust leak around oxygen sensor.

Aug 26, 2012 | Cars & Trucks

Not finding what you are looking for?
2005 Chevrolet TrailBlazer Logo

Related Topics:

146 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

Marvin
Marvin

Level 3 Expert

81294 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22326 Answers

Ronny Bennett Sr.
Ronny Bennett Sr.

Level 3 Expert

6927 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...