Question about 2004 Ford Ranger

1 Answer

Switch for fan only works on high

We have checked the relay, the motor and switch but nothing worked.

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Ford Master
  • 3,433 Answers

Chk the fan speed resistors mounted on housing on fitre wall. two screws and a couple of wires.

Posted on Jun 15, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya Mechanic can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repair professionals here in the US.
click here to Talk to a Mechanic (only for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My 99 jetta isn't blowing any air at all when I turn the ac on, or even the fans.


if I am understanding you right the fan isn't blowing anything. this could be a couple of things it could be a blown fuse, a bad relay, a bad switch, a bad fan motor, or a bad wire. I would start with checking the fuses and relay if they are all good I would see if there is power to the motor when it is on if there is power it is ether a bad motor or bad resistors if your fan runs on high but nothing else it is probably the resistors if nothing works it is probably the motor. if there is no power at the motor when there should be I would check for power at the switch if there is power going into the switch but no power coming out of the switch the switch is probably bad. if there is no power going to the switch you may have a brake in a wire if there is power coming out from the switch but no power at the fan you may have a brake in a wire if you suspect a brake in a wire you can test the resistance going throw the wire by setting a dvom to resistance and touching the positive lead to one end of a wire and the negative lead to the other end of the same wire high resistance bad wire no resistance good wire make sure there is no power going throw the wire when you test is though or it could throw off the test.

Jul 02, 2015 | AC Cars & Trucks

2 Answers

Blower motor blows high whenever ignition switch is on


Sounds like your fan switch could be shorted out

Apr 14, 2015 | 2000 Chrysler LHS

2 Answers

Heater fan works on high and nothing else. Would it be the fan or the switch?


its possible to be both , but check the heater relay switch first , and the heater resistor ,not knowing what you have -year -make -model motor size, that's the best any of us here can do.

Feb 26, 2015 | Cars & Trucks

1 Answer

1992 chevy C1500: Heat works on low speed, no medium, and high only works intermittantly.


On any other vehicle it sounds like the blower fan switch.
The fan switch provides power or ground to the resistor and there would be a high speed blower relay to bypass the resistor.
But in your case the fan switch is part of the controller.
I don't have a diagram for a 92 but the 94 model shows relays for low medium and high speeds. Each relay gets power from a fuseable link. The high relay gets power thru the low relay if the low relay is not engaged.
If you have the model with 3 relays you may need to check them.

Feb 01, 2013 | 1992 Chevrolet C1500

2 Answers

My fan has the 2 highest gears of the blower working but the 2 lower gears are out. i have replaced the switch and the fan motor and i have checked the fuses and nothing is working. any ideas on what it is


Its the relay for the motor. When the relays go the high speeds will operate but the low speeds will not. Should not be too expensive and is easy to replace, only hard part is that sometimes they put them in places that are hard to acess.

Jan 09, 2010 | 1991 Toyota Pickup

2 Answers

Blower motor for heater only works on high....what do you think I need to change. Relay or Resistor.


If the heater only works on the high setting, your problem is the heater fan resistor, not the relay.

Jan 07, 2010 | 2005 Jeep Wrangler

2 Answers

Heayer doesn't work


The resistors provide resistance in the circuit, dropping voltage to the blower motor to slow the motor speed down. On high, the blower receives full voltage through the blower relay.

If you had High but no other speeds, then the resistor pack is usually the culprit. If you have all other speeds but high, the most common problem is going to be the blower motor itself, relay, or the switch panel.

You can check this by turning the fan speed to "high", unplug the blower motor, and check to see that you have roughly at least 12v at the plug. If you have 12v, that means the switch panel is activating the relay and the relay is working. Over time, heat kills the magnetic properties of the magnets inside an electrical motor. Without enough magnetic energy, you may not get enough opposing force to spin the rotor full speed when the windings energize, but still enough to spin at lower speeds.

Another thing you can check is the connector at the blower motor and the switch panel. Sometimes these will heat up, start to deform, and cause a bad connection. The bad connection may be able to handle the lower current draw on low speeds, but the higher resistance from the bad connection won't be able to handle the higher current while in the full speed position.

Hope this helps, keep me posted. be glad to help you get your heater working again soon.

Jan 07, 2010 | 1995 Chevrolet Tahoe

1 Answer

Blower fan only works on high


If it is working at all then the relay and fuse is good and the problem is either the little vacuum hose on the back of the control switch panel or the panel itself.

Feb 01, 2009 | 2001 Chevrolet Silverado

1 Answer

1992caravan turn signals, low beams, and heater motor do notwork


A) Faulty turn signal switch or circuit.
B) Broken dimmer switch or poor electrical connection.Could be relay also.
C) Unplug the electrical connector at the motor and use fused jumper wires to connect the fan motor directly to the battery. If the fan still doesn't work replace the motor. If fan works could be your relay.

Jan 19, 2009 | 1992 Dodge Caravan

1 Answer

Vent fan only works when set to 4


Hi.....
On your Vehicle the problem for the FAN speed is NOT the FAN switch.
99.9 % of this problem on cars is the BLOWER MOTOR RESISTOR.
The blower motor resistor give the speed to the Fan.
But on High speed the switch make a By pass of the switch using a Relay for the high speed.
The Blower motor resistor, is located Beside of the Blower motor On the passanger compartment.

If you replace the blower motor resistor you have 99.9% of this will solve your problem.

I'm a Mechanic.

I hope this help on your problem.
Thank you for use fixya...

Oct 09, 2008 | 2003 Nissan Altima

Not finding what you are looking for?
2004 Ford Ranger Logo

Related Topics:

43 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

77186 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22265 Answers

fordexpert

Level 3 Expert

5575 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...