Question about 1991 Cadillac DeVille

1 Answer

1990 DEVILLE. Posted 6-14. New BCM, new fuel pump, new relay, still no fuel. Have tested wires, I get a brief 12 volts to grey wire on connector to fuel pump when key is turned on, then nothing. I can hear the relay clicking when I turn key on, 2 secs later it clicks again. Have tried different relays with same result. Any ideas?

Posted by on

  • hedgehog8 Jun 15, 2009

    No, I replaced the ECM, sorry for error! {If you do not have the correct key with the proper continuity, the starter will not even turn over. (I had to solder that tiny wire in the steering column once for that problem).}

  • messstat
    messstat May 11, 2010

    You have most-likely "violated" a PATS with either a remade ignition key or worn ignition...the security code is defeating the injectors...an anti-theft function.
    Did you get the BCM used? If so, you need the ignition key that went with the car the BCM is from!


×

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

    Sergeant:

    An expert that has over 500 points.

  • Expert
  • 299 Answers

That is correct for initial prime,then fuel pump works off of crank sensor.Fuel pump is ussually controlled through ECM not Bcm.Have you checked for fuel preasure when you first turn on key,

Posted on Jun 18, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

How to test fuel pump relay switch on 1990 Chrysler imperial


put new relay in.
have you checked its not the pump
First, confirm that the pump is bad by listening carefully for the one second hum from the tank when you turn the key to the start position. If you didn't hear a thing..

Check for 12 volts at the dark green with black tracer wire at the wiring connection located underneath the van behind the driver's door. This wire supplies the voltage to your pump. If you have the rear heat this connector is generally found right around were the hoses are for the rear heater. There may be two connections at this location but the one you're looking for is the larger one with four wires.
Connect a voltage meter (or test light) to the dark green with black tracer wire and have someone turn ignition to the on position. Look for a flash of voltage then off. If you get the 12 volt reading that means that the computer ( PCM) has grounded the ASD (auto shut-down) relay circuit.
Now have someone crank the engine while you are still reading the voltage at the wiring connector. If everything is working normally you should get 10-11 volts while the engine is cranking. If you only get a very brief voltage reading or zero consider additional testing of the crankshaft or camshaft sensors (or fuses). If you got any sign of voltage doing the above test but never heard the fuel pump hum, with the electrical connections intact, then there is a strong probability that fuel pump is bad

Nov 01, 2016 | 1990 Chrysler Imperial

1 Answer

What could be the problem


Pull the pump out and see if just running 12 volts across it gets it to work. If that happens then it is not the pump at all but more likely fuse board or even the body computer.

Feb 14, 2015 | Cars & Trucks

1 Answer

Where is the fuel pump relay and fuse located on a '91 Buick Park Avenue? And is there a reset for the fuel system?


fuel pump relay: on relay center,behind glove box, 2nd column of relays, 2nd one from the top.
fuse: the wiring diagram says that it is fuse #6 on/by?? the relay center.
there should be a fuel pump test connector taped to the harness by/behind the battery. probably single red wire with a black or white connector. apply 12 volts to connector to test fuel pump.

Apr 03, 2014 | Cars & Trucks

1 Answer

Having problem with 1998 Mercury Grand Marquis LS Fuel Pump. Only getting 6.58 volts at the pump. Suggestions?


Sounds like a bad connection between the two points.
It may be easier to run a new wire than to tear the harness and connectors apart.

Sep 28, 2012 | 1997 Mercury Grand Marquis

1 Answer

2000 chevy silverado 1500 4.8 4wd will not start


Your pump is controlled by the pcm using a 12 volt signal to the relay. Pull out the relay and probe the relay socket with a voltmeter. There should be 2 terminals with 12 volts when the key is on. With the key off, there should be one 12 volt terminal coming from the ecm b fuse. See top left of diagram below.
0996b43f80243417-z51ydotzssbx3fkw4old43yo-5-1.gif

Jul 15, 2017 | 2000 Chevrolet Silverado

1 Answer

New fuelpump wont work


It could be you asd relay automatic shutdown relay. If you could check voltage to your fuel pump when you turn on the key. you should get 12 volts. if it is there then it is on the fuel pump side, if it is not there you will need to check asd or computer or wiring.
hope this helps

Jan 12, 2012 | 1990 Dodge Ram

1 Answer

Fuel pump not coming on,installed new one, white plug that has a yellow wire has 5 volts and ground is ok the 2 wires in the center shows 0


The plug you are referring to is probably the fuel tank pressure sender not the fuel pump. It would be plugged into a black sensor about 2 inches long pushed into a rubber grommet on the fuel bung. The fuel pump connector would have more that 2 wires going to it. most likely a heavy purple wire would be the power to the pump. It has to have 12 volts to it to work. The sender may have 3 wires, 5 volts, ground, and sense. the pump connector would have 12 volts, ground and 5 volts for the fuel gauge sender down in the tank.
If the 12 volts is not there, check the fuel pump relay. it is usually up on the drivers side firewall.
With the key in the on position without starting the engine, you should have 12 volts to the pump for 3 seconds then it will click off. Without cranking the engine you should be able to locate the relay by the clicking sound.
There is also the obvious, like checking the fuel pump fuse.

Jan 11, 2011 | 2003 Chevrolet Avalanche

3 Answers

It seems i am not getting any power to fuel pump, replaced pump still no power dont hear pump turn on at key on position check relays but not sure on good or not


Replace the oil pressure switch for the third wire on that sends 12 volts to the fuel pump upon turning the ignition key on to prime. Once oil pressure is achived the computer shuts that circuit off and turns on the fuel pump relay to power the pump till you shut off the engine

Jul 13, 2010 | 1997 Chevrolet S-10 Pickup

1 Answer

What wire is the power for the fuel pump at the pump


there were some production changes in 1998 to the fuel pump wiring, so the connector can have 2 diff fuel pump power wire colors, the most common color is grey, but the the harness at the tank has just 4 wires, the larger wires at the four wire oval connector are the fuel pump 12 Volt and the other is the ground, it is black, the other 2 wires are the sending unit, also the connectors ( Chevy factory service bulletin) on this year had a problem with burning, so if you get a new fuel pump always replace the 4 wire fuel pump connector. I have attreached a picture of the connector
2ea264c.jpg

Jun 30, 2009 | 1998 Chevrolet C1500

3 Answers

1999 oldsmobile silhouette van won't start. no power to fuel pump


I have a silhouette and it had the same problem
Follow the fuel pump wiring harness to where it plugs into the floor of the van--pull the connectors apart--they will probably be corroded, and you will possibly have to change both wiring harnesses or connectors.

May 25, 2009 | 1999 Oldsmobile Silhouette

Not finding what you are looking for?
1991 Cadillac DeVille Logo

Related Topics:

211 people viewed this question

Ask a Question

Usually answered in minutes!

Top Cadillac Experts

yadayada
yadayada

Level 3 Expert

76846 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22246 Answers

Ronny Bennett Sr.
Ronny Bennett Sr.

Level 3 Expert

6927 Answers

Are you a Cadillac Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...