Question about 1997 Chevrolet Corvette

1 Answer

Just bought a 1997 corvette been sitting a while charged up battery would not stay running was missing only ran when i kept on fethering pedal the noticed exhaust pipe got cherry red

Bought a 97 corvette sitting a while charged battery car was hard starting missing only stayed running when feathered pedal then noticed driver side exhaust pipe got cherry red

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Contributor
  • 44 Answers

Check to see if the exhaust is exiting the rear tailpipe. Could be a plugged up catalytic converter. Or some sort of obstruction in the exhaust system....

Posted on Mar 31, 2014

3 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

greg_margo
  • 1959 Answers

SOURCE: Stored my 1989 corvette for the winter. Just tried to start it, and the battery is dead. I jump started the car and it ran for about 7-8 minutes and then shut off. Had to re-jump and again, car won't

At first blush, sounds like corrosion on the battery cables either at the battery or at the other end at the alternator or starter. There are several sprays at the auto parts store that will clear the corrosion but the best way is to remove the cables and clean both the cable ends and the posts. Once you're able to rule out the cables/connections having the charging system checked would be next point of order but its more likely to be the cables. A car that won't run on it's own isn't getting enough power from the alternator so I'd check the negative cable first.

Posted on Apr 27, 2009

  • 2309 Answers

SOURCE: 2004 malibu classic,car ran find last night.this

too muchfuel going into the exhaust, my guess is a skipped timing belt or blown exhaust valve

Posted on May 09, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a 1976 Stingray Corvette. Was sitting for over 1 1/2' in the garage. I tried to start it and it needed a new battery. I place a new battery it started up. After a few weeks now the car does not


You have an alternating problem..I assume on a 76 model you have an internal regulator...if you have no voltage meter then charge your battery and start the var then pull positive battery terminal...if car dies,alternator is bad and needs replacing.If it stays running your at least putting out some voltage but might not be enough...most parts stores(Auto Zone,ect)will do a free voltage check(on or off vehicle)

Aug 12, 2014 | 1976 Chevrolet Corvette

1 Answer

1997 gmc sierra. interior light left on, battery dead, jump started,ran for 15 min. tried to restart after shutting off only thing that happened was drivers lock locks and 3 guages, oil , gas, and pressure...


You probably didn't run it long enough to charge up the battery. Put a voltmeter on it and see if it needs charging, or get it charged up, or get another jump and run it for a half hour and then see if battery is charged up enough to start the engine.

If the security light is on or flashing, you may need to reset the security system.

Oct 26, 2013 | GMC Cars & Trucks

1 Answer

2005 toyota tundra new battery and altinator both been tested and battery still dies after trk runs for 10 min. any ideas?


sounds like the alt. is not the problem.does the battery drain while the truck is sitting or running?

Jun 12, 2012 | Toyota Tundra Cars & Trucks

1 Answer

The passive key light stays on even then the car is turned off on my 1995 cheverolet corvette, will this run the battery down?


no not if you dont let it sit for weeks without starting it. this is nomal on most vets that age. its a warning to thieves not to try to steal it. hope this helps

Jan 31, 2011 | 1995 Chevrolet Corvette

1 Answer

It a 2003 2.0t 93 model. It sat all winter without running. I started it after charging the battery and it ran for about 50-60 seconds, it then stalled out and it wont start again, unless it sits for...


Take the battery in and have it tested to make sure it is fully charged and is holding that charge and that all the cells are good....letting a car sit for any length of time without starting it and letting it run for a bit is bad news. Batteries will go bad. Gasoline left to sit in a car will "go bad" and can leave a coat of varnish on sensitive injectors, fuel lines, etc... Water and debris can ruin the fuel filter. Check the battery first, put some injector cleaner in the gas tank and you may also want to spray the throttle body with a recommended cleaner before trying to start again. It may also help to pull your spark plugs and clean or replace them. Hope this helps. Good luck.

May 05, 2010 | 2003 Saab 9-3

1 Answer

I used to get a voltage reading of 13.6 volts on the electronic dash of my 1997 C5 but after the battery ran down ( 4 1/2 years old )the battery voltage now reads 13.2 volts on the electronic dash. I...


13.2 volts is all your tired old battery can hold.anything above the 12 volts it's rated at indicates it's charging OK.it may increase again,but nothing beats new.consider a battery tender to keep it fresh if it sits for long periods.

Sep 23, 2009 | 1999 Chevrolet Corvette

1 Answer

Stored my 1989 corvette for the winter. Just tried to start it, and the battery is dead. I jump started the car and it ran for about 7-8 minutes and then shut off. Had to re-jump and again, car won't


At first blush, sounds like corrosion on the battery cables either at the battery or at the other end at the alternator or starter. There are several sprays at the auto parts store that will clear the corrosion but the best way is to remove the cables and clean both the cable ends and the posts. Once you're able to rule out the cables/connections having the charging system checked would be next point of order but its more likely to be the cables. A car that won't run on it's own isn't getting enough power from the alternator so I'd check the negative cable first.

Apr 27, 2009 | Chevrolet Corvette Cars & Trucks

2 Answers

The car is running poorly and missing when hitting the gas pedal


Give it a good tune up. Change the cap and rotor, plugs. Make sure that the plug wires are in good shape and not broken from heat.

Apr 14, 2009 | 1989 Chevrolet Corvette

1 Answer

1997 buick lesabre quit running


Clean the battery cables. Test the battery.
If the voltage is low, the car won't run right.
Computer needs 12-14 volts.

Jan 05, 2009 | 1997 Buick LeSabre

Not finding what you are looking for?
1997 Chevrolet Corvette Logo

110 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

75797 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22114 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8140 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...