Question about 1992 Mercury Topaz

2 Answers

Stumbles 2nd gear on Idles and revs in neutral fine

I have a 93 Mercury Topaz 2.3 manual trans, that the small ground wire from the battery to the core support broke. After repalcing that wire, the car now wont accelerate over 1500 rpm in 2nd gear on. It will idle fine and with no load, it will rpm just fine.I did Cap,rotor, wires, plugs and Ignition module and fuel filter and has not changed the problem any.

Posted by on

  • 8 more comments 
  • jrperform714 Jun 15, 2009

    not carburated. Does this change the spolution?

  • jrperform714 Jun 15, 2009

    This is not a carb motor as last expert said. 2.3 injected.

  • jrperform714 Jun 15, 2009

    code 538 is only code during the read.

  • jrperform714 Jun 15, 2009

    have to head to work at 2pm central time(10 min. Will be back tomorrow around 10 am central on tues.

  • jrperform714 Jun 16, 2009

    Changed maf and still does same thing. Checked fuel pressure down the road and it stays at around 50 psi.

  • jrperform714 Jun 16, 2009

    Connector has been changed. Check engine light does not work on the dash. Will a reader pull the codes?

  • jrperform714 Jun 16, 2009

    reader has the following codes:

    111 System pass

    214 Balance test failed

    528 Clutch switch circuit fault



    Any help?

  • jrperform714 Jun 16, 2009

    Actron 3140 scanner under koeo test thats what codes come up. Under koer side other codes come up. So how does it read 3 digit codes?

  • jrperform714 Jun 16, 2009

    koer side comes up with code 538

  • jrperform714 Jul 06, 2009

    Sorry. Had major family medical issues. Was ECM.How do i accept so you get paid?

×

Ad

2 Answers

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Top Expert:

    An expert who has finished #1 on the weekly Top 10 Fixya Experts Leaderboard.

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

  • Mercury Master
  • 76,164 Answers

What code do u have?

Posted on Jun 15, 2009

  • 4 more comments 
  • yadayada
    yadayada Jun 15, 2009

    Your year has only two numbers in the trouble codes for the engine, this system is called OBD 1, or EEC IV by Ford techs, here is a list of those codes and how to get them using the check engine light blink to read them. Go to link.

    Have you had the MAF sensor recall done? contact a Ford dealer with your cars VIN if not sure they can look it up, this recall covers a problem that makes the car run like do do.



    http://www.extreme-check-engine-light-co...

  • yadayada
    yadayada Jun 16, 2009

    The problem with the MAF was not the MAF itself but the connector to the MAF, u will be able to see if a new connector was spliced on, the splice connections have heat sealed shrink tubing around them, it is dark grey in color, if it hasn't been done get the repair connector and replace the MAF connecortor, also Please read the trouble codes again as outlined in the web link from last post and let me know what u find,

  • yadayada
    yadayada Jun 16, 2009

    you will need a ford reader, do u have one? it is called a "Start Tester", also if check engine light doesn't work that could be related to the problem, you may have a defective ECM.

  • yadayada
    yadayada Jun 16, 2009

    these are not valid codes for a 1993 Ford/mercury system, they are 2 digit only.

  • yadayada
    yadayada Jun 16, 2009

    can u call me at my home? 925-459-0571

  • yadayada
    yadayada Jun 16, 2009

    these are the possible codes for your system.

    Ford's common codes for OBD1 (vehicles made before 1995)

    11 system pass
    12 idle control fault
    13 dc motor did not move
    14 engine rpm signal fault or PIP circuit failure
    15 eec processor or power to KAM interrupted
    16 rpm to low to check oxygen sensor test or fuel control error
    17 cfi fuel control system fault or rich/lean condition indicated
    18 ignition diagnostic monitor (IDM) circuit failure
    19 cylinder identification (CID) sensor input failure
    21 engine coolant temperature (ECT) out of self-test range
    22 manifold absolute pressure (MAP) sensor circuit out of range
    23 throttle positioner sensor out of self-test range
    24 air charge temperature (ACT) sensor out of self-test range
    25 knock not sensed during dynamic response test
    26 transmission fluid temperature out of self-test range
    28 loss of primary tach, right side
    29 insufficient input from vehicle speed sensor
    31 egr positioner sensor below minimum voltage
    32 egr positioner sensor below closed limit
    33 throttle positioner sensor noisy/harsh on line
    34 egr valve circuit out of self-test range
    35 egr valve circuit above maximum voltage
    38 idle track switch circuit open
    39 axod torque converter or bypass clutch not applying properly
    41 oxygen sensor circuit indicates system always lean
    42 oxygen sensor circuit indicates system always rich
    43 oxygen sensor out of self-test range
    44 air injection control system failure
    45 coil 1 primary circuit failure
    46 coil primary circuit failure
    47 4X4 switch is closed or oxygen sensor failure
    48 coil primary circuit failure
    49 electronic transmission shift error
    51 engine coolant temperature sensor circuit open
    52 power steering pressure switch circuit open
    53 throttle position circuit above maximum voltage
    54 air charge temperature circuit open
    55 key power input to processor open circuit
    56 mass air flow circuit above maximum voltage
    57 axod circuit failure
    58 idle tracking switch circuit fault
    59 automatic transmission shift error
    61 engine coolant temperature circuit grounded
    62 converter clutch error
    63 throttle positioner circuit below minimum voltage
    64 air charge temperature circuit grounded
    65 charging system
    over voltage
    66 mass air flow sensor circuit below minimum voltage
    67 neutral/drive switch circuit open
    68 transmission fluid temperature over temperature range69 transmission shift error
    70 data circuit communication link circuit failure
    71 message center circuit circuit failure
    72 insufficient manifold absolute pressure (MAP) change during dynamic response test
    73 insufficient throttle positioner (TPS) change during dynamic response test
    74 brake on/off (BOO) circuit open
    75 brake on/off (BOO) circuit closed
    76 insufficient air flow output change during test
    77 brief wide open throttle not sensed during test
    78 power interrupt detected
    79 a/c on/defrost on during self test
    81 map has not changed normally
    82 super charger bypass circuit failure
    83 OIC-low speed fuel pump relay circuit failure
    84 egr vacuum regulator (EVR) circuit failure
    85 canister purge circuit failure
    86 shift solenoid circuit failure
    87 fuel pump circuit failure
    88 electro drive fan circuit failure
    89 transmission solenoid circuit failure
    91 no oxygen sensor switching detected
    92 shift solenoid circuit failure
    93 throttle positioner sensor input low
    94 torque converter clutch solenoid circuit failure
    95 fuel pump secondary circuit failure
    96 fuel pump secondary circuit failure
    97 transmission indicator circuit failure
    98 electronic pressure control circuit failure
    99 eec has not learned to control idle

×

Ad
  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Brigadier General:

    An expert that has over 10,000 points.

  • Master
  • 3,917 Answers

Hi,

The problem is not ignition timing, nor the carburator. (at least not directly)

At full operating temperature, and under engine load, the EGR system in conjunction with the feedback system of the carb will automatically adjust the fuel mixture.

Check for vaccum leaks and repair as required... Additionally,even the slightest vaccum leak will cause problems with the feedback system. Be sure to check the Thermostatic Valve for proper operation. (The Thermo Valve is located in coolant thermostat well in the intake manifold.)

Also, the Bosch Platinum plugs are a very good choice as long as they are the correct heat range for the application... http://www.sparkplugs.com/results_app.asp?productTypeID=1&AAIA=1096376

Some symptoms I've corrected in
the past may be the same as the one you describe.

When the engine wasn't up to temperature, the truck would cough and darn near
flame-out when going up a hill, like a freeway on ramp.

Also if you want to get rid of the spark plug way get rid of those spark plugs (too much advertising hype) don't use
anything fancy have the coil tested for voltage output get a
timing light and check for vacuum and centrifugal advance of the spark
use a vacuum gauge and check for low vacuum get a long tube and a
propane tank and artificially richen the fuel mixture if the problem goes
away when rich see if the accelerator pump circuit in the carb is ok .

Thanks for contacting Fixya.

Posted on Jun 15, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

94 blazer 1500 starts idles or rev to 5000 when in park or neutral. in drive idles ok but stumbles and dies when you accelerate under load.it takes awhile to reach 75 mphd it will kick down to climb a hill...


You either have a defective idle speed control valve or you have a huge vacuum leak on the engine like an intake manifold or warped throttle valve or throttle bore opening around the throttle valve, I have seen both...

Jan 08, 2017 | Cars & Trucks

2 Answers

Kia sportage 05 jerking in 2nd and 3rd gear, raving the engine spontaniously, help!


SX 2.4L w/Auto Trans Slip/Jerk Shift Problem - Kia Forum

www.kia-forums.com/kia-forte...td.../55002-sx-2-4l-w-auto-trans.html

Nov 5, 2009 - 10 posts - ‎8 authors
A noticable rev in RPM between 2nd and 3rd gear only after startup. I had been ... Last edited by TeeJay1959; 11-05-2009 at 04:49 PM. TeeJay1959 is ... Started engine, accelerated out of parking lot and got a rude jerk between 2nd and 3rd gear. You are right .... 1 Attachment(s) 93-02 Kia Sportage Mud. 2nd to 3rd gear shift a "jolting" exoerience
10 posts
Jan 30, 2015
Please Help with 2006 Spectra Transmission
10 posts
Jan 31, 2012
2010 Surging while driving
10 posts
Jul 4, 2011
2005 Kia Spectra Auto Trans Problem
10 posts
Jun 18, 2005
More results from www.kia-forums.com

Kia Sportage Software Update - RepairPal


Feb 08, 2016 | Kia Cars & Trucks

1 Answer

Transmission slipping in 2nd gear


1 Ck A/T fluid level & quality
2 Scan/ck for code(s)
3 With scan tool connected,road test vehicle/Ck parameters....
....time for a pro !!

Apr 06, 2014 | GMC Sierra Cars & Trucks

1 Answer

1993 chevy k1500 transmission problem


Do you mean start the car in drive? if so that problem is inhibitor switch. Other shift problems can be caused by TPS (throttle posistion sensor) if applicable

Oct 05, 2012 | 1993 Chevrolet K1500

1 Answer

1987 Topaz, has trouble accelerating.


Most likely it is a transmission problem. Being that old the transmission needs work and possibly the clutch replaced or Throw-out bearing.

May 11, 2010 | 1987 Mercury Topaz 2 Door

1 Answer

My 93 mercury topaz idles high doing warm days, and idles low doing cold days,what could that be.


1) weak anti freeze 2) defective thermostate 3) out of range coolant temperature sending unit

Any of these or combination of these will give you the sympthoms you are experiencing

Mar 25, 2010 | 1993 Mercury Topaz

1 Answer

93 mercury topaz will not start, battery checked, connections to starter/solenoid checked, how do you check solenoid?


the solenoid will maje no noise or just a click if bad. if good you will hear the sound of the inner plunger retracting with a poping noise
jump the solenoid wire to the battery cable to the starter and see if it works

Feb 20, 2010 | 1993 Mercury Topaz

1 Answer

I have a 93 mercury topaz that stalls while driving


if it only stalls hot relace the ign module on distributor

Oct 05, 2009 | 1993 Mercury Topaz

1 Answer

Mercury Topaz serpentine belt diagram


I have a 93 topaz, the diagram label is under
the hood itself.

Jul 16, 2009 | 1993 Mercury Topaz

Not finding what you are looking for?
1992 Mercury Topaz Logo

Related Topics:

161 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mercury Experts

yadayada
yadayada

Level 3 Expert

76132 Answers

fordexpert

Level 3 Expert

5520 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Are you a Mercury Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...