Question about 1993 Jeep Grand Cherokee

1 Answer

Check engine ligt is on and sounds like its missing.

Some one said maybee o2 sensors could be bad. but havent gotten the codes checked. Could it be something else like the injectors?

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Master
  • 1,392 Answers

Could be about 100 things. You need to get it checked.

Posted on Jun 15, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

06 dakota 4.7. P0300 replaced plugs,injectors,coils,o2 sensors & all other sensors,intake cleaned.bad ecm? cats show same temp both sides of cat, bad cat? Or??


Have you checked for vacuum leaks? Poor idling when cold that gets better when the engine warms up, or at higher RPMs are symptoms of vacuum leaks. Check all hoses and connectors. If it's a manifold gasket, you will want to use a smoke machine (check when the engine is cold).

Apr 03, 2017 | Dodge Dakota Cars & Trucks

1 Answer

CODES P0300, P1128


po300 is random miss fire doubtful two O2 sensors bad at one time most likely coolant temp sensor is bad causing engine to run rich this will cause O2 sensors to throw a code(thats what they are there for..exhaust gas temp. and raw fuel) running rich will also fowl spark plugs(=miss fire) P1128 ??

Mar 20, 2013 | 2006 Jeep Liberty

2 Answers

My 93 olds cutlass ciera keeps misfiring and stalling, i have change the spark plugs, fuel filter, o2 sensor, maf sensor, and still stalls and misfires any ideas?


For engine misfiring problem check the help links mentioned below. Click the link below to go through the troubleshooting procedure :---- Engine misses and truck jumps? Hard to down shift? Issue with high gear only? http://technoanswers.blogspot.in/2012/02/engine-miss-and-truck-jumps-hard-to.html

-----------
Bad miss at idle?

http://technoanswers.blogspot.com/2012/01/bad-miss-at-idle.html

-----------
While stop engine idles like cylinder missing?

http://schematicsdiagram.blogspot.com/2012/01/while-stop-engine-idles-like-cylinder.html

------------
Engine Misfire codes for car?

http://schematicsdiagram.blogspot.com/2011/12/engine-misfire-codes-on-chevrolet.html
Engine Misfire codes?

http://schematicsdiagram.blogspot.com/2011/12/engine-misfire-codes-on-chevrolet.html

--------------
Misfire on cylinder 4?

http://schematicsdiagram.blogspot.com/2011/12/misfire-on-cylinder-4.html

-----------
Oil on spark plugs and car misfires?

http://technoanswers.blogspot.in/2012/02/oil-on-spark-plugs-and-car-misfires.html

----------

This will help.

Thanks.

Feb 14, 2012 | 1993 Oldsmobile Cutlass Ciera

2 Answers

I have my engine light on, in my xg300 Hyundai 2001 if i replace the mass air flow sensor and my fuel air metering my light go off, Im a woman trying too fix my car my self pls help tks code...


check engine light will not go out or codes cleared till computer is cleared so if you have set off a code while trying to diagnose it will stay in memory with that in mind

PO171 & 174 are related to bank 2 lean o2 sensor reading high oxygen in exhaust at sensors
PO120 has to do with throttle position sensor input out of range
PO306 is a misfire in #6 cylinder

in my opinion any miss will cause o2 sensors to read lean because the cyl is in effect a air pump sensors only pick up o2 not the fuel does you engine run rough or hesitate/shaking on acceleration
i would check coil wire and plug for #6 also the injector not working will cause miss also they look ok do compression test on cyl will read 150psi if you find cause of miss you will be able to diagnose lean

with the tps sensor check to see if the connector was disconnected at any time you were testing

basically you need to isolate misfire and fix then have the computer cleared of codes drive car and if engine light comes on then we will go through test procedures for new codes

i hope this helps you to get a few ideals on how to proceed good luck ley me know

Jan 16, 2011 | 2001 Hyundai XG300

1 Answer

When u drive around 60mph car is holding back engine light is on say after cat h2 sensor checked the plugs got a miss on idole and its got a flat spot


Go to any Autozone or Advance Store and they will check your computer on board to see what code is stored in the computer. It sounds like you have a O2 sensor going bad. Theses sensors are screwed into the exhaust manifold to read back to the computer on board to tell the car if it needs more gas or less gas. Also the 2 auto store that I have listed will check you check engine light codes for FREE. Where most car dealerships will charge you 1 shop hour to tell you what sensor is going bad or is bad. Hope this helps.

Dec 06, 2009 | 2002 Volkswagen Golf

3 Answers

Check engine ligt came on my 97 Explorer as soon as it did it runs like a miss is this a limp in mode and how do I check the engine codes. I know Dodge not Ford.


just bring it to a local advance auto or auto zone they will hook up a code reader this will point you in the right direction it may be an O2 sensor MAF sensor in need of a tune up (plugs, wires, PCV, Air cleaner etc.)

Sep 18, 2009 | 1997 Ford Explorer AWD

1 Answer

O2 sensors trouble codes come back/after being replaced


What were the codes??? You should have gotten one code if it was only one O2 sensor that went bad. If all three O 2 sensor went bad you would have gotten three different codes. P0031 (bank1 sensor1) P0051 (bank2 sensor2) P0061 to P0064 O2 sensor after the catalytic. Hops this helps. 

Jul 03, 2009 | 1999 Chevrolet S-10 Pickup

1 Answer

Misfire and low power, think its the o2 sensor because i already checked the plugs and wires, fuel filter, fuel pump, but i also havent checked the distributor cap or rotary button, could it be the o2...


First off there is no distributer cap or button. There are three individual coils. Instead of a distributer it is computer controlled ignition(spark).
Your service engine light should be on above your gas gage on your dash. You need to have the computer scanned for trouble codes. There are many components that may be causing the problem. Even if one of the 2 o2 sensors is bad there is probably something else causing problem.

Jun 30, 2009 | 1996 Oldsmobile Cutlass Supreme Coupe

4 Answers

Check engine light came on...


sounds like you have a dead misfire on one of your cly.check plugs, plug wires/coils, and injectors.

Jun 11, 2009 | 2001 Acura 3.2CL

2 Answers

KNOCKING SOUND WHEN ACCELERATING, ALSO CHECK ENGINE LIGHT IS ON


Hello fellow Texan!

AutoZone should have gotten more than 1 code for this problem. The problem could be any number of things from knock sensor to O2 sensors. More information is needed.

Jan 24, 2009 | 1992 Lexus Es 300

Not finding what you are looking for?
1993 Jeep Grand Cherokee Logo

Related Topics:

31 people viewed this question

Ask a Question

Usually answered in minutes!

Top Jeep Experts

yadayada
yadayada

Level 3 Expert

76846 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22246 Answers

Kevin Daniels

Level 3 Expert

1455 Answers

Are you a Jeep Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...