Question about 1997 Chevrolet Monte Carlo

1 Answer

Not getting power to fuel pump I have replaced the fuel pump,check the relay

Car will not start don't seem to be getting power to pump

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Chevrolet Master
  • 1,250 Answers

not getting power to fuel pump I have replaced the - 9bd53557-c853-4dfe-8874-cf7fb7cf7768.gif

hope it helps

Posted on Mar 30, 2014

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

GM Elec
  • 1000 Answers

SOURCE: 92 Chevy Suburban Electrical Fuel System

I assume the fuel pump fuse is good?
The only time voltage will be sent to the fuel pump will be the first 2 to 3 seconds if the starter is not engaged. You will want to crank the engine over and check for voltage on the load side of the relay, circuit #30 at the relay.
Let me know after you check.
Regards,

Posted on Feb 23, 2009

  • 2 Answers

SOURCE: Fuel pump and electrical

its very likley that your fuse is blown. If you look it should be something like injectors a+b

Posted on Mar 06, 2009

  • 2 Answers

SOURCE: 1987 chevy r10 won't start

Assuming it is a fuel problem I checked at the carb. to be sure no gas was being pumped through the filter located under the power steering pump then the fuse on my 87 s10 was the ECM fuse.then check for the relay to click and the had to replace the oil pressure sending unit and mine started right up..the oil pressure must be about 4 lbs for the Pump tp operate...I loosened the fuel line to ck. for fuel but thats living dangerously...a pressure guage would be on the safe side......

Posted on May 18, 2009

  • 2 Answers

SOURCE: 98 Astro Van Intermittant Power to Fuel Pump Relay

I've been bitten by this twice! The culprit both times was the connector plug under the van infront of the fuel tank. the second time the connector pin and socket came loose inside the plug itself,( workes for a while then dosen't). Make sure there is good secure contact made in all sockets in this plug, and the pins are held where they need to be inside the plug itself.

Posted on May 29, 2009

  • 1 Answer

SOURCE: 1996 chevy tahoe fuel system

i am having the same problem with my 96 pickup i am getting low voltage to my fuel pump i have traced the wires back to the front the purpel wire is the one with low voltage i replaced fuel pump also fuel relay and still have low voltage

Posted on Jun 22, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Kia sportage cranks but seldom starts??


Have you checked the fuel pump relay to see if it is sending power to the pump ? The computer grounds the relay when the computer "sees" oil pressure or engine RPM.

Jul 17, 2014 | 2001 Kia Sportage

1 Answer

1994 Mazda PU Truck sometimes won't start if shutoff for 5-10 minutes.. Several tries later, it will start. spark seems ok, it gets enough fuel for a second, but then poops out. fuel pump shuto


Well there is no shutoff relay, but there is a fuel pump relay that powers the pump.
I would check it first. The computer grounds the relay for 3 seconds when you crank the engine to boost fuel pressure. Once the engine starts the pump is powered only if you have oil pressure.

Apr 12, 2013 | Cars & Trucks

2 Answers

05 c240 turns over won't start


most likely you have a bad crank sensor or fuel problem you need to check fuel pressure ,if you have enough pressure ,most likely you need crank position sensor,if you don`t have fuel pressure ,it might be your fuel pump relay or the pump, i would start with the relay first very unexpensive. you can also hear the pump if it`s working by cranking the engine and listening rear of the car for a humming sound .
good luck

Mar 03, 2013 | 1998 Mercedes-Benz S-Class

1 Answer

Why don't i have power to fuel pump fuse?


I would replace the relay just because it is cheap and it seems that it had a problem. I think the check you did may have been flawed but not sure at this point, the fuel pump only has power for 1 second unless the engine is being cranked over.Electric fuel pumps no matter the car line do fail most often after the 100,000 mile mark.

Sep 01, 2012 | Cars & Trucks

1 Answer

I have 1986 Alfa Spider that won't start. Car has been sitting for a year. I replaced battery, fuel tank, fuel sender unit, both fuel pumps. I seems that the in tank pumps is not getting any po


Could be the main or fuel run relay located in the compartment under the luggage rack, passenger side, main relay also, fuse for the fuel relay 8amp. Electronic Control Unit is also located there.

Could be electrical, Hook up a timing light, three leads: Power, Ground, and one that goes around the wire to #1 cyl. Turn the engine over and see if there's firing. Note: u can check all 4 spark plugs this way.

Fuse lead goes to pin 30 of the fuel relay, u can jump 30 across to 57 and check for the pumps running, if not, change-I suggest both relays, main and fuel run relays. Both pumps get their 12v DC from the fuel run relay, both should be running when you switch ignition switch to on, then a tachymetric signal is fed from the coil to the relay to keep it running.

Jun 10, 2012 | 1986 Alfa Romeo Spider

2 Answers

My 1999 Kia Sportage won't start. I checked the fuel pump while the key is on the ignition and I get the impression that it is not getting any juice. Fuel pump fuse is OK. Both cam and crank se


Well for starters, you need to diagnose the problem before replacing anymore parts. I say this because you mention both the fuel pump and sensors dealing with the ignition system which are 2 separate main things. Basically it takes 2 things to make an engine start, fuel and spark at the spark plugs. You need to narrow down what is missing because it seems since you replaced sensors dealing with spark and then you mention the other need fuel. I'm not sure as to where to start to help until whatever is missing is diagnosed and then find the cause of the loss. There are a couple of things you can check. Below is a picture of the relay box in the engine compartment. With the help of somebody put a finger touching both the fuel pump relay and the EGI main relay. While touching them have somebody turn the key to the "on" position (no need to try and start). When the key is turned on you should feel a "click" inside both of those relays. The fuel pump relay will click for about 3 seconds and the click again to shut off. The EGI main relay should stay on. If both seem to be fine you need to make sure of the fuel pump gettting "juice" and for power to the ignition system like the coils. You can get to the power/juice wire at the fuel pump pretty easy. You can access the connection at the fuel pump by lifting the lower part of the rear seat. Once the seat is lifted you should be able to see a part in the carpet that is cut to be able to lift the carpet up and access the plate covering the access to the fuel pump and/or the top of the fuel tank. Using a test light, check the green and yellow wires at the fuel pump. You should have power at those wire when turn the engine over or if the key is just turned to the on position you should have power there for about 3 seconds. To begin checking for spark or power to the ignition system you need to make sure you are getting power to the ignition coils. The red and white wires at the coils are your power wires. Check those. Also you can check the power at the fuel injectors. When the key is turned on or when trying to start, you should have power to the green wire at each of the fuel injectors. You should have constant power/juice at each of the fuel injectors. This is where I would start to narrow down the loss. Start here with these tests and let me know how the tests come out by replying/commenting here or you can email me directly at csautomotivecars@att.net ith what you have found out. Once the first tests are done and I know what the results are, we can go to the next step with a couple of other tests to figue the problem out. If one of the relays don't "click" then you have a possible bad relay. The EGI main relay is a common thing to go as well as the fuel pump relay. Don't mind helping and there is no cost to you for it but I don't want to tell you to start replacing parts until the problem is located. Hope this helps get you started.


4_24_2012_10_38_55_am.jpg

Apr 23, 2012 | 1999 Kia Sportage

1 Answer

Car will turn over but won't start. Through the


No noise from fuel pump when you turn over the car .First thing get voltage at fuel pump relay checked, is there 12 volt to the relay.If no, then problem is again the relay.--------- To reconfirm the problem, try other test, that is remove the relay and by pass the relay terminals with a jumper wire .Then with 12 volt external battery give power to fuel pump connector and see, if the fuel pump starts, then its clear that fuel pump relay is faulty.----------- Also other problem can be fuel pump inertia switch.If the inertia switch is faulty then also fuel pump will not start.-------- The fuel pump relay on a 1995 Ford Explorer is in the power distribution
box, in the engine compartment, driver's side near the firewall.----------
The fuel pump inertia switch is in the right front passenger area
it is below the dash but above the carpet in the right hand corner.--------
Its a push button type inertia switch.
--------
Fuel Pump Activation
When ignition switch is turned to START position, PCM operates fuel pump relay to provide fuel for starting engine. PCM senses engine speed and shuts off fuel pump by opening ground circuit to fuel pump relay when engine stops or engine speed drops to less than 120 RPM. When ignition switch is in ON position, EEC power relay is energized (contacts closed). Power is provided to fuel pump relay and timer in PCM. Fuel pump receives power through fuel pump relay contacts.
Inertia Fuel Shutoff (IFS) Switch
All models use an electrical interrupt switch in fuel system. During a collision or vehicle rollover, electrical contacts within inertia switch open, shutting off fuel supply to electric fuel pump. Fuel supply is interrupted even when engine is running.
A reset button is located on switch assembly. If electrical circuit trips, vehicle will not restart until switch is reset. Fuel system should be inspected before resetting switch.
IFS switch is located under instrument panel, near right side of transmission hump.
----------- If the fuel pump relay, the inertia switch and fuel pump all checked ok, and fuel pump is working with direct 12 volt source to fuel pump.Then problem relates to computer.The computer (power control module, PCM) is faulty and has to be replaced.--------- This will help.Thanks.Helpmech.

Jul 17, 2011 | 1995 Ford Explorer

1 Answer

My 1999 masda 626 won't start. it turns over but acts like it isn't getting any fuel.


check relays/fuses first then the pump if you know how to test it
the pump is easy to test locate any fuel line unplug it tell a friend to make a quick one key turn if squirts fuel then pump is fine
but check the pump relay first to make sure and to begin with simplest
it seems you can tell it is the pump but you don`t know where to start

Jun 07, 2011 | 1999 Mazda 626

1 Answer

1996 caravan replaced fuel pump dont have power going to it ,, already checked and moved around the relays.. is there anything else i need to do?


you don`t say did you check the fuses.were the connections at the fuel pump plug in good/clean condition.have you check for power at the pump wires at the tank you do then you will have to check the pump wires at the pump if you don`t have power by the tank then you need to check to see if power is powering up the relay and going out of the relay to the pump.you could have a corrosion problem under the relay box.

Apr 28, 2011 | 1996 Dodge Caravan

1 Answer

Fuel problem on my 1998 Camaro


Check for a bad connection to relay. relays shouldnt just go bad after you keep replacing them seems like it would be a bad connection for the relay and when you replace it you move the connection in the fuse panel. find wireing scehmatic just jump the power for the fuel pump directly to power and see if it works if so examine that you have power from the ignition switch and a ground to energize relay and that power is good on feed side of relay.

Oct 14, 2008 | 1998 Chevrolet Camaro

Not finding what you are looking for?
1997 Chevrolet Monte Carlo Logo

28 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

75797 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22114 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8152 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...