Question about Mercedes-Benz Sprinter

Open Question

P2047 P20B9 engine runs fine

Posted by Anonymous on

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Whatcauses the engine to vibrate in gear


sounds like a collapsed engine mounting. When the mounting fails it basically drops and the bump stop rests on the base of the mounting which leaves no room for the mounting to flex and the running engines vibration travels through the body

Aug 11, 2016 | Cars & Trucks

1 Answer

Oil pressure gauge reads high only when engine is running,oil level is fine


that is a sign of the wrong oil grade. that truck takes 5 w 20 oil

Jan 26, 2013 | 2005 Chevrolet Silverado

1 Answer

2002 Subaru Forester misses/runs poorly with slow acceleration when hot with a/c on especially after running 50-60mph on interstate. Problem is intermittant. Runs fine with excellent acceleration...


I have the same problem. But my check engine light comes on when this occurs. The car runs fine otherwise. The problem manifests when it's hot out and I've been driving for a while with the A/C on. When I stop somewhere (like the supermarket), shop, and get back in my car. It starts fine but when I put it in gear to go, it's extremely sluggish for a few seconds and the check engine light comes on. Then is runs fine but the check engine light remains on. The next day when I start it, the check engine light is not on. Also, I recently had the head gasket replaced. I took it back into the shop the first time the check engine light came on. The mechanic checked it and said everything checks fine. He re-set the light saying to keep an eye on it and bring it back in if the check engine light comes back on. It ran fine for 1.5 weeks and now this problem has started to occur.

Did you find anything out dwbradway? I wish I had a solution for you but I just have the same kind of problem. Any help would be appreciated!

Jun 18, 2011 | 2002 Subaru Forester

1 Answer

Car runs fine just quits


Does this have a "Check Engine" or "Service Engine Soon" light on? If so, get the codes pulled and post them back here along with the engine info. If no codes are present then it may well be a bad crankshaft sensor. I have seen many of these give intermittent problems (usually heat related) and do exactly what you have described without setting a code.

May 24, 2010 | 1994 Buick LeSabre

1 Answer

Water pump is leaking,my engin is running hotter


if engine is running hotter than normal, test the thermostat in a coffee pot, if it is opening fine, then the water pump is going out, and will definately need to be replaced asap to avoid further and much more costly repairs!!!!

Oct 27, 2009 | Pontiac Montana Cars & Trucks

1 Answer

Engine will be running fine, and will suddenly


might try a tune up start with spark plus and spark plug wires

Jul 03, 2009 | 1997 Toyota Camry

1 Answer

Trouble keeping engine running


I've solved this one by letting the computer do the work. I let the engine run rough at about 1500 rpm until the computer caught up with everything and adjusted either the carb or the timing, now it runs better than it did before!

Jun 20, 2008 | 1987 Oldsmobile Cutlass Supreme

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

105 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mercedes-Benz Experts

Colin Stickland
Colin Stickland

Level 3 Expert

22246 Answers

yadayada
yadayada

Level 3 Expert

76848 Answers

Michael Contreras
Michael Contreras

Level 2 Expert

166 Answers

Are you a Mercedes-Benz Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...