Question about 2003 Chevrolet Silverado 1500

1 Answer

Ticking in the motor

I have a ticking in the motor, I rev up the gas pedal the ticking accelerates at the same time. Now my temperature gauge stays at 160, could this be a bad thermastat?

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Master
  • 1,162 Answers

Most likely its the relay on your air conditioner. Ticking sounds can be anything you really need a mechanic to listen. I say relay on air conditioner because is happened on my vechile an is still there.

Posted on Mar 27, 2014

Ad

4 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad
afarri
  • 1386 Answers

SOURCE: my 2003 impala shifts hard

Hello and welcome to FixYa!

As a first course of action, I strongly suggest that you remove the positive battery connector. Let it sit for atleast 5mins. then reconnect it again. This will reset the system and can get it back to it's normal operation.

If the problem still persists then the problem could be on the IACV (idle air control valve) or TPS (throttle position sensor). Have both checked and replaced if necessary. Let's just hope option number one works to cut the cost.

Hope this helps and thank you for using FixYa! Have a good one!

Posted on Jun 08, 2011

joedatech
  • 12 Answers

SOURCE: 2005 avalanche temperature gauge does not move and

stepper motor failure in instrument cluster visit http://www.joedatech.com

Posted on Jan 25, 2012

bdstaoro
  • 131 Answers

SOURCE: press gas pedal

check your throttle pedal position switch and your throttle position sensor

Posted on Dec 19, 2013

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

In my 2002 Hyundai Accent, the meter where it shows x 10000 rpm used to just stay at one. Now it revs up to 3 when i accelerate. what does it mean?


Sounds like you rev gauge wasn't working and now it is . If you are sitting in the car , have it in neutral and depress the gas pedal your rev gauge should increase , if it never moved there's a problem , the wires at the back of the odometer were probably loose

Mar 02, 2015 | 2002 Hyundai Accent

1 Answer

Press gas pedal


check your throttle pedal position switch and your throttle position sensor

Dec 19, 2013 | 2005 Chevrolet Cobalt Sedan

1 Answer

My Toyota Quantum 2.7GL idles but does not rev up. i ve changed the fuel pump and filter but still it starts, idles but does not rev up when you press the accelerator?


We do not have this model in US, but I assume it is a new model 2016-17. You throttle (and the "rev" ) is controlled by the computer. The fact that your car is idles - should mean that your computer is fine! There are two types of idle control: 1st- when you have a bypass of the throttle, which lets the throttle flop stay close while idling and let's the air into the motor through a bypass and electronically controlled idle switch. Inspect your throttle - the electronic/metal unit located on the large pipe through which the air gets into the motor: if you have a "bypass" for the air then you need to inspect your throttle body as it could be your problem.
2. most likely you do not have a bypass and your idle is controlled by your throttle body, then it is sure working fine and your only issue is that your engine computer does not know that you press the accelerator. Your gas pedal has an electrical unit on it which connects to the engine computer- inspect the connector/wires if all looks fine most likely your accelerator sensor does not work- you need to change the gas pedal unit ( I think it called accelerator sensor).
Good luck.

Jan 05, 2013 | 2007 Toyota Quantum 2.7

1 Answer

1990 toyota pickup v6 starts-up step on gas pedel motor then dies


does thr engine rev upwhen started than idels back down.try idel control switch and map sensor

Oct 27, 2012 | Cars & Trucks

1 Answer

I have a 1997 lumina with 3.1L. the problem started with loss of power under load and p0300 code. check coils and vacuum leaks both OK.change spark plugs and wires.[same problem] check compression OK.


Since you changed the sensor we will assume it is working. When you disconnect it you put the computer in limp mode which stops it from using sensor values. If code 300 is the only code we will assume the coolant temp sensor and others are ok.
I would check fuel pressure with a gauge next.

Aug 21, 2012 | 1997 Chevrolet Lumina

1 Answer

Engine will turn over, but car will not stay cranked.


You'll have to figure out if it is a fuel or ignition problem.
Is the check engine light on ? Have you checked for trouble codes ?
It uses an idle control valve to adjust the idle speed. The valve could be dirty or failing, or the throttle body could be dirty.

Jul 03, 2012 | 2004 Chevrolet Impala

1 Answer

1995 saturn sl2 ticking noise when accelerating


these are known for carbon build up on the valves that cause several problems.this could be the problem as the carbon can cause the valves to stick a bit in the valve guides while its running and show up as a ticking noise with the gas applied.have the top end service done which cleans the fuel system injectors and any carbon build up on the back of the valves.if this gets bad enough it can cause the cam holders to break locking up the motor if the piston hits the valve.another thing to check is oil pressure and the lifters may be worn to the point that they need replacing.check the cam lobes as well if worn these can cause a ticking noise on acceleration.

Apr 17, 2012 | Saturn SL2 Cars & Trucks

1 Answer

My 1997 LS upon starting its necessary to rev up the motor until the coolant gauge drops to cold then it will stay running. After driving a short distance and turning off, i need to floor the pedal to get...


I would look into the coolant sensor. (assuming you have the 1.9 liter) Its' located on the drivers side of the cylinder head, with a small two wire harness connected. These go bad and send the wrong temperature reading to the computer, so it will thinks it's extremely cold out, and dump more fuel. I have had this issue on a couple of saturns I have worked on. The best way to diagnose it is to hook up a scanner, and see what the coolant temperature is. Then you are not guessing.

Apr 20, 2011 | 1997 Saturn SL

1 Answer

Vw polo maintains engine revs when foot is off the accelerator.


You need to check the cable the runs from the gas pedal to the engine, it might be rusty and need some drops of penetrating oil at the point it meets with the engine accelerator valve.

Feb 11, 2010 | 2007 Volkswagen Golf

1 Answer

318ti M44 acceleration problem


Have someone handy to press the gas pedal for you after the engine has warmed up well; best if driven.

While you listen at the exhaust pipe, have your helper increase the revs slowly and note whether the exhaust note changes to a hiss, instead of the sound of an engine firing.

You may have a decayed catalytic convertor and when they come apart inside, they can clog mufflers and resonators (the second, smaller muffler).

I've had this happen on more than one car and when it happened on a Fiat Strada years ago, since the routing of the system was fairly straight and made of heavier gauge stainless steel, I fired two shots with a .357 magnum into the tailpipe.
Never had another problem with it.

Jul 15, 2008 | 1996 BMW 318

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

105 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

76109 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8270 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...