Question about 1997 Pontiac Sunfire

1 Answer

Alll warning lights on

All dash warning lights are on and rpm gauge an temp gauges go on and off but fuel and speed gauges are fine

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Pontiac Master
  • 2,620 Answers

Faulty instrument cluster. You will need to replace it to fix this problem GM has had many problems with these cluster along with some others.

Posted on Mar 27, 2014

  • Derek Garrison
    Derek Garrison Mar 28, 2014

    how much work would this be to do ? the ;ady i got the car from said it started after she went into a pubble with car

  • Timllfixit Mar 28, 2014

    I think the clue may be there? I'm guessing there is water/moisture in the fuze box and/or one of the multi wire harness connections under the bonnet. See how many connectors in the main harness you can access and carefully pull them apart, WD 40 them and refit. Then have a good look at the underbonnet relay box etc. If access to fuze box is difficult but moisture is visible, try using a hair dryer. Don't use a paint hot air gun, its too hot!

×

Ad

3 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad
husni_g2002
  • 112 Answers

SOURCE: Gauges will not work 2004 aztec same problem with 2002 aztec

Switch ig. on, ground the sender unit wire for about 3 seconds see if the temp. gauge moves, if so change sender unit, if not then it is a faulty gauge reader.
also check instrument voltage stabilizer.

Posted on Jan 20, 2009

  • 17 Answers

SOURCE: all dash lights on

Many times, When electrics act up. it has to do with a ground problem. Fuses must be good you have power. Auto electrics like to have a single wire running to the device and then depend on a ground near by to grounded steel instead of a return wire. Loose grounds have no return and the device acts crazy and will be erratic, and not act properly. No where for the electricity to go. Eliminate the possibility of bad or missing grounds first, then get out an electric volt ohm meter, Start checking voltage, and eliminating things that have proper and constant voltage. Then look for bad devices. Just trying to save you some money. Electrical Trouble shooting can be time consuming and expensive. You can do it. lbreen

Posted on Apr 22, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

3 Answers

All meters in the dash board are not working..what cause this?


The main connected behind the dash board has come loose,

Sep 18, 2014 | 1995 Honda Accord

1 Answer

My 2003 Saturn VUE is saying that I'm over-heating (both the warning light stays on, and the gauge stay pegged hot) even after my car has been sitting in the driveway for 2-3 days (or longer). There is not...


i'd change the engine temperature sender unit , or just disconnect it for a while and see if the gauge symptoms disappear , if they do then change the temp sender unit,if the symptoms remain i'd say get the OBD codes read as may have a faulty dash component

Jul 04, 2014 | 2003 Saturn VUE

1 Answer

I had my Alternator changed yesterday on a Ford escort gti. The battery light was on and temp gauge was stuck past hot. Once changed all was fine but today I started it up and temp gauge is stuck past hot...


The temp gauge and battery light issues may not have been related.
The gauge reads high when the circuit to the temp sending unit is grounded. It could be the gauge on the dash, or a wiring problem, or the temp sending unit on the engine.

Jun 20, 2013 | Cars & Trucks

2 Answers

Gas, fuel, and temp gauge doesn't work


You have blown a fuse..check fuse box. There may be one fuse box one in the cabin but also check for the fusebox in the engine compartment.

Oct 04, 2017 | 1992 Dodge Caravan

1 Answer

91 mercury cougar dash panel


chec main maxi fuse in engine area--wiring harness mite have issue--or instrument cluster has failed-and they usualy need to be replaced-find magicmechanic online and send him issue-will tell u what to do

May 21, 2012 | 1989 Mercury Cougar

1 Answer

Wont start but turns over fine all gauges on dash dont move fuel gauge temp gauge and all warning lights are lit


Hello:
you will need to check the fuel pressure to see if your getting fuel, then pull off a spark plug wire and check for spark (spark should be blue) start there and this will help determine your problem.
Good luck

Jul 18, 2009 | 2002 Saturn S-Series

1 Answer

Problem with dash gauges and AC


I had this happen to me, and I was amazed to find out that the battery caused the probblem.It had two dead cells and it was only a week old.

May 27, 2009 | 2000 Pontiac Sunfire

1 Answer

Dash lights flicker and or go out on 04 Chrysler Sebring Conv.


On thedash of my 2003 sedan sebring ,My dash ilumination lights for the speed,temp,tack\rpm and fuel are unlit.
I found that there is a paper thin plastic across and behind all four of these gauges which lights up all four gauges,if working correctly, There is a very poor connection to this thin film lighting system ,basicaly a wire terminal used as a staple and that very well could be your problem.
It as far as I know would require whole gauge assembly replacement! because dealers dont sell such small portions of some assemblies!
I myself will attempt to crimp this poor connection on my car without damaging thin film! there are no bulbs for those four gauges too iluminate!

Jan 10, 2009 | 2004 Chrysler Sebring

Not finding what you are looking for?
1997 Pontiac Sunfire Logo

198 people viewed this question

Ask a Question

Usually answered in minutes!

Top Pontiac Experts

yadayada
yadayada

Level 3 Expert

76846 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22246 Answers

Jeffrey Turcotte
Jeffrey Turcotte

Level 3 Expert

8548 Answers

Are you a Pontiac Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...