Question about 2000 Chevrolet Blazer

3 Answers

Have 93 chevy s10, stopped and started just fine

Have 93 chevy s10, PU w/a 2.8l engine, throttlebody fuel injection,
5 speed manual, stopped and started just fine on my to work, went to leave for home, would not start. drizzled fuel into the carb, started up and ran til the fuel ran out. decided that it had to be the fuel pump. replaced fuel pump, and while i was at it, replaced fuel filter, fp relay, oil pressure switch. do not seem to have any power to the pump. i checked for power to the pump at the two wire connector plug close to the pump, one side had low voltage, 8.34 volts, the other side was dead. tried to run a 12 volt jumper directly to the pump at the plug close to the pump, that doesn't seem to charge the system either. no matter what i do, no fuel. a side question, can the computer be checked out of the vehicle? thx for your time

Posted by on

  • czicn34 Jun 16, 2009

    turned out that it was the relay and a bad ground. after checking and rechecking the ground, found one the was not grounded properly.
    got it fixed and it started right up.

×

Ad

3 Answers

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Chevrolet Master
  • 3,433 Answers

Ok, The fuel pump doesn't run installed. Make sure everything ia in place and connected. Then go for the Maf sensor on the air intake duct.. It controls the fuel through the ecu. Have you purged or attempt to purge yhe fuel system with the fuel manifold valve? Try all of the above before diving into wiring.

Posted on Jun 15, 2009

Ad
  • Level 1:

    An expert who has achieved level 1.

    Mayor:

    An expert whose answer got voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 6 Answers

The other wire that is "dead" is the ground wire for the fuel pump. try cutting that wire after the connector towards the pump, and running it to a good clean ground.

Posted on Jun 15, 2009

Ad
  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 15 Answers

I had the exact same problem. There's an orange wire that goes to the fuel pump relay it's supposed to have voltage but mine didn't. I simply connected a wire from the battery to the orange wire and the fuel pump started working again. The truck started right up.

Posted on Jan 22, 2015

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

93 s10 2.8 manual. Overcharging problem. Truck sat for 2years before I bought it I did full time up. Starts and idles fine. Anything over 50mph and it jerks and tries to turn off.


Check the fuel system pressure - sounds like the fuel pump or fuel pressure regulator. As you increase speed the engine requires more gas and it sounds like it's starting to starve at 50+.

Mar 08, 2017 | 1993 Chevrolet S-10

1 Answer

What would cause you to lose fuel pressure while driving.


Chevrolet S-10 Questions - Fuel System Loses Pressure ...

www.cargurus.com > Questions > Chevrolet > S-10

CarGurusJul 28, 2012 - Fuel System Loses Pressure - I have a 2003 Chevy S-10 Pick Up with the 4 ... car a few times, what essentially you are doing is priming the fuel pressure. ... A dirty fuel filter will not cause the lines to lose pressure after the engine is shut off. ... I have a 98 s10 2.2 liter and it was driving fine all day then when ...

Chevrolet S-10 Questions - My 2001 S10 has a hard starting ...

www.cargurus.com > Questions > Chevrolet > S-10

CarGurusSep 16, 2012 - My 2001 S10 has a hard starting problem if the truck sits between 1 ... Vacuum leak, have you checked fuel pressure while it sits? ... Would the spider alsocause a misfire at low rpms? .... at an idle, or squeaking while driving and it gets faster as you go? ..... 1994 Chevrolet S-10 2 Dr STD Standard Cab LB.

Chevy S-10 Won't Start - Repalced Fuel Pump and Pressure ...

www.cartruckinfo.com/chevy-s10-wont-start.html
Chevrolet S-10 pickup won't run and has no fire unless I jumper the fuel pump relay. ... Once the truck starts and is running you can remove the jumper to the fuel pump ... Iwould get the fuel pressure checked to start with, because that's where the ... 93 gmc 4.3l FI runs but dies out loss of power after 5 mins of running then ...

Stalling S10: I Have a 1994 Chevy S10 2.2l It Stalls After 35 ...


Dec 10, 2015 | 1994 Chevrolet S-10

1 Answer

Throttle housing diagram for 1996 Chevy S10. 4 cylinder pick up truck


Sorry I have the tech to send diagrams .
However I do have the factory manual for this engine .
Why don't you send some more information and likely I can solve your problem

Mar 14, 2015 | Chevrolet S 10 Cars & Trucks

1 Answer

Chevy s10 fuse box diagram


need to chack fuel regulater

Mar 26, 2014 | 1991 Chevrolet S-10

1 Answer

On my 93 chevy s10 4x4 blazer, my instrument panel worked before new motor was put in, after having the new engine put in, my fuel gauge, oil pressure, voltmeter, rpm, and my temp gauge all quit worki


Look for a missing ground strap from the engine to the body or frame. Remember the engine sits on rubber mounts so that ground strap is essential.

Feb 21, 2014 | Cars & Trucks

1 Answer

Got a 93 chevy s10 replaced fuel pump new spark plugs and wires and also new fuel filter will crank up but when try give it alot gas it cuts out bad


If it is the 4.3 check the oil and smell it,make sure the fuel is not going into the oil.There is a spider fuel injection unit under the intake.

Jul 21, 2010 | 1996 Chevrolet Blazer

1 Answer

93 s10 blazer, 4.3 engine code w...cranks and runs fine.new acdelco fuel pump in january. new plugs,cap and rotor button,new wires and coil. engine has a ''miss'' for lack of better word under load from...


I don' know if this could be your problem or not, but i had a simmiler problem on a 95 blazer i had,first i thought it was the egr valve, so i took it off cleaned it real good both valve and intake, put it back on it helped but it was still there, my friend a cert. michanic said it was in the injection system just a little skip in the engine when you were just crusing down the road at a steady speed like a gust of wind would hit you, at that time my friend witch is a certified michanic at a chevy dealer advised me to trade it off so i did, at that time it would cost me around 800 to 1000 bucks to fix, but i'am sure its a lot cheaper now, as this was 7 or 8 years ago. Thies injection systems were put on the 4.3 vortex engines, if yours is not a vortex i would say its still a problem with the throutle body.

Dec 31, 2009 | 1993 Chevrolet S-10

1 Answer

93" subaru legacy ( EJ22 with auto) engine stopped & won't start


Water introduced through the fuel system. Drain tank and lines, refill, and add HEET.

Dec 26, 2008 | 1995 Subaru Legacy

1 Answer

How to change 1988 dodge b150 1/2 ton 5.2L throttlebody fuel injection to multiport fuel injection


you should swap complete engines and ecus i have seen this set up installed in a 1938 dodge truck so yes it can be done

Oct 17, 2008 | 1988 Dodge B150

1 Answer

'93 Aerostar-stalls while driving/scary-stalls in 'drive' at stops


Wow!!! Now that's a headfull of problems....
This could be a great many things...
Check these before you sell. I have a '93 Aerostar and can't live without it.
1. Check idle speed
2. Fuel filter may be clogged or water in the fuel system.
3. Choke improperly adjusted or sticking.
4. Distributor components damp or damaged.
5. Faulty emissions components.
6. Faulty or incorrectly gapped spark plugs/ Also check wires.
7. Vacuum leak at the carburetor/fuel injection unit or vacuum hoses.
8. On 1986 models, stalling during idle or deceleration may be caused by sludge in the throttlebody. (2.3 litre engine)
9. On 1986 & 1987 models with a 2.3 litre engine,hesitation or stalling during acceleration may be caused by carbon build-up on the intake valves.....I hope this helps!! Adios

May 23, 2008 | 1993 Ford Aerostar Extended

Not finding what you are looking for?
2000 Chevrolet Blazer Logo

360 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

76051 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8265 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...