Question about 2001 Chrysler Town & Country

1 Answer

Speedometer dont work rpm gage drive between 3-4 radio wont come on heat blower dont work windows do not ro down anymore

Battery died when I charge it back up all my car accessories stopped working. my rpm gage drives between 3-4 my radio don't come on or my heat blower. windshield wipers don't work or my bright lights. The speedometer don't work it stays down at 0.

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Top Expert:

    An expert who has finished #1 on the weekly Top 10 Fixya Experts Leaderboard.

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

  • Chrysler Master
  • 42,022 Answers

Use a scanner to reset the CPU as the program is corrupted from the flat battery

Posted on Mar 26, 2014

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Mr Repair
  • 10 Answers

SOURCE: radio

First check to see if the fuse to the radio is burned out. Then check to see if you are in fact geting power to both the radio and the radio memory. There are two power wires going to the radio unit. One is always hot the other only when the key is on. If all of these things check out to be good you have a burned out tuner in the radio. It some times happens when the voltage is more than 12.5 volts.

Posted on Jul 09, 2008

  • 43 Answers

SOURCE: 2002 Sebring -Odometer Lights Flicker then bing battery indicator

have the engine wire harness checked maybe a communication problem between modules.

Posted on Mar 27, 2009

  • 91 Answers

SOURCE: windshield wipers on pt cruiser

the pump wire is probably not making good connection with the pump that is why the washer fluid wont work try and clean the connection. the pump is located under the fill tank

check for a bad relay for the wipers not working. the relay will be under the hood or under the dash next to the fuses. the cover will tell you what piece is the relay. the relay controls the delay in the wipers so that is probably bad and you can get them at napa for cheap. and simple to install its just like a fuse.

Posted on Mar 28, 2009

  • 101 Answers

SOURCE: my headlights,windshield wipers, and turn signals wont work

check all your fuses. replace any and all bad ones. if fuse blows again u have a short somewher

Posted on Jul 03, 2009

  • 16 Answers

SOURCE: my turn signals and windshield wipers stopped

replace multifunction switch.

Posted on Mar 27, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Wiper dont work speedometer dont work radio and heat blower dont work rpm gage drives between 3-4 bright lights dont work automatic windows and locks dont work


sounds like might b a main fuse. do u have a kick panel and a box under the hood? sometimes a main relay or fuse will cause many electric things to go out.

Mar 26, 2014 | 2001 Chrysler Town & Country

1 Answer

Radio fuse


there might be a fuse for the windows i doubt it there will be one for the radio but the speedometer do you mean the light wont work or the sppedometer itself if its the speedometer itself then it is the speed sensor and the gas guage its the sending unit or if its the light then if all the other lights work and those dont then take the instrument cluster off and replace those bulbs

Sep 18, 2013 | 1998 Oldsmobile Aurora

1 Answer

Rpm gage flickering,radio.heater fan all die while driving?


Have you had the charging system tested, it may be low voltage that is causing this or a defective battery connection due to corrosion or a loose cable or both.

Feb 10, 2012 | 1992 Geo Tracker

1 Answer

I was told I am able to ask follow up questions. My 2002 Mini Cooper has had problems lately and yesterday the car just died. The speedometer and rpm gauges stayed at 55 and 4000 even after the car died if...


The Mini cooper has a battery maintance log where it should not be allowed to go less the 12vlts also your battery is AGM so dont even attempt to recharge it unless it is a slow charge or tricle charge your are basically in need of a battery

Aug 01, 2011 | 2002 Mini Cooper

1 Answer

My rpm gage is not working, my speedometer is not working, my gas gage is not working, and my oil gage is not working, and my temperature gage is not working pretty much when i start up my car and drive it...


I'd wager that the fuse that controls the gauges is shot, or one of the internal connectors got unplugged (Fuse sounds more likely). Radio, Lights, and Turn Lamps are usually on seperate circuits.

Dec 28, 2010 | Ford Explorer Cars & Trucks

1 Answer

Driving and suddenly all the dash gages, a/c, radio stop working


your alternator is defective......have it checked for current output when it's loaded...all accessories on....alternators should put out about 100 amps as an average but it also depends on the state of the battery......the battery actually powers the alternator for the alternator to recharge the battery, so if the battery is bad, it will load down the alternator and possibly damage the regulators inside it....if the alternator is bad then it might damage your new battery......one way to check is to start your car, then remove either the positive or negative cable from your battery...the car should continue to run.....hold the gas pedal down until your rpm is about 1500 and turn on your accessories....if the car dies at that rpm ...then the alternator is definately defective.....voltage output will show 14-15 volts but not enough current and current is whats required for things to work right.....good luck....., the reason for at least 1500 rpm is because alternators don't put out until a certain speed is reached so at 1500 rpm, it should be more than enough for the alternater to produce current.

check for bad or corroded or oxidized connection of all ground and positive cables of the charging system as well.......bad connections cause high resistance to current flow and severly limits current capacity.....loose connections do the same thing......it's a good idea to clean or replace these cables first then try the above.

silvio

Jun 27, 2009 | 2005 Dodge Caravan

2 Answers

Electrical system issues


I believe what happened is the battery died and the computer lost its memory, you didn't hook the jumper cables up backwards at all did you even for a minute?
Does it run now do you have a battery meter what does it read?

Aug 15, 2008 | 2007 Kia Rio 5 Sx M/T Hatchback

Not finding what you are looking for?
2001 Chrysler Town & Country Logo

203 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chrysler Experts

yadayada
yadayada

Level 3 Expert

75744 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22114 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8123 Answers

Are you a Chrysler Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...