Question about 2011 Ford Mustang

1 Answer

Temperature gauge doesnt work and temp light is on

After engine rebuild, the water temperature gauge does work and light is also on

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Top Expert:

    An expert who has finished #1 on the weekly Top 10 Fixya Experts Leaderboard.

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

  • Ford Master
  • 23,148 Answers

Is the temperature sensor connected?

Posted on Mar 25, 2014

Ad

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad
latoss101
  • 47 Answers

SOURCE: 95 ford f-250 4.9 engine

no you need to get service key reset ok m8

Posted on Jan 03, 2009

  • 2 Answers

SOURCE: Dash Temp Gauge reading extremely hot

I had an issue with my 95 taurus and we ended up having to replace the thermometer

Posted on Mar 05, 2009

SOURCE: where is the AIT located on a ford focus 2007

I'll assume you mean the IAT (intake air temperature) sensor. And while i'm not very familiar with the exact motor in your vehicle, the sensors are generally mounted on the Intake tube from the air box to the throttle body, sometimes mounted on the air box itself, or possibly even built into the Mass Air flow sensor. Which will be mounted most likely on the air box before the intake tube.

There is more than one water temperature sensor. One is for the ECM and the other for the guages. If the ECM one is unplugged it won't affect the gauges.

Posted on Oct 22, 2009

  • 20 Answers

SOURCE: why won't the oil and temperature gauge work on

you should switch the temperature sensor and oil pressure sensor you had on your first engine,because your new engine must come with the light indicator dashboard so the sensor of your new engine are not compatible with your gauges....lipak!...

Posted on May 05, 2010

  • 1114 Answers

SOURCE: 1998 ford ranger 3.0. Heat

Hello did you flush out the cooling system while you had you coolant drained?this would be ideal to do at t hat time.Also be sure to bleed All air out of cooling system to avoid air lock.

Posted on Dec 25, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a 2008 Saturn Aura XE and the check engine light is on and the temperature gauge is not working.


have you checked the water in the radiator lately
probably overheated and the gauge is not working because there is no water to measure the temp in

May 24, 2016 | 2008 Saturn Aura XE

1 Answer

Engine Temperature Gage at the Instrument Panel not working


Your temp.gauge is probably bad ! Check for voltage at the coolant temp. sender ! You have to check it with the engine running . The red with white stripe should have a voltage the other wire ,yellow with red stripe is ground side ! Instrument panel fuse box fuse # 15 a 10amp fuse powers the gauges ,if your gas gauge works it's not the fuse . The dome lights get there power from an other fuse an circuit ! Did you check the bulb ? Check fuse # 8 IP fuse box , also a 10amp . Check for voltage at the dome light ,switch on !

Aug 13, 2015 | Ford Cars & Trucks

1 Answer

Temperature gauge doesnt work


Are you getting heat?If so then the temp. sensor is faulty.It's a cheap fix for what you have already done

Jan 18, 2014 | 1994 Mercury Tracer

1 Answer

Temp gauge and blazer jumps around when driving


Vehicle temperature gauges (temp gauge) read the temperature of the liquid in cooling system. From what I understand, the temp gauge jumping around has since gone away after you placed water into the radiator. It is very possible that water converted into steam was trapped in the cooling system and reached the temp sensor in your engine. The vehicle moving caused this steam to shift around reflecting rapid changes in temperature on the sensor, causing the needle to jump around on your console.
Hope this helps.

Nov 06, 2013 | 2001 Chevrolet Blazer

2 Answers

Is it normal on 94 grand prix 3.1 for the temp. gauge to NOT stay at a steady temp. all the time? mine seems to go up to 210 at a stop light then go back down after i start rollin again, i just had air...


Have you checked your cooling fan to see if it is working propely? Let the car idle and get warm and listen for the fan to kick in (if they are electric) or just watch to see if the fan starts to spin faster if it is the old school type with a clutch. Have you replaced the thermostat? A bad one will let the temp rise since it opens too late and then the temp will drop off. But it won't due this only at a light and it will do it infrequently.

Apr 18, 2013 | 1994 Pontiac Grand Prix

1 Answer

Why won't the oil and temperature gauge work on


you should switch the temperature sensor and oil pressure sensor you had on your first engine,because your new engine must come with the light indicator dashboard so the sensor of your new engine are not compatible with your gauges....lipak!...

May 05, 2010 | 1988 Ford Ranger

3 Answers

97 saturn sl2 temp light flashing and low coolant light flashing what could be the problem ? coolant is full and the heat works.


If the temp gauge is reading normal, the lights are flashing, and the coolant level is full, the level sensor in the coolant bottle is the problem. I'm a service consultant for a Saturn dealer and I've run across this many times.

Apr 17, 2009 | 1997 Saturn SL

1 Answer

1996 Cutlass Supreme-Temp shows hot even after engine rebuilt


is the temp gauge sender new
or the engine cooling fans spinning fast enough
air in the heating pipes ? bleeding

Feb 28, 2017 | 1996 Oldsmobile Cutlass Supreme Coupe

1 Answer

Gauge temperature


Your description of the problem is not very clear. It seems as if your temp gauge does not work, or does not indicate the correct temperature.
If you disconnect the wire from the sensor unit and put it to battery negative (ground), the gauge should move to the full hot position. If this does not happen the best chance is that the gauge does not work. If it does work, the sensor is faulty. In a very unlikely situation, the wire could be faulty..

Aug 29, 2017 | 1999 BMW 318 ti

Not finding what you are looking for?
2011 Ford Mustang Logo

Related Topics:

51 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

76846 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22246 Answers

fordexpert

Level 3 Expert

5546 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...