Question about 2002 Chevrolet S-10

1 Answer

Truck runs good at idle but after running it starts to miss fire as if running out of gas

Checked firing order and wires all good. do you think it could be the fuel pump?

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    MVP:

    An expert that got 5 achievements.

    Greenhorn:

    A rookie expert who has answered 20 questions on their first day.

    Cheetah:

    An expert who has answered 20 or more questions within one hour.

  • Contributor
  • 71 Answers

Install a fuel pressure gauge. Key on engine off it should build close to 60psi and back off a few lbs. It should hold steady and not drop off. If it does drop off, replace the pump. Engine running at idle, it should be reading right around 52-54 psi. The engine will barely start/run at 50 psi.

Posted on Mar 24, 2014

  • dbsr7000
    dbsr7000 Mar 26, 2014

    If it isn\'t the fuel pump, I had to shim the crankshaft sensor on my 2002 to stop a misfire p0300 code. I also have read that a leaky spider can cause that also. Go this helps

×

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Truck is not firing on 3 cylinders yet it runs.. Runs really rough, back fires, under powered.. Plugs are Wet, Firing order is correct. New Spark plug cables. Don't know that is wrong! Please Help


Check for spark at the plug ( may have coil problem).
If spark is good then do a compression check. Pressure shouldn't be less than 75% of known good cylinders.

Apr 17, 2013 | 1995 Dodge Dakota

3 Answers

My husband did a tune up on my car yesterday and now it wont start it will turn over like it wants to start but it wont he said that its miss firing we have bought 3 new coil packs and still will not start...


If your car is miss firing and your husband changed the coil packs,the wires leading from coil packs to sparkplugs must have got crossed.This will change car timing which will result in the car miss firing.He needs to go over wiring and correct problem for car to run right.You can go online to autozone.com and type in Info about car to get the correct wiring layout.Your problem isnt the new plugs n wires.Its the wiring layout.

Feb 09, 2011 | Pontiac Grand Am Cars & Trucks

1 Answer

Engine missing --started missing all of a sudden . replaced plugs and cam sensor in dist.. Roter and dist. cap and wires in good shape. Had a test on the engine, said that it was miss fireing at several...


On my 2002 safari I had a inter miss fire. After double checking all electrical. I had a bad injector of all things that was bad. My not be ur case but I thought I would mention it

Feb 08, 2010 | 2000 GMC Safari

1 Answer

My truck didnt pass smog they said it was a firing issue and some gas isnt getting burnt..is it the spark plugs? are they out of order?


If your plugs weren't wired right you would have trouble with missing, rough idle if it would start and run. Some gas not getting burnt suggests that a tune up may be in order. New plugs, wires, cap and rotor. It would be a good idea to have the throttle body checked out, 16 years of gas flow will wear it and maybe its putting out a little too much gas. Going one hotter on your plugs could also help get rid of that unburnt gas. Make sure there are no codes that would affect gas consumption, if there is fix them first. Hope this helps.

Sep 24, 2009 | 1993 GMC Sierra

1 Answer

Miss firing


could be a wire crossed, or it's out of time. since you used motorcraft plugs, did you set them properly to the correct gap? replacing plugs without gapping them can cause the sluggishness, out of time can cause the mis-fires and rough running.

Nov 27, 2008 | 1994 Ford F150 Styleside Supercab

Not finding what you are looking for?
2002 Chevrolet S-10 Logo

66 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

75797 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22114 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8152 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...