Question about 1997 Cadillac Eldorado

1 Answer

Runs hot has anti-frezze can it be water pump

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Sergeant:

    An expert that has over 500 points.

  • Expert
  • 319 Answers

It could be the pump, thermostat, or a bound up heater hose. I would start with a complete power flush, or buy the kit and do it yourself. Then replace the thermostat, if that doesn't work, then have the water pump replaced.

Posted on Jun 14, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Rear heater core is hot in and out the condersor is cold


It is pluged. That is why you have cold air blowing. If it is possible take the heart core out and drain all the anti frezze out you can. Fluch it out with water as much as possible. Put some water into one side of it and see if it comes out the other. If not add about a half cup of draino in it and let it set for about 10 min. If water runs threw it ya got it if not add some more untill you get the water to flow through it freely. Reinstall and you should be fine.

Dec 01, 2012 | 2000 Ford Expedition

1 Answer

My 98 chevy malibu is running a little hot. the heads are not cracked.changed the anti freeze.change the thermostate. what could be the problem


If your engine is running fine with no miss in it possibilities could be radiator fan or water pump if the radiator fan is working fine it could be the water pump. I have seen a water pump after removing it where the fins on the pump were completely worn out causing the overheating.Let me know how this turns out for you thanks.

Jul 27, 2011 | Chevrolet Malibu Cars & Trucks

1 Answer

I drained the cooling system and refilled with antifreeze. Now it runs hot. I know the water pump and thermostat are ok


If you filled it with straight anti-freeze, it will run hot. Anti-freeze needs to be diluted with water to work properly. Use the guidelines on the jug to figure the proper mixture for your area. If unsure, usually 50-50 is a good mix (but I live in the SE US). I was guilty of the straight anti-freeze usage in the '80's and was told I had to mix it...and when I did, everything worked properly.
Hope this helps...if you didn't use straight antifreeze, then this is of no help :)

Jan 30, 2011 | Toyota Previa Cars & Trucks

1 Answer

Antifreeze seems to be running out down by starter. however we thought maybe it was the thermostat because no hot air no water in oil.


This could be the water pump. If you are losiing anti-freeze it may be the water pump, but check the hoses first. One of the hoses could have develope a leak.

Nov 28, 2010 | 2005 Dodge Ram 3500

1 Answer

My newly purchased 1995 buick regal custom has started leaking antifreeze. is this a common problem and what would be my next step. is it something that requires immediate attention?


first you need to find out if the raidetor is leaking or if the water pump is going out. if water is runnig down the block where the pup is thaths your problem...aslo be awear animals love the sweet tast of anti-frezz and will kill thim so if you have pets watch thim as well. best of luck

Nov 28, 2010 | 1995 Buick Regal

1 Answer

My car is leaking anti-freeze daily and there is a noise like maybe a barring sound. The anti-freeze leaks when I turn the car off and then runs hot until I put more in it? Could this be the water pump?


Yes, it is the water pump, the bearing to the water pump have gone bad, and that's where more then likely where the water is leaking out of, be careful, if engine gets to hot , the cylinder heads will get damage, then you be looking at alots of $$$ to repair.Hope this was very helpful, good luck.

Sep 16, 2010 | 2006 Dodge Grand Caravan

2 Answers

Leaking anti freeze in the right under the hood near right front tire


it could be the water pump if the front of the engine is on that side. or heater hoses. with the engine cold, fill the system full. use straight water so you won't waste anti freeze. run the car until it gets hot. the system will pressurize. inspect the suspected area. the leak should be apparent. if the leak appears to be running from the engine block, it's most likely the pump.

May 22, 2010 | 1997 Honda Civic

1 Answer

93 acura legend doesnt run hot for a few days after i add coolant, then it starts to run hot, its low on coolant, i smell coolant sometimes, but i never see it on the ground, no water in the oil, or steam...


Could be water pump yes. Look where the water pump shaft is and see right behind where the shaft enters the pump and see if you see a small hole on either side of the pump. See if there is any anti-freeze coming out of the that hole or anywhere around the water pump housing. If you see anti-freeze coming out then the pump is probably bad and needs to be changed. You could also be loosing it from the heater core although most of the time you will notice a substance on your inner side of windshield that when you try and clean it only smears. Looks like a film on the windshield inside of the car. You will also smell anti-freeze pretty strongly inside of the car especially when you use your heater.

Dec 10, 2009 | 1993 Acura Legend

1 Answer

1994 nissan pickup--heater not blowing hot enough air


your fan motor is shot, motor has bad brushes replace it, if u feel its still not hot, drain your rad and but a 28 oz bottle of pine sole and add water till full, run it for about 20 mins. drain, run strait water, drain, then put anti frezz in with water, 50/50 mix or mix your own. it should clean your cooling system compleatly out.. do not turn heat on while pine sole is running throw it, gives of a bad smell.

bert

Jan 28, 2009 | 1994 Nissan Pickup

Not finding what you are looking for?
1997 Cadillac Eldorado Logo

Related Topics:

127 people viewed this question

Ask a Question

Usually answered in minutes!

Top Cadillac Experts

yadayada
yadayada

Level 3 Expert

76846 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22246 Answers

Ronny Bennett Sr.
Ronny Bennett Sr.

Level 3 Expert

6927 Answers

Are you a Cadillac Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...