Question about 2004 Ford Explorer

1 Answer

No guages or check engine lite

No tach/speedo

Posted by on

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 8 Answers

Not sure what all you have looked at to diag the problem, but I would start by checking fuses to see if one has blown.

Posted on Mar 24, 2014

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Tach problems


If you have an after-market radio, suspect the CHASSIS GROUND CONNECTION for the instrument cluster.
Also, check all fuses to be sure it isn't a blown fuse.

Aug 10, 2014 | 1994 Ford Mustang

1 Answer

Instruments don't work, key stuck in ignition, doesn't shift correctly


Sounds like you need a new car.
With joking aside, the problem with your speedo, tach, gas guage, temp gauge and odometer can probably be one of two things. Check your fuses. If they are fine you may need to replace your cluster panel. I had to have the entire thing changed over my speedo not working right. It was not cheap. You might want to check the relay box under the hood. Does your transmission leak? Check the fuses and relay on it also. Get a new ignition switch and replace the old one if your key is stuck. You can try WD40 on that key but don't expect any miracles. The bearings are likely shot. Sorry I posted all of this bad news. Good luck.

Jan 05, 2014 | 1998 GMC Jimmy

1 Answer

1984 nissan pickup dead speedo, tach and fuel guage


Have you checked to see if the instrument panel has a good ground connection? Rust is NOT your friend when it comes to electrical connections!

Apr 22, 2017 | Cars & Trucks

1 Answer

MY 2001 VW CABRIO GUAGES ARE FLICKERING AND NOT WORKING PROPERLY FUEL,TEMP,SPEEDO,TACH WHAT CAN I DO


the case you have disconnect on the ground ( brawon coler) inthe claster . all guage have one ground check the braown coler wire but don't remove or disconnect the calster it may lose key prog try disconnect battarry then check from guage bording up to dash bord bracket . try make sure you have no short with any sender ( fuel .tem. or speedo)

Jul 27, 2011 | 2001 Volkswagen Cabrio

1 Answer

My 92Cadilac Eldorado check engine lite comes on an the speedo stops tach still works but when I come to a stop it won't go back in to first gear I have to manually put it in first but then it is only...


hi there it sounds like the problem your having is the speed sensor.
before replacing check the wire connection if no broken wires.replace sensor .
the speed sensor is on the transmission.

Jun 12, 2011 | 1992 Cadillac Eldorado

1 Answer

I have a 98 bmw 318ti and the tach,speedo, fuel guage and temp guage stopped working all the dummy lights work (check eng, seatbelt etc) any suggestions??


there are buttons are not working, the first one which is responsible to operate the four lights togather ( flasher lights ) . the second buttong is responsible to lock the doors . boh of these buttons are located beside the gear stick.

Dec 28, 2010 | 1999 BMW 318 ti

1 Answer

All the guages are at zero. speedo, tach, gas, oil pressure, etc. Could it be a fuse?


Yes, sounds like a fuse. Check the owner's manual for what fuse controls what function.

Nov 04, 2010 | 2003 GMC Yukon XL

1 Answer

The guages don't work, then, at any given time, they will just begin working. Nothing on the dash will work...no tach., speedo, temp, gas guage and automatic door locks...nothing. Then, out of the blue, as...


You have to remove the under hood fuse / relay box and disassemble , check for broken / corroded wires in the harness plugs at the bottom and broken solder joints at the board. I have repaired many of these for the same problem. hope this helps8c02778.jpg

Oct 15, 2010 | 1997 Dodge Caravan

1 Answer

1999 996 carrera speedo and tach does not work(analog and digital


maybe the speedo drive has stripped some teeth. good luck!

Jul 27, 2009 | Porsche 911 Cars & Trucks

Not finding what you are looking for?
2004 Ford Explorer Logo

Related Topics:

22 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

76164 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

fordexpert

Level 3 Expert

5520 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...