Question about 1993 Ford Explorer Limited

2 Answers

I have a 1993 Ford Explorer that goes into high idle when I put in gear. It does this when the engine is hot or cold.

Explorer Limited 4wd with 4.0L V6 automatic. Runs great. Idles correct (600-900 rpm) cold or hot when in park or neutral. RPM jumps to 1600 when put in gear (Reverse or Drive). Replaced EGR valve and Vacuum Solenoid valve recently to clear a code.

Posted by on

Ad

2 Answers

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Top Expert:

    An expert who has finished #1 on the weekly Top 10 Fixya Experts Leaderboard.

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

  • Ford Master
  • 2,899 Answers

On some cars there's a speed sensor on the clutch or transmission. That might cause an idle problem.

Posted on Apr 16, 2015

Ad
  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Top Expert:

    An expert who has finished #1 on the weekly Top 10 Fixya Experts Leaderboard.

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

  • Ford Master
  • 35,614 Answers

Replacing the parts mentioned may have cleared the code without solving the real problem.

Posted on Mar 24, 2014

Ad

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
New users get 2 Free calls (no credit card required) and instant help on almost anything you can think of (from cars to computers, appliances, handyman, and even pets).
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

kirkx
  • 2019 Answers

SOURCE: my 1990 ford ranger running

Use a length of rubber hose to listen around for the leak.
Or use some brakeclean or starting fluid to see where the leak is by it reving up. (stay away from the alternator).
Pinch off any vacuum hoses, one at a time, looking for one that makes a difference.

Posted on Aug 11, 2010

dncholas
  • 222 Answers

SOURCE: 1990 Ford Probe 2.2 automatic stalls in forward, reverse OK

Sounds like a bad IAC (idle air control valve/sensor) that controls your idle when going from throttle to idle. If bad your idle will act crazy and can cause stalls easily. Pretty sure that's it.

Posted on Aug 21, 2010

  • 369 Answers

SOURCE: when bought engine idled @ 800 rpm when warm, now

could be numerous reasons. this is your best bet take it in to a mechanic and have your engine codes scanned. it is a minimal charge, some even do it for nothing it only takes 10 minutes.this will point you in the right direction.

Posted on Jan 27, 2010

vetteman3002
  • 2299 Answers

SOURCE: i have a 1991 ford

Are you sure that the change in elevation is changing the problem? Or is it just quit after the engine warms up? Does it do it when you get back home? The reason I am asking if the idle is normal after warming up and only high when it is cold, I would suggest the mass air flow sensor. But need to make sure that it is a elevation issue.

Posted on Oct 27, 2010

emissionwiz
  • 76649 Answers

SOURCE: 1993 ford f350 7.5 460 i have problems with the high idle in park sometimes other gears mostly park the funny thing is when cold it runs at 1,000 rpm and when hot it go's 1,250-1,450 i replace the

Check the engine intake and all vacuum hoses for leaks, do this with a can of spray carb cleaner, if you hit a leak the idle speed will change. Repair what you find.

Posted on Aug 09, 2012

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

F250 1993, 4WD will not engage, hubs locked,light comes on? some times a little grinding, workes until I chang gears and goes out.


Ford has fiber gears that have a tendency to grind away and no longer work, requiring replacement.

Feb 01, 2015 | 1993 Ford F250

1 Answer

Ford explorer idling too high


High idle is in almost all caused caused by a vacuum leak on the engine, get a can of carburetor spray and spray around the top of the engine, if you hit a leak it will make the engine sound different and there will be a sucking noise. Also check for hoses that are leaking that connect to the intake vacuum source. If no leaks are found you will need the system scanned for faults in the idle speed control system.

Sep 10, 2012 | 1993 Ford Explorer Limited

1 Answer

1993 ford f350 7.5 460 i have problems with the high idle in park sometimes other gears mostly park the funny thing is when cold it runs at 1,000 rpm and when hot it go's 1,250-1,450 i replace the


Check the engine intake and all vacuum hoses for leaks, do this with a can of spray carb cleaner, if you hit a leak the idle speed will change. Repair what you find.

Aug 09, 2012 | 1992 Ford F350

1 Answer

High idle on cold start on a 86 dodge d50 2.0 liter


Feb 27, 2012 | 1986 Dodge Pickup 4WD

1 Answer

My 1993 ford explorer stalls right out after 15 mins of driving


FAULTY FUEL PUMP.A BAD FUEL INJECTOR .OR COULD BE IDLING TOO LOW ALSO IF ENGINE GETTING TOO HOT OR OVERHEATING.CHECK THE ANTIFREEZE LEVEL.TO SAVE TIME AND MONEY HAVE IT SCANNED.

May 06, 2010 | 1993 Ford Explorer Limited

1 Answer

What is the firing order 93 ford explorer v6 4.0


1993 Ford Explorer 2WD & 4WD
4.0 liter SOHC V-6 VIN "X"

1a7600c.gif

Hope helped with this (remember rated this help) Good luck.

Nov 26, 2009 | 1993 Ford Explorer Limited

1 Answer

I cant remember what I had replaced about 5-6 months ago, seems like it was a sensor. My 1993 Ford Explorer is not running or idling at normal speed. When I pull up to stop it is like it stays engaged and...


listen for a hissing noise(vacuum leak around the pcv elbows or upper intake gaskets) this will cause a high idle set off lean codes which will say bad o2 sensors alson check idle air control valve which is located by throtlle body this will stick causing the vehichle to not run at idle sometimes taking it off and cleaning the carbon buildup out will fix the problem use some break cleaner

Feb 23, 2009 | 1993 Ford Explorer Limited

1 Answer

Idle too high


The throttle linkage may be sticking. May have a vacuum leak at the intake manifold or with the hose connections.

Jan 01, 2009 | 1999 Ford Explorer

Not finding what you are looking for?
1993 Ford Explorer Limited Logo

286 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

76649 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22219 Answers

fordexpert

Level 3 Expert

5537 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...