Question about 1985 Toyota Celica

1 Answer

I have put a new full pu,p and a new fule pump relay and it still isnt cranking

It turns over but still isn't getting fire. we have put a new alternator, and a new fuel pump and a new fuel pump relay. we are at witts end.

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Top Expert:

    An expert who has finished #1 on the weekly Top 10 Fixya Experts Leaderboard.

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

  • Toyota Master
  • 42,120 Answers

Run fault codes and check for cam / crank position sensor . Check that the cam shaft is turning ( broken timing belt/chain) check immobiliser is operational

Posted on Mar 24, 2014

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I put a new fuel pump in rear tank and fuel filter but not starting.im getting fire at fuel pump but no fire from relay .i put new relay still nothing


Fuel pump will usually only run when on Crank. When engine fires up then it stays running. This is so it won't pump in a crash.

Jan 31, 2015 | Cars & Trucks

1 Answer

1988 chevy S10 2.5L tbi


out of time. get piston num. 1 to top dead center on compression stroke then make your rotor on dist. point to #1 and it should fire up. you may have to then turn the dist. some to get in in specs.

Feb 18, 2014 | 1998 Chevrolet S-10 Pickup

1 Answer

Have a 1999 ford explorer sport 4x4, cranks want start. have replaced fuel pump, crank senser and cam senser, checked fuzes, replaced computer. doesnt seem to be firing


When you turn the key on you should beable to hear the fuel pump come on. Other than that you have a fuel pressure test port, looks just like a tire valve stem get a little probe press the valve after cranking fuel should come out strongly and not dribble out. If is doesnt seem to be firing your going to have check the coil pack for spark from the coil pack take one plug wire out and put it in a position that as you crank the vehicle you will be able to see spark jump or even hear give it a 1/4 air gap from its connection. If you dont have spark and your timing chain isnt broken you need to check for power the choice of tool is a test light.or volt meter. If you dont have either test tool we will go by sound when you turn the key on the engine fuse box has relays do you hear them click. That click noise will be fuel pump relay and PCM relay for power inpect those relays for corrode connections you mainly have a power problem and inspect for proper ground a missing ground can also cause the ECM to not fire the coils2_26_2012_7_32_43_am.gif

Feb 26, 2012 | 1999 Ford Explorer

1 Answer

After changing out the radiator the fan comes on all the time and the fuel pump isn't working, I tryed a new brain box but that didnt fix it. any help ?


It is not the PCM. The fan on all the time says you may be in failure mode, with fixed values by the PCM. You disconnected something electrical during the radiator swap out. The fule pump should come on for 5 seconds when you turn key to ON, and humm. Then turn off.

The power relay should turn on the PCM, which in turn, turns on the fuel pump relay to acitvate the fuel pump. Check the power relay first.

I think this relay is under the hood in the relay box. See owner manual.

Oct 11, 2011 | 1994 Ford Taurus

1 Answer

CHANGED THE FUEL PUMP,THE FUEL FILTER,THE O2 SENSOR,THE SPARK PLUGS,THE ECT SENSOR, THE IAT SENSOR, NEW FUEL PUMP FUSE, BUT IT DOES NOT WANT TO CRANK


IS THERE POWER TO THE FULE PUMP DID YOU CHECK THE FULE PUMP RELAY YOU CAN CLICK OFF AND ON WHEN TURN THE KEY OFF AN ON ITS UNDER THE HOOD DO YOU HEAR IT CYCLE WHEN TURN THE KEY TO ON POSITION HAVE SOME ONE TAKE THE GAS CAP OFF AND LISTEN FOR THE FULE PUMP TO RUN FOR FIVE SECONDS IF THEY HEAR IT THEN PUMP IS RUNNING AND OK WHEN YOU TURN THE KEY BACK OFF WAIT 10 SECONDS FOR IT TO RESET AND IT WILL CYCLE AGAIN WHEN YOU TURN THE KEY ON .. IF THAT IS OK CHECK FOR SPARK AT A PLUG IF YOU HAVE SPARK AT THE PLUG THEN ONE SHOT EITHER IN THROTLE BODY AND TRY TO START IF IT FIRES THEN WE CAN TAKE FROM THERE LET ME KNOW HOW YOU DO HERE POHLCAT

Mar 04, 2011 | 1995 Isuzu Rodeo

1 Answer

My car want get any fule iput a new fule pump still no fule istraight wired it and got fule but no fire is there a sensor that would cause it to loose power to the fulepump and cause it not to get fire


Check out your fuel pump main relay and fuse. Often the relay that controls the main fuel pump is also the one the supplies voltage to the coils.

Oct 13, 2010 | 1998 Buick LeSabre

1 Answer

I have a 1998 ford wind star new fule pump but still not geting fule , wont crank engine turns ove but won;t start


INSTALL PRESSURE GUAGE THEN CK, VOLTAGE TO PUMP PCM TURNS ON PUMP RELAY FOR 2 SECONDS WHEN KEY CYCLED ON ,, IF NO POWER CK INERTIA SWITCH ( MAY BE TRIPPED ) IF NO POWER TO INERTIA SWITCH CK FUEL PUMP RELAY IF NO VOLTAGE AT PUMP RELAY THEN CHECK FOR SPARK AT PLUGS IF NO SPARK CK PCM POWER RELAY IT SUPPLIES VOLTAGE TO PCM THAT INTURN POWERS FUEL PUMP RELAY

HOPE THIS HELPS

Aug 08, 2010 | 1998 Ford Windstar

2 Answers

My fuel pump is not working but ther is power going to the pump and i just replaced the pump and relay


hope you used oe typ pump to many isuses with after market pumps so any way if you have power at pump what is voltage needs to be 12v at least pull hose see if you have fule coming out power the pump your self now if you got after market pump did you replace the pig taile with supled updated one should ben in box .if not need put new pig tail on hope this helps

Aug 13, 2009 | 1996 GMC Sierra

1 Answer

New fuel pumpis working but there is no power getting to the pump


sounds like the ecm relay. that has to work in order for the processor to turn on the fuel pump relay.

Jun 21, 2009 | 2003 Ford Crown Victoria

Not finding what you are looking for?
Cars & Trucks Logo

93 people viewed this question

Ask a Question

Usually answered in minutes!

Top Toyota Experts

yadayada
yadayada

Level 3 Expert

75817 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8180 Answers

Are you a Toyota Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...