Question about 1994 Chevrolet S-10

1 Answer

Running bad i just changed the the spider unit in my 1994 s 10 cmfi it was running and not mising but it was pumping fuel when it was cold and you could small fuer real bad and it was smoking gas vapors now it is running rugh like its not firing on all cyclenders , is there a serten way the popets go on ? order i put them on the way the other came off ! changed the iac ,nothing cleand other parts no v leaks the only code it came up with is 44 ?? help i need my car for work

Posted by on

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Contributor
  • 27 Answers

Egr valve is stuck open,replace it and it will run.i dont know why they go bad when the spider does

Posted on Nov 21, 2014

Ad

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad
  • 599 Answers

SOURCE: Service Engine Soon Light and Rough Idle (Below 1200 rpms)

do you get check engine codes?..have you done a leak down test and compression test to determine mechanical engine health?

Posted on Oct 07, 2008

  • 341 Answers

SOURCE: really bad gas milage

The 93-94-95 all have this problem ..the fuel line that come into the back do split and leak ..other problem is with vaccum lines coming off the back of intake and vacuum lines come apart from a 3 way fitting.located fire wall .when these are off will cause gas smell and bad millage .... hopes this helps...

Posted on Dec 10, 2008

txkjun
  • 409 Answers

SOURCE: 2000 silverado 4.8 v8 runs bad when it is cold out side.

Try replacing the coolant temperature sensor for the injection system.

Posted on Jan 11, 2009

morse008
  • 1111 Answers

SOURCE: 2001 chevy 3500 van Fuel pump out?

1st ensure the fuses are all good and there is fuel in the vehicle and your not getting a false reading by tapping on the tank ..does it sound Hollow oe Empty / another way is turn on the key and listen for the pump to work a slight humming should be heard ...if so locate the fuel bar and cap screw depress the valve shielding your eyes with say a towell and see if gas dispurses make sure the key is on while doing this if no gas is there or fuel pump is heard then it may be either a bad ground to the unit or the fuel pump itself corroded connections will contribute to this as well unclipping and reclipping the connection togeather should allow a better connection

Posted on Sep 26, 2009

whitehawk92
  • 15 Answers

SOURCE: 94 s10 blazer 4.3 vortec,idles pretty good when

check your idle sensor. or it can be the sensor thats hooked up on your catconverter. or a pluged cat conveter

Posted on Oct 17, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Ok i changed the spider on my 93 gmc jimmy. The fuel pump was working b4 i changed the spider, now all of a sudden u cant hear the fuel pump and there is no fuel running threw the injection lines. Does...


if i'm not mistaken there might be the fuel pump relay mounted on the firewall. you might've hit the connector on the relay when doing the spider.

Oct 16, 2013 | 1993 GMC Jimmy

1 Answer

My 1995 blazer 4.3 cmfi 4x4 stalled in town i got it home and i think i have it narrowed down to a fuel problem. it will try to start if i spray starting fluid in butterfly, fuel pressure is 61 and 58...


A grenade is a good option . You know it is a fuel problem, you will have to get into the injector system, and see what is wrong. That spider system must have given GM plenty of headaches, which could explain why they quit using it. IIRC, most of the problems had to do with the pot that held fuel and was distributed to injectors by hoses.

Jun 17, 2017 | 1995 Chevrolet Blazer

1 Answer

I have 1986 Alfa Spider that won't start. Car has been sitting for a year. I replaced battery, fuel tank, fuel sender unit, both fuel pumps. I seems that the in tank pumps is not getting any po


Could be the main or fuel run relay located in the compartment under the luggage rack, passenger side, main relay also, fuse for the fuel relay 8amp. Electronic Control Unit is also located there.

Could be electrical, Hook up a timing light, three leads: Power, Ground, and one that goes around the wire to #1 cyl. Turn the engine over and see if there's firing. Note: u can check all 4 spark plugs this way.

Fuse lead goes to pin 30 of the fuel relay, u can jump 30 across to 57 and check for the pumps running, if not, change-I suggest both relays, main and fuel run relays. Both pumps get their 12v DC from the fuel run relay, both should be running when you switch ignition switch to on, then a tachymetric signal is fed from the coil to the relay to keep it running.

Jun 10, 2012 | 1986 Alfa Romeo Spider

1 Answer

94 1/2 GMC Safari Vortec inj. Orphaned code reader Motor starts with starter fluid but will keep running. Not consistent. No codes on flash reader. 55-65 psi from fuel pump no drops when running....


I think you may have a bad spider. the pump can be changed by itself but I would do the spider itself if i was going to try anything else-good luck

Oct 06, 2011 | 1994 GMC Safari

1 Answer

Have trouble code 45 on a 1993 s10 blazer 4.3l. Have replaced oxygen sensor, did not help


1994 Chevrolet S10 Blazer 4.3L, Vin W Customer Concern: DTC 45 The spark plugs are black on both banks. Right bank plugs are damp. Removed the tuning valve and looked inside the plenum. Can see a washed/clean area on the right side. Fuel pressure is good, it holds when the pump stops. Tests/Procedures: 1. Remove the upper intake plenum cover and inspect for a fuel leak at the fuel pressure regulator.

2. Inspect the fuel pressure regulator and return lines and fittings at the left side of the plenum.

3 Replace the Central Multipoint Fuel Injection (CMFI) unit. Potential Causes: Leaking Fuel Line - One or more may have a problem.
Leaking Fuel Pressure Regulator
Tech Tips: The fuel pressure regulator may only leak at a cold or hot engine, only with vacuum applied, or only without vacuum applied. The leaking at the fuel lines and fittings have as often been the result of repairs as the initial cause of the problem. Handle the lines and fittings carefully. The fuel pressure regulator is a integral part of the Central Multi-port Fuel Injection (CMFI) unit. Any failure requires entire unit replacement.

Mar 03, 2011 | Chevrolet Blazer Cars & Trucks

2 Answers

My pickup just stops while driving, after it warms up. I have had to change the fuel pump fuse, then it will run ok while it is cold. Then it will blow the fuse and stop. Does this sound like relay or fuel...


You most likely have a bad wiring issue on top of the fuel tank sending unit/fuel pump holder bracket. A replacement of this unit will be necessary to rectify your condition; I change these quite often; a very common failure, with exactly the symptom you describe.

You will either need to drop the tank (hard), or remove the bed (easier) to replace the unit.

Oct 26, 2009 | 1994 Toyota Pickup

2 Answers

Car needs starting fuel to start but then runs ok.It is a 94 gmc jimmy V6


I'd try a new coolant temperature sensor. It may be telling VCM that engine is already warm, so no need for extra fuel to start cold.

Aug 07, 2009 | GMC Jimmy Cars & Trucks

1 Answer

1998 FUEL PUMP PROBLEM??


if it is a v6 vortex you need 60 psi to run vehicle, could be a bad spider assembly(fuel injector unit)

Nov 26, 2008 | 1998 GMC Blazer

1 Answer

Service Engine Soon Light and Rough Idle (Below 1200 rpms)


do you get check engine codes?..have you done a leak down test and compression test to determine mechanical engine health?

Oct 07, 2008 | 1995 Chevrolet Blazer

Not finding what you are looking for?
1994 Chevrolet S-10 Logo

47 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

76673 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22219 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8531 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...