Question about 2000 Alfa Romeo GTV

Open Question

HEATER BLOWER ONLY RUNS ON HIGHSPEED - 2000 Alfa Romeo GTV

Posted by Anonymous on

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My blower motor quit working changed blower and now it runs all the time even with key off worked fine before blower went out the fuse had also blown what could cause it to run all the time now


Most would say it is the Blower Motor Resistor or a relay..And possibly the dash heater control knob..However it is running all the time even with key off..This means it is getting power all the time from somewhere..It sounds as if wiring is crossed..Did you have to change wiring plug in connectors..?..

Feb 19, 2015 | 2004 Chevrolet Monte Carlo

1 Answer

I have a 2002 GMC Savana Cargo van with a a/c and heater blower that will not work. The problem started when I lost the low speed, then the medium, and finally the highspeed. Fuses and relays are ok.


You checked the fuse and relay, did you check to see if you had power at the resistor ?
American built vehicles control fan speed by the power circuit which goes thru the resistor. The high speed usually bypasses the resistor.
You may need a new blower motor or control switch.

Jul 20, 2012 | 2000 GMC Savana

1 Answer

Heater blower motor.,Highspeed only works..problem??


9 out of 10 times its the heater fan resistor doing this. it has wires that corresponed to diffreent speed settings for heater fan. the resistor is beside the blower motor, Your Kia Sportage Blower Motor Resistor controls the heating equipment in the vehicle by opening and closing the fan motor. The Kia Sportage Blower Motor Resistor allows the heating and climate control system to control the speed of the vehicle's cooling fan. its under the passenger side glove box. undo 2 screws and disconnect the electrical connector. thats it!!

Jan 24, 2012 | 2000 Kia Sportage

1 Answer

1997 Chevy S10 pickup Fan switch for heater runs on high only.


replace the blower motor resistor located on the heater box were the blower motor is located the wiring to the blower may go to it. This is very easy to locate if you buy the part first.

Jan 06, 2010 | 1997 Chevrolet S-10 Pickup

1 Answer

1999 contour heater blower doesn't work i


on blowermotor ground ground wire to a go metal ground and see if motor runs if it does then you have a bad ground. also try tapping on motor if it turns on then replace motor,hope this helps.

Oct 19, 2009 | 1999 Ford Contour

1 Answer

I have a 2000 ford E350 van with front and rear air. the front blower motor runs at low speed, The front blower still runs on low even when the knob is set on medium or high. I do not know where the...


it's either the blower motor switch or blower motor resister. Resistor ?Heater Blower Motor Switch Removal Remove the battery (10655) ; refer to Section 414-01 . Remove the battery tray. Remove the screws. Remove the battery tray. Disconnect the heater blower motor switch resistor connector. Remove the heater blower motor switch resistor (18591). Remove the two screws. Remove the heater blower motor switch resistor. ----------------------------------- Switches Removal Disconnect the battery ground cable. Remove the center trim panel; refer to Section 501-12 . Remove the control assembly. Remove the screws. Remove the control assembly. Remove the A/C-heater function selector switch knob. Disconnect the vacuum harness connector. Disconnect the A/C-heater function selector switch connector. Remove the A/C-heater function selector switch. Remove the screw. Remove the A/C-heater function selector switch. Remove the temperature control switch knob. Disconnect the temperature control switch connector. Remove the temperature control switch. Remove the screw. Remove the temperature control switch. Remove the heater blower motor switch knob. Disconnect the heater blower motor switch connector. Remove the heater blower motor switch (18578). Remove the screw. Remove the heater blower motor switch. ----------------------------

Mar 31, 2009 | 2007 Ford E-350 Super Duty Length XLT

1 Answer

Heater blower


Sounds like the blower motor resistor is bad. These things go bad all the time. and for the switching modes there is a vacuum line that runs under the window in the engine compartment and runs by the alternator, its tiny and may take a few minutes to find. check first by the evaporator case and follow it by the alternator to the driverside of the throttle body. these too break and will not allow the heater mode changes. the blower motor resistor controls the fan speeds and the vacuum line allows which vent the air flow goes through.

Feb 09, 2009 | 2000 GMC Safari

1 Answer

Heater fans Runs all the time


Check your resister in the duct just in front of the blower! Follow the wire from your blower to it and un plug it

Dec 23, 2008 | 1999 Chevrolet Silverado 1500

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

15 people viewed this question

Ask a Question

Usually answered in minutes!

Top Alfa Romeo Experts

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

yadayada
yadayada

Level 3 Expert

75117 Answers

ROBERT GARCIA
ROBERT GARCIA

Level 3 Expert

874 Answers

Are you an Alfa Romeo Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...