Question about 2003 Mercury Grand Marquis

2 Answers

A/C fan speed not working

A/C blows cold air but the fan speed switch does not work. At the same time the air suspension warning light came on and it seems the compressor is not working. I know they share a fuse but the fuse is okay, Are the problems related?

Posted by on

Ad

2 Answers

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Expert
  • 279 Answers

There are a total of 5 fuses which affect blower fan (correct terminology) speed. One is a 40 amp unit in the fuse block under the hood. (Passenger side) The other 4 are in the fuse block under the passenger side of the dash board. Check them all.
Charlie

Posted on Jun 14, 2009

  • Charlie Jun 14, 2009

    The other 4 fuses are all rated at 15 amps.
    Charlie


×

Ad
  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 16 Answers

Get a new one

Posted on Jun 14, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

03 Merc. Sable. AC works fine until I slow down in traffic, then it will slowly switch to blowing warm air


Have your a/c condensor fan checked out. It most likely is not working, or is not functioning at full speed. When you are driving air is being pushed through the condensor helping to keep your a/c cold, but when sitting in traffic there is no air flow if the condensor fan is not functioning at full speed.

Jul 26, 2014 | 2003 Mercury Sable

1 Answer

How do you check if the power if available to the fan when high speed is selected?


just unplug the fan motor and connect a tester with a light bulb to it turn the fan control on and watch for the light to get brighter as the speed goes up, if it does replace the fan motor . if not check fuses and power to the switch itself.good luck

Apr 07, 2012 | 2004 Isuzu Rodeo

2 Answers

06 Chevy Suburban Dash fan stopped working


this is because you have a bad switch which has gone bad and you need to replace it or either try to bypass it through another circuit.

Jul 25, 2009 | 2006 Chevrolet Suburban

3 Answers

99' Escalade a/c front vent blows cool air an rear blow cold air.


i have the same problem, my rear a/c blows great very cold, the front a/c blows but it is not cold at all. I had the the a/c seviced and it was vacumed and correct ammount put back in, no problems, the front still blows but it is not cold, i have checked everything and the a/c guy said it might be the door not opening. any help? still not working

Jul 13, 2009 | 1999 Cadillac Escalade

1 Answer

The AC blows on #4 fan setting but doesn't blow at all on 1-3


That is the blower resistor. 4 is wide open, so, no resistance. I had 4 of them put into my truck. The wires were burnt and shorted the others until the problem was found. Check the plug if you do this yourself.

Jun 13, 2009 | 2005 Chevrolet Colorado

2 Answers

1995 lincoln town car Rear air suspension problem


probably a leak in the system. check the switch in the trunk, make sure it is on.

Jan 10, 2009 | 1995 Lincoln Town Car

1 Answer

Heater only blows hot (well, warm) on full speed of fan


Replace the temp control on this car, it should be electrical control not cables.

Dec 03, 2008 | 2000 Ford Escort

1 Answer

Heater blows cold, and fan switch only works on 4 and 5


working on 4 and 5 speed that the resistor that broken cold air you got to move the selector to see the motor that move the trap hot and cold sometime when the motor was not move to the hot side for a long time its jam the motor on the passager side under dash put to hot and gently tap the motor tanks pierre

Oct 24, 2008 | 2002 Chevrolet Malibu

Not finding what you are looking for?
2003 Mercury Grand Marquis Logo

220 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mercury Experts

yadayada
yadayada

Level 3 Expert

76846 Answers

fordexpert

Level 3 Expert

5546 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22246 Answers

Are you a Mercury Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...