Question about Cars & Trucks

1 Answer

My CCM 404 DS has suffered a sudden loss of power If you rev it right up in neutral and close the throttle sharply it will frequently cut out once the revs drop near to idle It also stalls frequently when coming to a stop unless I keep a small amount of throttle on No longer lifts on acceleration though it is still accelerating with a fair amount of power and when you close the throttle even in 5th at road speed it slows down fast like you've dropped to 2nd to engine break Have today changed the plug and cleaned the air filter thoroughly hoping that will sort it but im thinking probably dirt in the carb somewhere It is one of the slightly older rotax motors and hasnt quite done four k miles yet Please advise

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Top Expert:

    An expert who has finished #1 on the weekly Top 10 Fixya Experts Leaderboard.

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

  • Cars & Trucks Master
  • 76,691 Answers

Duplicate question.

Posted on Mar 21, 2014

Ad

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad
  • 5 Answers

SOURCE: I have a peugeot 306 1.4 v reg. when at idle ,the

check ur air flow take the air filter top off and take the air filter out then try it a few time if ok put new air filter in if not check the carb

Posted on Sep 24, 2009

  • 80 Answers

SOURCE: Focus over-revving

If you replace the throttle body,
Check the accelerator cable for correct installtion.
if correct.
Replace the accelerator cable

let me know

Posted on Sep 27, 2009

  • 171 Answers

SOURCE: 1985 ford F150 is running very rich. (choke is

When you say it's destroying the air filter---do you mean it's all sooted up ?? I am assuming that what you mean.
Try disconnecting the vacuum line at the egr valve and see if that helps.
But it sounds more like a plugged up exhaust system.Try disconnecting or looosing the flange before the cataylic convertor and then see how it runs.

Posted on Nov 20, 2009

omaromid
  • 332 Answers

SOURCE: Vw polo maintains engine revs when foot is off the accelerator.

You need to check the cable the runs from the gas pedal to the engine, it might be rusty and need some drops of penetrating oil at the point it meets with the engine accelerator valve.

Posted on Feb 11, 2010

mcdevito75
  • 1970 Answers

SOURCE: Taurus 2003 idling problems

mcdevito75 here, Sounds like the idle speed motor, Ford is known for these idle speed motors going bad, in the later stages the car races like crazy. have your repair shop check this idle speed motor and change it.

Posted on Jul 10, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My MAN F2000 revs up by itself as if someone kicked the gas pedal sharply causing the rpm to go up and down suddenly,it stalled what should i do?


It could have a bad throttle control positioner. My dad had one that did that as soon as the weather got warm.

Jul 10, 2015 | Cars & Trucks

1 Answer

Loss of power and loss of vacuum to brakes


Restriction in the exhaust can cause this. Test with a vacuum gauge normal 60 mph readings around 14-18 hg. in depending on throttle position once power loss starts if reading goes to zero restriction is present. then use of a infra-red thermal heat gun you can locate the restriction. hot to cold at plugged stop.

Apr 17, 2014 | 2003 Saturn VUE

1 Answer

I have a 92 ford 150 manual. sometimes revs high in neutral when truck is put back into gear it does the same for the entire ride. If I turn it off and back on it acts right, but with a slight loss of...


If the check engine light is on, you need to check the computer for trouble codes first.
The idle speed is computer controlled by the idle air bypass valve. The valve can get gummed up, and so can the throttle body.

Apr 30, 2013 | Cars & Trucks

1 Answer

My 97 Hombre with 2.2 L 4 cyl, all of a sudden


probably the throttle position sensor,but also could have jumped time.i would take the T.P.S. out and check the resistance,i am not sure what the correct resistance is for that model but you can find out at the parts store.

Nov 21, 2009 | 1996 Isuzu Hombre

2 Answers

Why does my evo 4 over rev when going through gears and loss of power when pushing the turbo is it a fuel problem


ive found that the walbro pumps looses presure when warm do u get fuel cut or over boosting jerking or poping

Oct 05, 2009 | 2004 Mitsubishi Lancer Evolution

3 Answers

Engine speed will not rev over 4000rpm


take it to a mechanic to check the timing. if the timing is off then it may run at a idle an a little above but once you rev it up then the timing will truely show an it will run like ****. have you checked your air filter that may be another cause. hope this helps

May 23, 2009 | 2001 BMW 325

1 Answer

200 Pontiac Grand Am over 3500 RPM loss of power


on almost all gm cars after 96 the engines were governed to not free rev over 4000rpm. when in gear and power braking the rpms stay lower cause of the load on engine. when reving above 3500 rpms the computer cuts back the timing and fuel to reduce engine damage if left to free rev. hop that helps.

Apr 26, 2009 | Pontiac Grand Am Cars & Trucks

3 Answers

88 Nissan z24i backfires through throttle body and loses power when in gear


Check your intake and exhaust modules. I have a 1987 D21 and had the same problem (if I understand your post). I replaced the modules located behind the driver side headlights and it fixed the problem. Good luck! I hope this helps.

Nov 04, 2008 | 1987 Nissan Pickup

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

96 people viewed this question

Ask a Question

Usually answered in minutes!

Top Cars & Trucks Experts

yadayada
yadayada

Level 3 Expert

76682 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22219 Answers

Randy Ohler

Level 3 Expert

14585 Answers

Are you a Car and Truck Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...