Question about 2005 GMC Envoy Xl

1 Answer

Rpm gauge not working

Rpm gauge is not moving or working

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • GMC Master
  • 1,311 Answers

Could be a bad instrument cluster (bad stepper motor) or the vehicle speed sensor is bad. Does cruise control work, if it does then it is the cluster.

Posted on Apr 05, 2014

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Do the RPM gauge supose to move up on dash when cranking?


The tach readout is controlled by software in the Instrument cluster (IC) based on the values sent from the VCM/PCM. The readout on your scanner should show the correct rpm values (120 to 240 is wrong). Therefore, if the engine is running normally, the computer is probably not sending the correct values to the IC, but the crank sensor is OK.

Jan 01, 2017 | GMC Cars & Trucks

1 Answer

Switching gears from 1st to 2nd


there is a computer that controls your rpm gauge, your speedo, and your shift. check that and your speed sensor. the sensor is faster and easier.

Jul 26, 2009 | 2004 Nissan Maxima

1 Answer

I put my car in drive and will not move why?


it can only be 2 things.
1: transmission slip
2: engine died, or has weak power.

if you know what engine rpm is, you can solve this riddle.
A: RPM RISES FAST, MPH (SPEED) DONT. BAD TRANNY
B: Rpm sicks low, car dont move, bad engine (weak, or 100 other reasons. but (bad engine power)

it be impossible for me to express RPM with sounds,
so only an RPM gauge works. does your car have one.? "dash"?
im too lazy to look but, most cars have sub models that dont have this
important gauge.

Nov 30, 2013 | 2005 Acura MDX

1 Answer

Rpm gauge doesnt work.


will be one of the fuses in the dash. also could be air in the line if you have that style rpm gauge.

Oct 27, 2013 | Subaru Cars & Trucks

1 Answer

2004 pontiac aztek speedometer will not go back to zero when stopped when speeometer maxes out will not move again and rpm gauge bottemed out and will not move


sounds like a short somewere for the rpm gauge as for the speedo it sounds like the cable could have broke or streched

Feb 27, 2011 | 2004 Pontiac Aztek

1 Answer

The oil pressure gauge goes from 0 to all the way up and the needle moves back and forth while driving it checked oil its good now its clicking underneath the car and it felt like the transmission was...


First we would need to know when this occurs. Asuming the oil level is at the full mark!. If the pressure goes up during acceleration and down at idle when engine is fully warmed up, then this is normal. An engine requires 10 psi of oil pressure per 1,000 rpm ( ex. 20 psi at 2,000 rpm, 25 psi at 2,500 rpm, and so on ) . If the gauge is moving back and forth erratically at idle , i would say the gauge is bad. If it drops to 0 while accelerating I would say your oil pump is bad. If from time to time it seems to work and other times it seems not to work, I would say the oil pressure sending unit for the gauge is bad. If the pump failed you would start to here a Knocking noise from the engine in a short period of time. Use the above scenario's to narrow down what it may be.

Mar 27, 2010 | 2005 Nissan Altima

1 Answer

Car shuts off and gets no spark it will run for about 4 and a half mins.it then takes about 10-15 mins. to restart


Please look into your rpm gauge if you have one when you are cranking the motor does the gauge slightly move up and down if it does not it is your cam sensor please email me at sj196653@yahoo.com so we can chat about it if the rpm gauge does not move I will guide you threw the rest.

Feb 15, 2010 | 2002 Hyundai Accent

1 Answer

Gauges will not work 2004 aztec same problem with 2002 aztec


Switch ig. on, ground the sender unit wire for about 3 seconds see if the temp. gauge moves, if so change sender unit, if not then it is a faulty gauge reader.
also check instrument voltage stabilizer.

Jan 20, 2009 | 2002 Pontiac Aztek

1 Answer

WHY DOES MY RPM GAUGE STICK WHILE DRIVING


faulty dial, remove the instrument panel and spray some switch cleaner in to the back of the dial, if this doesn't work you'll need to replace the dial

Jan 07, 2009 | 1998 Honda Civic

Not finding what you are looking for?
Cars & Trucks Logo

237 people viewed this question

Ask a Question

Usually answered in minutes!

Top GMC Experts

yadayada
yadayada

Level 3 Expert

76164 Answers

Freddy

Level 3 Expert

1311 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Are you a GMC Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...