Question about Chevrolet Blazer

1 Answer

Where is the speed sensor in a 2003 jimmy

My speedoometer drops to 0 after 40 kmph and the transmission goes into nuteral my abs light is on and the parking brake light flashes on and off

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Sergeant:

    An expert that hasĀ over 500 points.

    Champion:

    An expert who has answered 200 questions.

  • Expert
  • 266 Answers

You have some sensor and mechanical issues. Start with the codes which Autozone or Pep boys will recover from your car computer. They can look up their meaning.
This will give you a guide to a costly fix

Posted on Mar 19, 2014

Testimonial: "according to the mechanics that checked there are no codes"

  • ifawnmeade Mar 19, 2014

    Was it a dealer computer ? The universal code system might not find it.

×

Ad

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad
Mr Repair
  • 10 Answers

SOURCE: 2003 mazda protege 5 transmission problem

It sounds as if you may have a short in the wire harness, or a bad plug on one of the sensors. This is common. Make sure the sensor connections are clean then use die-electric grease on them where they make contact.

Posted on Jul 09, 2008

  • 183 Answers

SOURCE: Replaced rear differential speed sensor

Did you use a mopar sensor.I have fixed this problem many times and not had much luck with the aftermarket sensors.Just a thought.Good Luck!!!

Posted on Aug 04, 2008

  • 231 Answers

SOURCE: ABS Light and Parking brake light on

check your fuses, then check the ABS valve located beside the master cylinder and the wiring to it and finally check your speed sensor, which is located on the transmission on a 2 wheel drive and on the transfer case on a 4 wheel drive. but make sure hat your E-brake is released as it will cause these lites to come on.

Posted on Oct 09, 2008

  • 30 Answers

SOURCE: ABS light & brake light on, problems with speedo working properly

The rear wheel speed sensor is the most common problem on those trucks and will do what you are talking about. It is located at the top of the rear axle in the center. It picks up it's signal from a tone ring on the diff inside! If a tranny input or output sensor is bad then the tranny won't shift properly!

Posted on Aug 14, 2009

  • 497 Answers

SOURCE: 1996 rodeo, ABS/Brake warning light on dim, will

Get an OBD reading

Posted on Oct 07, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

Brakes abs light and pulsating brakes


Too many possibilities. You need to have a scanner that does abs systems used on it and see what the codes are. This could be anything from a faulty wheel speed sensor to a bad abs module.

Aug 17, 2016 | 2001 GMC Jimmy

1 Answer

Transmission not shifting into high gear since abs/4x4 code


answer to any 4l60e trouble ' GMT400 - The Ultimate 88-98 GM Truck ...

www.gmt400.com > Street and Track > Transmissions
Mar 5, 2011 - Before guessing at transmission problems, check the fluid level (car warmed up, ... that do not show up as PCM codes (like shift A&B solenoid failures, for example). ... 1-2 shift is delayed and harsh, may not shift into OD: Check TPS for ...goes into 3rd gear: Reaction planetary is worn out due to high miles or ...

GMC Jimmy Transmission Problems - Edmunds

forums.edmunds.com > GMC > GMC Jimmy
Dec 20, 2013 - 1998 Jimmy After truck warms up shifts hard between 1st and 2nd gears. any ideas ... The ABS light stays on,the engine light stay on, the speedo doesn't work, .... I have a 1990 S15 4x4 Jimmy with a manual 5 speed transmission that went out. .... While driving it will only shift into 2nd gear and 3rd no overdrive. and usually ... Ford F-Series Transmission Problems - Edmunds
Dec 18, 2013
Buick Rendezvous Transmission and AWD Problems - Edmunds
Dec 18, 2013
Dodge Dakota Transmission Problems - Car Forums at Edmunds.com
Dec 18, 2013
Ford Transmission Problems - Edmunds
May 14, 1998
More results from forums.edmunds.com

Automatic Transmission May Not Shift Correctly at High ...

repairpal.com > Problems > Toyota > 4Runner

Feb 03, 2016 | Cars & Trucks

1 Answer

Tahoe speedomoter abs break light on


More than likely you have a bad speed sensor on the transmission. If that goes bad it will make the needle bounce and give you false readings. The brake system sees this information and tells the computer something is wrong. The ABS system has monitors on all four wheels that measure wheel speed. Also at worst if your cluster is bad it will do the same thing. Start with the easiest less expensive part. There are tests you can run too but you will need a service manual. Good Luck.

Jul 21, 2012 | 2003 Chevrolet Tahoe

2 Answers

MY VAN HESITATES DURING ACCELERATION AND SPEEDO DROPS TO ZERO THEN ABS LIGHT COMES ON


There could be a hundred causes for a check engine light. First step is to hook up a computer scan tool and see what codes the computer has. The next step depends on the codes.

Dec 09, 2009 | 1998 Chevrolet Astro

1 Answer

Help on GMC jimmy


It sounds like you need a transmission output speed sensor.

Aug 16, 2009 | 1999 Chevrolet Blazer

1 Answer

1999 jeep grand cherokee will not shift into over drive.


change the Speed sensor on the transmition.  On my 99 it would not shift out of first gera when my gas light would turn on. Every time it happened untill i filled it up . I changer the speed sensor  and all is fine

Apr 05, 2009 | 1999 Jeep Grand Cherokee

2 Answers

2003 mazda protege 5 transmission problem


It sounds as if you may have a short in the wire harness, or a bad plug on one of the sensors. This is common. Make sure the sensor connections are clean then use die-electric grease on them where they make contact.

Jul 09, 2008 | Mazda Protege Cars & Trucks

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

13 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

76846 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22246 Answers

Ronny Bennett Sr.
Ronny Bennett Sr.

Level 3 Expert

6918 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...