Question about Ford Expedition

1 Answer

Hazards, turn signal and brake light dont work

Rear lights work, just nothing else on left side

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Sergeant:

    An expert that hasĀ over 500 points.

    Champion:

    An expert who has answered 200 questions.

  • Expert
  • 266 Answers

Has to be a fuse, or something electrical. Examine the fuses for signs..if not, then take it to Pep Boys to read the codes

Posted on Mar 18, 2014

Ad

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad
  • 255 Answers

SOURCE: My brake light and turn signal on the left don't work.

Hi, you have a bad bulb,....

Posted on Aug 17, 2008

  • 1 Answer

SOURCE: Chev Cavalier 2003 only one rear turn/brake/hazard light

I have a 2002 Chev Cavalier that had the same exact problem. I replaced the bulb harness (purchased from a chevy dealership for around $5) which was fairly easy to do. I have had zero problems with it since.

Posted on Dec 03, 2008

  • 141 Answers

SOURCE: left rear turn signal and brake light dont work

You have a broken wire to the turn/brake light portion of the light as they use the same wire. Or where the plug goes into the light assy could be bad. Torsion mount lights are horrible and you should think about replacing with a universal light that you can wire direct.

Posted on Feb 17, 2009

  • 1986 Answers

SOURCE: 1994 chevrolet pickup - brake light problems

There will be an electronic flasher module located under your dash near the steering column (don't know it's exactly location as it varies). It sounds like this unit may be faulty.

Posted on Aug 21, 2009

  • 4 Answers

SOURCE: 99 Chevy Tahoe... Rear turn signals, brake lights, and hazards

I had this problem, and to be honest, it happened to the left side about a week later...it's the board that the bulbs plug into...it's a very common problem with this model. So popular that you can normally get the socket board off the shelf at a parts store! it's extremely simple to replace, and I replaced all the bulbs at the same time!

Posted on Oct 11, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

My rear turn signals are not working. front turn signals work rear parking lights work brake lights work


In the diagram for rear lamp, the top wires are voltage, the bottom black wire is ground. The brown wire on either side should be tail lamps, goes hot when you turn on the headlamp switch. The other top wire on either should be for turn signal. With everything turned on, is there voltage on that wire?
Because the front works and the rear don't, possible wiring circuit problem? The voltage for turn signals comes from bcm. The bcm knows when you turn on turn signal switch, either side, then the bcm sends voltage to turn signal lamp at the rear and front.

rear-turn-signals-not-working-front-nrw1b5lbo1usuvcsnuvurzx3-3-0.jpg

Oct 17, 2016 | 2009 Chevrolet Chevrolet HHR LS

1 Answer

Why aren't hazard lights or brake lights working?


Brake lights /rear hazard lights not working - Ford Truck ...

www.ford-trucks.com > ... > 1967 - 1972 F-100 & Larger F-Series Trucks
Jul 9, 2010 - After checking the brake lights I tried the emergency flashers and found that they are working in the front but not in the back. I do have rear turn ... 1995 F350 Brake Lights / Turn Signals not working
Jul 9, 2012
Turn Signals and Brake Lights Do Not Work
Mar 10, 2012
Turn Signal, Brake Lights, & Rear Hazard not working
Aug 3, 2010
Rear Turn Signals, Hazards and Brake Lights not working....
Aug 29, 200

Sep 30, 2015 | Cars & Trucks

1 Answer

I have a 2003 2 door explorer sport, just recently my turning signal and break light have stopped working on the passenger side!! I changed the light bulb, and nothing!! I changed the turning signal light...


No, because the left side is still working. The loose wiring was to the multifunction switch (turn signal).

Power gores through the turn signal switch to the brake switch on the brake pedal, then to the rear lights. Does the highmount brake lamp work?
At the RH lamp socket, Measure the voltage between the RH rear lamp C4032 pin 3, circuit 5 (OG/LB), harness side and ground. Should be 12 volts.

try that first.

Did you change the front and rear bulbs?

May 21, 2011 | Ford Explorer Sport Cars & Trucks

1 Answer

Left front turn signal does not flash. Left rear OK. socket was corroded so I replaced socket. No flash. Checked wires for voltage, only the parking light connection ever gets anything. Front and rear...


Try pushing the Hazard switch on the Column several times and see if it restores the connection. From what I understand about the Multifunction Turn switch is that some of the contacts share connections with the Hazard Button.

The contacts work on a type of derailer setup and when the contacts get dirty or wear, things stop working. Moving the Hazard switch resets the points and springs each time you go in and out of the Hazard setting.

If your brake light is working you know the wires to the light socket from the brake switch are okay. Probably would not hurt to check brake light switch as it shares the common wire. The split between the left turn and right turn signal wire has to occur, yet the opposite brake light will stay on steady while the other side blinks.

Oct 22, 2010 | Ford E-250 Cars & Trucks

2 Answers

My 97 chevy blazer, the brake lights dont work but the third brake light does and the turn signals or hazard lights dont work??


More likely it is the hazard/turnsignal/highbeam/cruise control switch module. It costs about $275 for the module. However there is a repair kit for the likely culprit...the hazard button. Try jiggling it around a little, see if that helps. Spray a little WD-40 into it so it can jostle back into it's correct position. You could try a junkyard unit or Ebay. It's not too hard to change. The hard part is doing it without removing the steering wheel. It can be done. I've done it. But hopefully you can locate the repair kit which costs about 15 dollars. Good luck.

Apr 27, 2010 | 1997 Chevrolet Blazer

2 Answers

I have a 96 town car


Ok. First of all, chk all the bulbs. Well at least the four parking lamps. The ones that are supposed to flash. One or two are burnd out. It happens. The flasher(s) work on resistance and that is provided by the bulbs.Brake likes and the turn signals are electrically associated.and you already said one side does not work, so let's start with bulb inspection Let me know

Oct 31, 2009 | 1996 Lincoln Town Car

2 Answers

99 Chevy Tahoe... Rear turn signals, brake lights, and hazards


I had this problem, and to be honest, it happened to the left side about a week later...it's the board that the bulbs plug into...it's a very common problem with this model. So popular that you can normally get the socket board off the shelf at a parts store! it's extremely simple to replace, and I replaced all the bulbs at the same time!

Oct 10, 2009 | 1999 Chevrolet Tahoe

3 Answers

No turn signals or brake lights on left and right but brake light on top


I agree. My brake light dont work. Only the third brake light does. The running lights work but when i apply the brakes the rear tails dont light up.
I currently have this issue along with the signals dont work unless I bang the top of the steering colum. The hazard switch doesnt work either. If the signals dont work it makes this very quick clicking sound on the passenger side. I checked the fuses and they are good. The bulbs still work. The brake switch works cause the third brake light goes on. And seeing as I am having a problem with signals.....GM says I have to replace the switch in the steerg colume. Its a little box about the size of a cigarette pack. If you take apart the panels off ( right behind the steering wheel, where the hazard switch is) ...that is where it is located. Its plugged into the signal lever. Hope this helpa....Good luck everyone with this issue.

Oct 17, 2008 | 2001 Chevrolet Blazer

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

30 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

76164 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

fordexpert

Level 3 Expert

5522 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...