Question about Nissan Cars & Trucks

1 Answer

2000 maxima, car runs rough smell fuel

Was running great yesterday, starting up this morning and very rough with rpm bouncing 500-1000 and eventually stalls. Just had O2 sensor replaced maybe 4 weeks ago.

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Legend:

    An expert who has written 200 answers of more than 400 characters.

  • Expert
  • 331 Answers

This could be a number of things. I'd like to know more about the cars maintenance history and any recent repairs that you have had performed. Symptoms of a rough idle and the smell of raw gas could be related to a clogged air filter, fouled spark plug, bad COP (coil over plug), or related wiring, clogged CAT (too much back pressure), dirty or defective, MAF sensor, damaged EGR valve, timing, damaged intake valve (need to perform a compression test to confirm), or a damaged fuel injector (the injector could be clogged, worn out and no longer spraying correctly). Please write back. I'm not sure what tests and inspections, you have already done. Were there any other symptoms? Did the engine light come on at all? If so, did you retrieve any codes? Let me know if this information helps and where you want to start from here, good luck.

Posted on Mar 18, 2014

  • Bob Jacquet
    Bob Jacquet Mar 19, 2014

    Thanks for the input so far. About 2 months ago I replaced MAF sensor. 3-4 weeks ago I replaced the upstream O2 bank 1(the check engine had been on a while and the code my mechanic got said this sensor was bad. We replaced it, however the one I ordered the wires were not long enough do he spliced them into wire he had around(soldered and taped). 2 days after the check engine came back on but car was working normal. I had to drive it and it worked fine on the freeway, and after a long drive when I stopped it ran normal for a few minutes before returning to rough again. I also tried removing the air filter completely but it does not affect it. This is everything i've tried/repaired

  • Larry Blais
    Larry Blais Mar 20, 2014

    Would you have the code reread and make sure it is for the same issue. Please forward that code (example: P0141) It sounds like your engine is either getting more fuel than it should be or the fuel mixture isn't being burned completely. Why, is going to be the hard part. this problem could be related to a number of components. Do you have a repair manual and some testing equipment? The O2 sensor may have been bad or the O2 sensor was fine but wasn't operation within exceptable perameters. If raw fuel is going into the exhaust. The O2 sensor will indicate an error referring to the engine running lean. What it means is that the ECU is tring to make the fuel/air ratio change to a leaner threshold. Or that it isn't reading any oxygen levels at all. This could be due to bad wiring or clogged and/or defective O2 sensor. What did the old O2 sensor look like when it was pulled? Was it clean or covered with carbon? Please write back with what you find out and we can go from there. I have a feeling that you will need to dig deeper into this repair to find out why your car has this failure. I don't fault your mechanic for recommending to replace the O2 sensor, they are less accurate after 100K miles. But that doesn't mean that when an O2 is not working, that replacing it will fix the problem. Ask your machanic how the "live data" looked for the upstream and down stream O2 sensors, before the repair. If he or she, will be the one rereading the ECU. It would be a good idea to see if the readings are the same, better, or worse, with the new sensor. Write back when you have time, good luck.

×

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

2012 maxima will start, but won't idle and dies after a few seconds. Has been running perfectly until this morning.


Check the fuel lines and unions for small air leaks (smell of fuel) also check fuel filters for partial blockages P.S CHECK THE FUEL GAUGE FIRST.

Jul 22, 2016 | 2012 Nissan Maxima 3.5 S Sedan 3.5L V6 CVT...

1 Answer

What would cause 1993 eldorado not to run? fuel pump is working, get 48 psi in fuel pressure and all cylinders are firing. need help


may be you should make a diagnostic and you can do it in a garage or you can do it by yourself if you want to do it by yourself you need some tools and you can find some good ones here: spobd2.com

Mar 27, 2013 | 1993 Cadillac Eldorado

1 Answer

Sputtering on 1991 nissan maxima from a stop then at 2000 rpm or so it will run grat


its your idyll. You need to turn up the gas flow to the fuel injection or the carburetor.

Aug 26, 2012 | 1991 Nissan Maxima

2 Answers

My Nissan maxima 98 won't start in cold morning


check the temperature sender for your fuel and emissions (not same as sender for gauge is most cases) if fuel injected, if carburated check choke. also ensure plugs and wires are in good shape

Mar 14, 2012 | 1998 Nissan Maxima

1 Answer

Rough start, smell gas


For the RPM's jumping up and down i would replace the throttle position sensor. If it smells like bad gas or rotten eggs these are signs that the cat. converter is going bad. For the poor gas mileage replace the fuel filter.

May 08, 2010 | 2000 Mitsubishi Eclipse

1 Answer

Rough Idle and missing at low rpms on 2003 Ford Ka


make sure you put the right plugs in the fault is most likely the coil pack follow the plug leads from the spark plugs and you will reach the coil pack about £60

Oct 28, 2009 | 2003 Ford Escort

1 Answer

2000 nissan maxima hard to start.


sounds like solenoid on starter is worn, replace starter.

Aug 18, 2009 | 2000 Nissan Maxima

2 Answers

87 Supra idles rough and dies out


check timing and set idle to 650rpm

Dec 15, 2008 | 1987 Toyota Supra

1 Answer

Runs rough then clears up &runs great


found waste gate on turbo sticking freed up ok now

Sep 21, 2008 | 1991 Volvo 940

2 Answers

ROUGH IDLE & SMELLS LIKE GAS BURNING THRU EXUST. OBOVE 3,000 RPM RUNS GOOD!


sound like you have a bad fuel pressure regulator . check your fuel pressure. could also be a leaking injector. the fuel pressure test will tell you which one

Sep 11, 2008 | 1996 Nissan Maxima

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

102 people viewed this question

Ask a Question

Usually answered in minutes!

Top Nissan Experts

yadayada
yadayada

Level 3 Expert

76051 Answers

Phil Lovisek
Phil Lovisek

Level 3 Expert

726 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Are you a Nissan Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...