Question about 2007 Mitsubishi L-200 2.5

1 Answer

Starting problems

My 2008 L-200 2.5 when starting for the first time for the day starts well after it is glowed,if i run for about 5 to 10 miles and rest for 2 hours the vehicle takes a long time to fire up and when is does fire up white puff of smokes comes from the exhaust,what can you suggest i can do to remedy the situation?

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    New Friend:

    An expert that has 1 follower.

    Cheetah:

    An expert who has answered 20 or more questions within one hour.

  • Expert
  • 85 Answers

Could be a coolant leak into the cylinder. (head gasket leak) use a five gas scanner to check for hydrocarbons in cooling system.

Posted on Feb 17, 2014

Ad

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
New users get 2 Free calls (no credit card required) and instant help on almost anything you can think of (from cars to computers, appliances, handyman, and even pets).
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad
  • 1 Answer

SOURCE: restarting pajero

Hi James Just wondering if you got that troublesome beast running yet if not
drop me an email and ill help get you going again .

Posted on Oct 26, 2008

  • 86 Answers

SOURCE: My engine is smoking when i start engine on mornings

sounds like valve guids are wearing out.. drying out and cracking. only fix is to replace them. or try a heavier oil. sometimes that will help depending on the severity of the problem.

Posted on May 06, 2009

  • 3 Answers

SOURCE: 98 mitzi l200 2.8 l eng 4M40

White smoke is a sign of unburnt diesel fuel, check your glowplugs as thats the most common cause when starting .It will start but not hot enough to burn fuel at start up, also check glowplug relay if not the plugs
Delica Owner 4m40

Posted on Dec 21, 2009

  • 228 Answers

SOURCE: my 2002 montero was smoking

HAVE YOU NOTICED COOLANT LOSS,RECENTLY?KEEP THE COOLANT LEVELS FULL,CHECK TO SEE FOR ANY LOSS AT ALL! OIL SMOKE IS MORE BLUE THAN WHITE,BUT FUEL CAN HAVE A LIGHT BLUE SMOKE.Antifreez more whitesh with a similar smell of antifreeze.

Posted on Sep 12, 2010

cansmo
  • 2431 Answers

SOURCE: I have 1999 Mitsubishi Montero

Mitshubishi had a update and one time when a montero sport came in about doing a valve job , The reson I know this I work on a customer that had a blown head gasket and had the machine shop do a valve job, we had a hard time ordering valve stem seal as they were updated from black to brown in color,why was updated at that time,the seal leaked and burned oil,So what does this have to do with yours , not only is your valve stem guide worn,your valve guides cannot seal and you get oil in the combustion chamber,as the oil pan gasket of course it ll will leak there and seep, and your front seal has a weep leak,Here is you 140k miles if you decide to repair it? valve job at both cylinder head, before you commit this have a through evaluation especially with the transmission. by the way Mitsubishi and Dodge caravan from 1996 to 2001 suffer from this.Do you know how I can tell when I am near a montero? the lifter are noisy

Posted on Apr 29, 2011

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

DI have a 1983 ford f250 with 6.9 diesel engine. The previous owner told me that the front fuel tank did not work; he said that he was running the truck on the front tank once and that the truck started...


have you looked into the injectors, or injector balance? glow plugs just preheat the cylinders before you start turning the engine over. if the injectors are dumping too much fuel it will run rich and blow black smoke, lean it will dump white smoke, same as if it has an internal coolant leak, but smell different. Ford has had problems with EGR systems on some of their diesels, being an older truck how many miles is on it? and the front fuel tank could have a bad fuel pump, pretty common for them to do what you have described. Also might want to have the timing looked at on it! It ignites off of pressure, and if the timing is off it will adversely affect the ignition of the fuel which will make for hard starts, and poor running. there is a lot that needs to be looked at to figure this one out! could be quite a few different things. Good luck!

Nov 20, 2013 | Cars & Trucks

1 Answer

Having cold start problems 2006 h.d. f350 ,truck is parked in heated garage all night,starts normal in the a.m.,sits outside all day at work,soon as temp falls below 30 F it starts then stalls immediately...


glow pug indicator and glow plug themself are 2 seperate system
test for power at the glow plug harness conector 1 each side over valve cover
test light clamp on batery neg test each wire going to relay for power on both side
then quick check on glow plug end test light clamp on positive test all wires
going to glow pug on each side f this does ligtht up the test light system should be o.k.
for the FICM i have used a hair blower on hi to warm the surface of if to start up a few of
these motors to get them back to the yard for replacment afterward
run a ffeet of these from 250 to 550 lots of problem and work 26 units
good luck

Feb 25, 2011 | 2006 Ford F 350 Super Duty

1 Answer

We have an 2005 E450 diesel that has cold starting problems. We use for a limo bus, so it has three batteries. We put a good charge on them; it turns over fine after waiting on glow plugs. It only shows...


check the alternator first as a diode in the rectifier pack will cause this problem ,take the cables off the alternator when leaving vehicle and then try starting it the following day ,if batteries still low then it could be a cell in a battery so so disconnect them one at a time till you find the dodgy one or put a drop tester on the each battery in turn ,

Sep 17, 2010 | 2005 Ford E-Series

1 Answer

My 2003 Renault Megane Scenic 1.9dci expression won't start


The funny sound you mentioned must be identified, could it be the starter trying badly to turn. Here the fault of your battery drain is that the glow plugs take a lot of current and it must NOT come ON when the starter motor runs. Hence the fault could be your GLOW plug relay unit with the auto cut off timer that is faulty. If you keep draining the battery to a lower threshold level , there is every possiblity that the battery life will be lowered . I hope the present battery rating is the recommended Amp/hr rating to give the extra run for the morning start. Next area of suspicion is the starter motor itself , it could have a bad commutator or a bush. It will be good to have a clean up and service. Finally check for excessive drain on your battery with a current check in series for the drain current when the switch if off. If the current exceeds the limit disconnect each circuit to confirm. hope this advice helps. good day

Jul 22, 2010 | 2003 Renault Sportwagon

1 Answer

My 1986 F250 with a 6.9 diesel engine will not start on a warm day unless it is plugged in for an hour before. Once it fires up, it will run great and I can turn it off two hours later and it will still...


Sounds like your batteries are not producing like fully charged batteries. You may have to replace them do you have the tool to load check them? Hope this helps you. Darrell S

May 22, 2010 | 1986 Ford F 250

2 Answers

Glow plug system will not cycle


check fuel pump or relay,run scanner for trouble codes, some auto parts stores will do this for free

Sep 27, 2009 | 1984 Ford F 250

1 Answer

Starting problem at cold weather and even if it starts it stop after running a mile or two


Hello
Your Land Cruier should pre-heat its self with the glow plug light on the dash board.

The frist thing to check is the glow plugs to make sure that all 8 are working you will have to remove them to test them one at a time,
As you will propley find out at least 3 or 4 glow plugs are down.

The idle up is just to lift the revs in the engine for jump starting or running other items on the car ie carvan,trailer.

As it will only lift the revs buy 200-400 RPMs this will have nothing to do with your pre-heat on the Jeep.

If you still have any problems please contact me
Regards Paul
www.limotec.co.uk

Jan 12, 2009 | 2007 Toyota Land Cruiser

1 Answer

Keeps blowing fuse


disconnect your glow plug relay and try it, the relay may be shorted out

Oct 25, 2008 | 1997 Ford F250 SuperCab

Not finding what you are looking for?
2007 Mitsubishi L-200 2.5 Logo

59 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mitsubishi Experts

yadayada
yadayada

Level 3 Expert

76630 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22219 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8516 Answers

Are you a Mitsubishi Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...