Question about Lincoln Town Car

1 Answer

Loss of power upon take off

Car starts perfect but when i pull off it is sputtering and backfiring occasionally i put the gas petal all the way down to the floor and it eventually catches up with itself and rides good whats the problem??? and i do let the car warm up before taking off

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Top Expert:

    An expert who has finished #1 on the weekly Top 10 Fixya Experts Leaderboard.

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

  • Lincoln Master
  • 21,873 Answers

What year is the car and is the check engine light on ?

Posted on Feb 17, 2014

Ad

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

SOURCE: fuel system

fuel strauner inside tank

Posted on Jul 17, 2008

  • 393 Answers

SOURCE: loss of power,sputtering,backfiring.

yes,bad gas could but it sounds like you have one or two cyl. not firing check the spark plugs and wires how long since last t-up

Posted on Dec 27, 2008

hotrodtod38
  • 141 Answers

SOURCE: Hesitation/Backfiring

sound like its flooding

Posted on Feb 15, 2009

SOURCE: bogs down

Even though this is an old post i feel it needs an answer since there is 225 followers wanting an answer. This situation sounds as if this vehicle is either suffering from the Throttle Position Sensor switch which has bad spots in it causing lack of voltage or the Fuel rail pressure regulator which can not keep the fuel pressure built up in the fuel rail making the auto veel like it is running out of fuel.And the transmission speed densor which also controls fuel. The situations for each device has a test that can be done to determine which one it is. And last but not least lets never forget our fuel filter this can cause the exact same problem. I am eliminating the cam sensor because it stabilizes at idle. Eliminating the crank sensor because it too at idle also stabilizes and returns a smooth idle. So a fueling problem is what we have here one of the above. Enjoy and if you need help determining which one just ask me I will help you figure it out. Please rate my advise thanks it is how i receive my achievements.

Posted on Apr 11, 2012

  • 1 Answer

SOURCE: Sudden loss of power, Backfiring, starts then stalls

The car still runs and drives, just no power and shakes badly during acceleration. Could the timing belt have jumped? Could this happen while driving yet the car still runs?

Posted on Oct 14, 2012

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

My 2004 MERCURY Monterey is sputtering/ bucking backfiring and smells of gas. I have had the fuel filter rack and pinion cv joints plugs and wires changed all within the past 8 weeks


Questions, Troubleshooting Help & Support Page 8 - Fixya

www.fixya.com/troubleshoot/page-8
Why does my 2012 dodge ram 1500 fuel pump stay on... Dodge Cars &. ... My 2004 MERCURY Monterey is sputtering/ bucking backfiring and smells of gas.

2005 PT Cruiser GT misfiring and bucking - Edmunds

forums.edmunds.com > Chrysler > Chrysler PT Cruiser
Mar 24, 2010 - I put in some fuel injection cleaner and filled the tank with Premium. ... itbucking, sputtering at low speed until i can pump the gas enough to get ...Missing: monterey ‎smells

Sputter/Stutter and Loss of Power - Ford Explorer and Ranger ...

www.explorerforum.com > ... > Stock 1995 - 2001 Explorers

Jun 2, 2010 - 19 posts - ‎6 authors
If the sputter got real bad, I could smell what smelled like weed eater gas inside the cabin. As you could also imagine, there is a loss of power.

Feb 03, 2016 | 2004 Mercury Montery

1 Answer

My car is stalling when idling and sputtering when driving like it is losing power


Try some gas line anti freeze (methle hydrate) It will dissipate water which may have been at the bottom of the tank. If he put regular gas and you put super, add octane boost. and drive for half hour and it will clear.

Dec 15, 2013 | 1999 Saab 9-3

1 Answer

Sputtering and stalling


Have the fuel pressure tested, running out of gas will destroy the fuel tank moumted fuel pump or cause it to run slow with the resulting loss of power.

Dec 15, 2013 | 1999 Saab 9-5

1 Answer

Loss of power when appling pressure to throttle, surging happens


There are a few thing that can cause this type of problem, A weak fuel pump is the most common, not enough fuel pressure . the pump puts out just enough to start and idle but when gas is applied it sputters and pops and stalls out. I would start with having the fuel pressure tested, a fuel pressure gauge will be needed to perform this test. you may be able to rent one from auto parts store, you will connect at the injector rail, there will be a valve , like the tire air valve. screw end of gauge to valve and start engine and see what the pressure is. the pressure needs to be at 38 psi, or test pressure without starting just turning key on and then pressure needs to be 47- 50 psi.

If the pressure is lower than the specs then pump is bad..
the other problems could be a bad tps sensor or mass air flow sensor, but from the way you listed what the problem is doing i would have to say start with the fuel pump testing first,

Dec 22, 2012 | 1995 Mitsubishi Diamante

1 Answer

1998 Pontiac Bonneville SE 3.8L Backfires/ Sputters


sounds like the ignition module is going bad.

Aug 04, 2009 | 1998 Pontiac Bonneville

1 Answer

93 buick lesaber car ran fine engine locked up so


have you checked firing order on plug wi92717856res? could be problem.

May 05, 2009 | 1993 Buick LeSabre

1 Answer

Sputtering when at half throttle.....


coil could be getting hot and braking down and also the timing chain could be streched

Mar 01, 2009 | 1999 GMC Jimmy

1 Answer

Loss of power,sputtering,backfiring.


yes,bad gas could but it sounds like you have one or two cyl. not firing check the spark plugs and wires how long since last t-up

Dec 27, 2008 | 1991 Jeep Comanche

2 Answers

Sudden loss of power, Backfiring, starts then stalls


Your timing belt could be broken. You want to have this checked as soon as possible to prevent any further engine problems.

Nov 27, 2008 | 1991 Honda Civic

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

108 people viewed this question

Ask a Question

Usually answered in minutes!

Top Lincoln Experts

yadayada
yadayada

Level 3 Expert

76164 Answers

fordexpert

Level 3 Expert

5520 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Are you a Lincoln Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...