Question about Mercedes-Benz Cars & Trucks

Open Question

High oil warning ml350

My "oil hi" light is randomly coming on. I got my oil changed about 2500 miles ago and Jiffy Lube so I would think that if the oil was too high that the light would have come on long ago. Also, the day after the oil hi light started coming on, my ml350 started making a "whirring" noise that occurs at lower speeds like 25 mph or less while I am either accelerating or decelerating. Sometimes it is louder than other times. Do you think these are related? And what could be the problem?

Posted by Anonymous on

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

bschilz
  • 2049 Answers

SOURCE: i have a 2003 trailblazer and when i accelerate it

It sound slike a "Fan Clutch". I had a GM Suburban do the same thing.

Here's an article to consider...
http://www.aa1car.com/library/cooling_fan_clutch.htm

Posted on Aug 13, 2009

monkeybear45
  • 94 Answers

SOURCE: 2002 Windstar. Automatic transmission has begun to

Sounds like a bad torque converter. When the torque converter is engaged, it's not "whirring" it's on decel or freewheel that it "whirs".Did you check fluid level and color?

Posted on Nov 26, 2009

  • 1810 Answers

SOURCE: My 2000 Blazer started making a tapping/ ticking

time to add some oil

they likely used 10/30

add a litre of 80w90 it will thicken the curent oil and should stop the noise

it is likely you will need thiswith all your future oil changes high nilage motors make noise and require thicker lubrication

Posted on Jan 16, 2010

airjer995
  • 5332 Answers

SOURCE: 2007 ford 500 oil warning light comes on and just

When they changed the oil they did not reset the light. The car needs to be told when the oil is changed.

when the warning comes on press the setup button. it should say press reset if new. Press the reset button. It should say if new oil hold reset. Press and hold the reset button until the display changes to oil life set to 100%.

Posted on Oct 12, 2010

  • 673 Answers

SOURCE: 2000 Chrysler 300M V6 with 150k miles started giving a clacking noise from the engine area after getting an oil change from Jiffy Lube. I was less than 2 miles from their shop when it started clackin

Sounds like your valve lifters. It's possible that they drained the oil and never refilled it. This does happen when they go on break or lunch half way through a job. They think they added the oil, but did not. Out you go, Mr. Clack-Clack.

Posted on Jun 21, 2012

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I just got an oil change today. Drive the car for about ten miles and then the oil light came on???? I'm afraid to drive it back to the garage.


I'm afraid to ask, was it at one of those... Change your oil and Lube in Jiffy, places?
if so, you may have just got Lubed!
It is not as uncommon as one may think, to not put oil back into engine.
I would park the car, Call that place and have them come out and check it. Even if you are able to check the oil at the dipstick, yourself, don't do it. Let them come out and do it.

May 16, 2015 | Cars & Trucks

1 Answer

2006 Cadillac cts is burning gas faster than the normal rate after i got an oil change at jiffy lube 2 weeks ago


I dont think there is a connection between an oil change and the gallons per mile.
With that age car, I suggest a Terra engine clean. It will blow away nine years of gunk from the spark plugs, fuel injectors, cylinders and exhaust. Should give you more power, more miles..

Mar 18, 2014 | Cadillac CTS Cars & Trucks

1 Answer

High oil warning ml350


Check the oil on the dipstick. If it is high, it may be contaminated with gas or coolant. You can smell if it is gas. If it is coolant, it will look milky brown color. That would point to a head gasket problem.

If the oil looks good and not contaminated, but still high, drain enough out the drain plug until oil is at proper level, or just go ahead and drain all the oil so it can be looked at at for contamination. Because if jiffy lube put too much in, you are right, the light should have come on sooner. The whirring noise could very well be from a high oil level, so look into all possibilities. If oil is not too high, it could be just a sensor problem-but it doesn't sound like it. Good luck.

Feb 16, 2014 | Cars & Trucks

1 Answer

2000 Chrysler 300M V6 with 150k miles started giving a clacking noise from the engine area after getting an oil change from Jiffy Lube. I was less than 2 miles from their shop when it started clackin


Sounds like your valve lifters. It's possible that they drained the oil and never refilled it. This does happen when they go on break or lunch half way through a job. They think they added the oil, but did not. Out you go, Mr. Clack-Clack.

Jun 21, 2012 | 2000 Chrysler 300M

2 Answers

When Jiffy Lube changed the oil in my 2009 Ford Expedition, they did not reset the "Change Oil" message in the instrument panel. Since I set out on a trip immediately after the service, I can't...


You can leave it,it is a gadget,not tied to any system

You should have an owners manual (still) on a 2009

Never go the Jiffy Lube

Read all the damage and horror stories ,on quick change
places.

Dec 08, 2010 | Ford Expedition Cars & Trucks

1 Answer

Had a faulty oil filter put in by Jiffy Lube. Low oil pressure light came on after about 2000 miles into oil change. Jiffy Lube stated it was a faulty oil filter and replaced it. Drove off and light...


I can tell you that it sounds like someone is trying to take you for a ride.. I've been a mechanic for 28 years. And I've never heard of o rings going bad on a motor that only has 56000 miles. Change the oil filter again.. make sure that it's not a fram.. gram filters have been known to cause your oil pressure light come on. Hope this helps you.

Apr 22, 2017 | Volvo S60 Cars & Trucks

1 Answer

Sensors went bad, at 60 k miles, is this covered in warranty


you need to take the vehicle to a real mechanic. Jiffy lube employes are not mechanics. Change your oil at jiffy lube and get mechanical work done at a reputable auto dealer or mechanic shop.

May 06, 2009 | 2005 Nissan Altima

1 Answer

JUST GOT OIL CHANGE AT JIFFY LUBE ...NOW CAR DIES OUT IN NEUTRAL


Jiffy Lube is notorious for taking things apart and not putting them back like their supposed to do. I USED to use them....try looking at the air filter, cause they always take it out to show you. I would bet its an airflow problem....please rate me...thanks

Feb 02, 2009 | Mazda Millenia Cars & Trucks

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

26 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mercedes-Benz Experts

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

yadayada
yadayada

Level 3 Expert

75197 Answers

Michael Contreras
Michael Contreras

Level 2 Expert

166 Answers

Are you a Mercedes-Benz Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...