Question about Cars & Trucks

Open Question

Oil pressure sending unit

Oil pump pressure on nissan hardbody 3.0 16v tdi

Posted by Anonymous on

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 1 Answer

SOURCE: Pontiac Bonneville(2000) oil pressure sending unit

The oil pressure sending unit is located behind the oil filter, Threaded into an aluminunm housing. It has wiring that plugs into the sending unit. The oil filter has to be removed and you will need a deep well socket and a 6 inch extension. Change the oil and the sending unit together.

Posted on Feb 02, 2009

farroutideas
  • 78 Answers

SOURCE: oil pressure sending unit

Hi there;

Your looking foer the oil pressure sensor on the 2004 8.1L.
You will find it located directly behind the EGR valve threaded into the block just to the drivers side of the center bolt for the transmission to block connection.

Thanks
Farrout!

Posted on Mar 17, 2009

  • 118 Answers

SOURCE: where is the oil pressure sending unit located?

The pressure sending unit is located on the passenger side rear of the engine just above and slightly to the left of the filter and filter housing.

Posted on Aug 01, 2009

  • 1 Answer

SOURCE: oil pressure sending unit location

oil pressure sending unit show location on 2000 dodge caravan V-6

Posted on Nov 28, 2009

Molson02536
  • 3854 Answers

SOURCE: where is the oil pressure sending unit?

The oil pressure sending unit is located on the engine block, passenger side by the Distributor. Good luck and make sure you get the right sending unit, there is the simple unit that only turns on a low oil pressure light and the other will send signals to the oil pressure gauge.

Posted on Feb 06, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

On my 97 nissan hardbody 2.4 ka24e eng with 258890miles on it got a new oil pump timing chain & head job the spring is red what color will increase the oil pressure


Nissan has fitted the spring to give the correct oil pressure to the crank and cam bearings, you can damage the white metal crank shaft bearings by increasing the oil pressure , fit the standard spring.

Aug 06, 2015 | Nissan Cars & Trucks

1 Answer

Oil pressure on nissan hardbody 2.4 ka24e is low I think it should be more


Could be a bad oil sending unit or your oil pan is leaking or your valve cover is leaking.

Aug 06, 2015 | Nissan Cars & Trucks

1 Answer

2004 2x4 2.4i 16 valve Nissan Hardbody d/cab repair manual


You will have to pull out your oil sender switch, and have a oil pressure gauge fitted, this will tell you if you have internal problems or it just the sender unit , your mechanic could do it in no time at all

Jan 07, 2014 | Cars & Trucks

1 Answer

High oil pressure reading on a 2005 nissan aramada


You may have a defective oil pressure sending unit on the engine or the oil pump relief spring may be sticking. Have the oil pressure tested with a special tool that goes in the oil port the sender is screwed into to determine the cause of the high pressure.;

Jun 22, 2012 | 2005 Nissan Armada

1 Answer

The oil gage went to high and we changed the filter and it has new oil but its still registering high what is it


Remove oil sender unit on engine scew in a oil pressure gage if oil pressure ok replace sending unit if not oil pump needs to be replace

Jun 27, 2011 | 2005 Nissan Xterra

2 Answers

My 2005 Nissan Armada is reading oil pressure abnormally high. The gauge is maxed out.


  • Well it could be a bad oil pump or a bad Oil Sending Unit. If you have an oil pressure gauge you can pull the sending unit and stick the pressure gauge in there and see what the reading is. I would thing 60PSI would be suitable.
  • I believe this Oil Sending Unit is on the front (possibly the back) of the oil pan.
  • Just remove the connector and put a wrench (or a deep socket) and twist it out and replace with a new one.
  • Make sure the oil filter is snug and not leaking as well.
  • Check your oil level too and make sure it is properly filled.
  • Good luck and thank you for using FixYa.

Regards, Tony

Jun 13, 2011 | 2005 Nissan Armada

1 Answer

Oil light comes on and off when in park idling. oil level is fine.


Sounds like a weak oil pump at higher rpm the pump creates more pressure which is adaquate to make the light go out and supply oil to the engine. At lower rpm your oil pump is not creating the pressure needed. Be carefull not to let it idle or sit in park to long this could damage the engine. There is oil pressure sending unit also this is what makes the light come on and it also shows the oil pressure on the oil gage on dash if your vehicle is equipped with gage. The sending unit could be faulty, but play it safe and have your mechanic diagnose the problem.

Mar 22, 2011 | 2003 Nissan Xterra

3 Answers

My 04 XTerra's oil light keeps coming on but there is oil in the car....not overheating, driving okay??? I am perplexed.


1st you need to do an oil pressure test. If it reads between 20psi-60psi, then it's Ok and you have a bad oil pressure switch. If it's below the above specs then you have an internal engine problem - IE: bad oil pump, bad bearing, etc...

Mar 12, 2011 | 2004 Nissan XTerra

1 Answer

Petrol not running properly from the petrol tank to the engine on a nissan primera


check your sending unit on top of the tank. Check for 12V with key in ON pisition. If 12V is present, look at the connector in sending unit it self. Inside of connector corrodes, causing no power to the pump. No power to pump, no gas in engine. Good luck

Aug 02, 2008 | 1990 Nissan Hardbody King Cab

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

10 people viewed this question

Ask a Question

Usually answered in minutes!

Top Cars & Trucks Experts

yadayada
yadayada

Level 3 Expert

75807 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22133 Answers

Randy Ohler

Level 3 Expert

14585 Answers

Are you a Car and Truck Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...