Question about 2000 Volvo S70

Open Question

Gauges Not Working

My car has recently lost all function with gauges. Speedometer/odometer/rpms/temp/gas. Some of the lights still light up on the dash when I start the car (battery, check engine etc.), but the gauges do not move. I had a similar problem in the summer, and I simply unhooked my battery and then it worked fine. That did not work this time. The car also runs at random RPMS, causing it to rev and stop. The gas pedal is mostly unresponsive. Let me know what you think!

Posted by on

Ad

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
New users get to try the service completely Free afterwhich it costs $6 per call and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad
  • 375 Answers

SOURCE: electrical fault

It could be lamba sensor in exhaust gone faulty you need to get it on a diagnosic com puter really to check as modern engines have lots of sensor to monitor air fuel temparatures etc most garages have them now as all cars have electronic control units to control the running of the engine

Posted on Jun 22, 2008

Ad
  • 1 Answer

SOURCE: speedometer intermittently stops working

your ABS module (board) is crack and a good fixman could check that to fix or change it

Posted on Sep 22, 2009

  • 1 Answer

SOURCE: 1999 Volvo S80 T6 slightly fluctuating idle/blinking head lights

I had a similar problen on my s60 I got the trottle body properly cleaned and it fixed it right up

Posted on Sep 24, 2009

ftw1952
  • 10319 Answers

SOURCE: I have a 2004 Volvo s60 with a 2.4. The car runs.

Here is a website that a free manual can be down loaded for your vehicle


http://ezinearticles.com/?Find-the-Free-Auto-Repair-Manual-You-Need-Online&id=92717

Posted on May 01, 2010

  • 1 Answer

SOURCE: 2002 Volvo S60 D5 gauges-backlights stopped working

Volvo's are know for bad Dashboards. The circuit board processor on the back of the DIM Cluster goes bad. I had a shop in Richmond, VA fix mine for $275 out of the car. They will fix yours if you send it to them, here is the URL:

http://www.carradio.com/

Posted on Jul 20, 2012

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

2005. Why have gauges ceased to function?


Gauges have their own fuse. Under dash fuse panel. If it keeps blowing, you have a short to the power wire.

Nov 22, 2015 | Nissan Maxima Cars & Trucks

1 Answer

1994 f150 dash gauges not working


Go to fuse panel left of steering column. Ck to see if #17, 10A fuse, is blown.

Nov 08, 2012 | 1989 Ford F 150

1 Answer

What do I do if I the gas gauge and speedometer doesnt work?


No help but my gauges stopped working at about the same time on my '98 Frontier. So far, the fuel, temp., speedometer, odometer and trip gauges don't work or some work at different times after starting the engine.

Sep 09, 2010 | 2001 Nissan Xterra

1 Answer

Dash board gauges not working on voyager 2000


You need to check your main fuses under the hood first and then check them under the driver side dash board.

Jan 25, 2010 | 2000 Plymouth Voyager

1 Answer

2000 Toyota Camry instrument panel gauges not working


check the fuses in your manual it will tell you which fuses are for the dash and replace them it sounds to me like they are blown! good luck

Jan 09, 2010 | 2000 Toyota Camry

2 Answers

My check gauges light came on and my gas gauge, temp gauge, speedometer and of course odometer are not working.


Mine has done this a few times after having disconnected the battery for service. Disconnecting and reconnecting the battery a second time brought them back. A mechanic friend told me it hase something to do with the ECM relearning after having been disconnected. Hope this helps.

Jun 15, 2009 | 1995 Plymouth Grand Voyager

Not finding what you are looking for?
2000 Volvo S70 Logo

Related Topics:

60 people viewed this question

Ask a Question

Usually answered in minutes!

Top Volvo Experts

yadayada
yadayada

Level 3 Expert

76630 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22219 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8514 Answers

Are you a Volvo Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...