Question about 2000 Nissan Xterra

1 Answer

Fuel gage not working - 2000 Nissan Xterra

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Expert
  • 79 Answers

You need to replace your fuel level sensor. This is found on the fuel pump. You will need to drop the fuel tank to do this job. If you decide to do this on your own, you will also need to buy a new packing so prevent a evap leak from happening.

Posted on Feb 19, 2014

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My 2000 Chevy s15 Rpm and Gas Gauge is not working


I didn't see an s15 in that model year, in my database?
If the speedometer works but the tach doesn't, I think something is wrong with instrument cluster?
GM has had a problem with fuel gage sending units. The sending units are not hard wired to instrument cluster, they send signal to pcm, the pcm sends serial data to instrument cluster, telling the cluster the gage settings.
It may be possible to use different size resistors in place of the fuel level sending unit, to see if fuel gage reacts properly to different resistors, if the gage reacts properly, then I think the problem is the fuel gage sending unit.

Nov 02, 2016 | Chevrolet Cars & Trucks

1 Answer

Gas gage not working


Maybe a problem with instrument cluster?
Usually the circuit works off resistance to ground. The sending unit in gas tank provides resistance to ground. The signal wire for fuel gage is a purple wire, if goes to fuel pump wiring connector. With key on, use digital multimeter, check for voltage. If no voltage, either problem with wiring circuit or instrument cluster. W/0 looking at instrument cluster, I don't know if you can replace gage itself w/o replacing instrument cluster?

If voltage on the purple wire, ground it, while a helper watches the gage, if the gage starts reacting, then check the grounds for fuel pump wiring connector, if that checks ok, suspect the fuel pump sending unit has a problem.

Apr 23, 2016 | 1991 Chevrolet Lumina

1 Answer

My fuel gage in my chev s10 doesn't work I've done


did you set the fuel in right .sound like the sending unit is not right place

Dec 02, 2012 | Cars & Trucks

1 Answer

Fuel gage fuse


The fuel gage shares the same fuse as all the gages, so if the fuel gage is inop and all other gages are working then you have another problem. The most common cause is that the sending unit for the fuel gage inside the fuel tank is defective, that is true 99% of the time in my 35 years of repair work.

Jan 20, 2012 | Ford F-250 Cars & Trucks

1 Answer

Gas gage is not working rite


The most common cause of a erratic or incorrect fuel gage reading is a defective fuel gage sending unit inside the fuel tank. To replace the sending unit requires that the fuel tank be removed from the car and then the fuel pump module which contains the sender be replaced.

Jan 04, 2011 | 1997 Oldsmobile Aurora

1 Answer

Fuel guage not working


Testing the fuel gage requires accessing the harness from the fuel pump and grounding the yellow / white wire with 160 ohms resistance this should cause the gage to read full, and with the circuit open you should have the gage reading empty. If the gage works in this order then the likely failure is the sending unit in the tank , and will require replacement.

May 30, 2010 | 1999 Ford Expedition

1 Answer

Fuel gage not workin after going


You could have losen the wireharness from the tank to the frame, check along the frame towards the fuel tank and check for any loose connection. The only other thing is the sending unit in the tank it self may have gone bad. Good luck

Apr 08, 2009 | 1996 Chevrolet K1500

1 Answer

The digital fuel and temperature gauge is not working


u will need to replace the fuel gauge sending unit.

Mar 27, 2009 | 1989 Ford Probe

3 Answers

2001 Pontiac Montana Temperature Gage and Fuel Gage malfunction


sending unit or float in gas tank, check if any broken wires or well plugged in and then check the float for the gas.

Nov 02, 2008 | 2001 Pontiac Montana

Not finding what you are looking for?
2000 Nissan Xterra Logo

28 people viewed this question

Ask a Question

Usually answered in minutes!

Top Nissan Experts

yadayada
yadayada

Level 3 Expert

76109 Answers

Phil Lovisek
Phil Lovisek

Level 3 Expert

726 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Are you a Nissan Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...