Question about 1994 Mercury Villager

1 Answer

Its a 94 mercury villager runs good til it warms up then dies and wont start back till it cools off i replaced the imc, distributor, coil pack and fuel pump

Cant figure it out is it the computer

Posted by Anonymous on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

Check your fuel pump relays and fuses and make sure they don't have play

Posted on Apr 26, 2014

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 141 Answers

SOURCE: 1989 cougar wont start

Is the inertia switch on the passenger kick panel popped?

Posted on Jan 09, 2009

chuck943
  • 783 Answers

SOURCE: Engine trouble after warmed

Try this first.Take off the distributor cap and rotor button,Then remove the 2 screws holding the cover on under this. You will then see a sensor and a wheel with a bunch of slots in the end of the wheel this is the ignition photo cell.You will probably see a black film built up on it.Clean this with electrical cleaner then blow dry or let it totally air dry before putting it back together. This usually solves the concern you have.

Posted on Mar 20, 2009

  • 64 Answers

SOURCE: 94 mercury villager wont start

power on the small terminal of the starter solenoid when you turn the key?

Posted on Jul 11, 2009

dttech
  • 4803 Answers

SOURCE: I have a 93 mercury topaz 4cyl 2.3L that stalls

It sounds to me like you replaced everything but the most likely cause of a stall while driving...The crank sensor.

Posted on Oct 11, 2009

  • 1 Answer

SOURCE: 1998 Mercury Grand Marquis GS runs Rough when cold

I have the same problem and can
Not figure it out did u have any luck?

Posted on Oct 17, 2011

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

1996 mercury villager as it warms about 3 miles you come to a stop it will still idle but when


Check your air inlet hose(large black rubber hose from air filter to engine)for any cracks, especially between ribs. When there are cracks,when you accelerate it flexes open and creates a giant vacuum leak causing your van to die. Other things to check would be coolant temp sensor,not switch, and have the vehicle scanned if possible.

Sep 01, 2014 | 1996 Mercury Villager

1 Answer

Turns over but wont start


check battery and connection,tune up,fuel filter.

Mar 09, 2013 | Cars & Trucks

1 Answer

Why does my 93 Caravan Start fine and run great till it warms up then dies and wont start untill it cools back down.


I had the same problem a few years ago and it was the coil pack breaking down. If it starts missing before it dies id get a new coil pack. Before u buy a coil pack you need to get it warm again and just before it dies look underneath the vehicle to see if the catalytic converter is starting to get hot, if it is hot and usually getting red hot, its stopped up.It will fool you in to thinking that the coil is bad.

Nov 05, 2012 | 1993 Dodge Caravan

1 Answer

94 CAPRICE WITH LT1 WONT STAY RUNNING


check fuel regulator, fuel pressure, could be bad sending unit in fuel tank, change out fuel filter

Apr 30, 2012 | Chevrolet Caprice Cars & Trucks

1 Answer

1999 mercury villager, where is the cam sensor located and how do i change it?


cam sensor is in distributor, not serviceable. 1999 is noted for failing cam sensors. Usually runs good cold, then gets worse after warm till it fails all together.
Buy Rich Porter reman on ebay for $200 to get a good one.

join our group

http://groups.yahoo.com/group/villagerquest/

Feb 20, 2011 | 1999 Mercury Villager

1 Answer

I hav a 94 chevy k1500 but it wont stay running. One morning i started it up, got it warm then while i was goin down the road it acted like it was running out of gas,would die then start back up then just...


Turn on the key and listen by the fuel tank for the fuel pump to hum. A common problem is low fuel pressure. It will build pressure when the key is turned, use that fuel, and then the pressure drops. Kind of like when you're using a squirt gun that's getting empty.

Feb 28, 2010 | 1994 Chevrolet K1500

2 Answers

I have a 1996 Mercury Villager (Canadian version) with 60 K miles. Sometimes when starting, the engine turns but it wont start. When this situation occurs, I usually try to start again while pressing on...


I would definitely consider the fuel pump. I had long turnover times before starting for years, but even worse was in hot weather it would just stall while driving. Sometimes it would only idle, but not run if you pressed the gas very far. Park it for 20-30 minutes and it would run again without another problem for weeks. Dealers and mechanics kept replacing other things like ignition coils and distributors. After a conversation where someone said they had the same problem, but only when they had less than half a tank of fuel, I knew it was the pump. I replaced it myself and all problems went away.
The fuel leaks back down to the tank and air gets in the lines. Then the pump is slow to build pressure up again. If you turn the key on, but not start, wait 45 seconds, off, on again but not start, wait again, now start it will take a little less time to start, less battery drain, until you fix the problem.
You may not have the heat problem in Canada. But here in Georgia it gets hot enough that if the fuel tank is low and the pump has this problem, it will overheat and shut down till it cools. A full tank helps it keep the pressure up and serves to cool the pump.

Jul 02, 2009 | 1996 Mercury Villager

2 Answers

Wont start after warmed up


Check the PCV valve, EGR valve and the Idle Air Control Valve. Also check for any vacuum leaks

Jun 02, 2009 | 2000 Mercury Villager

Not finding what you are looking for?
1994 Mercury Villager Logo

144 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mercury Experts

yadayada
yadayada

Level 3 Expert

75051 Answers

fordexpert

Level 3 Expert

5470 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Are you a Mercury Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...