Question about 1998 Lincoln Town Car

2 Answers

My defroster blows hot but window fogs up more plus it smells like radiator coolant

With that heater blowing hot it also has an oily film on the windshield. I can drive it for 15 miles and pull over and it starts to work fine. Could it be a bad heater core or something else.

Posted by on

Ad

2 Answers

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Lincoln Master
  • 2,448 Answers

NO Question about it the heater core is bad

Posted on Mar 05, 2015

Ad
  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Top Expert:

    An expert who has finished #1 on the weekly Top 10 Fixya Experts Leaderboard.

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

  • Lincoln Master
  • 21,873 Answers

Yes the odds are the heater core is leaking coolant.

Posted on Feb 13, 2014

Ad

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya Mechanic can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repair professionals here in the US.
click here to Talk to a Mechanic (only for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

  • 56 Answers

SOURCE: Fogged windows with the defroster on hi

That is normally a classic symtom the Heater core has gone, Another is normally lost of coolant or smelling of antifreeze

Posted on Jan 23, 2009

shaggyrat
  • 1224 Answers

SOURCE: a/c blows cold parked then blows hot after a few miles

engine fan not kicking in at right interval to bring air in so its pulling in hot air threw ducts
or you have a disconnected duct blowing all air out not to right place

guages could be faulty or bad a/c relay

Posted on Jun 10, 2008

  • 6 Answers

SOURCE: heater blows cold air. does not get hot and

mine wouldn't blow warm air either so I took it out on the hiway and ran it at 5 grand for about 10 minutes.now it works like new.
Hope this works as well for you.

Posted on Jan 13, 2010

greg_margo
  • 1959 Answers

SOURCE: The heater core gets hot

Check to see if the air coming from the vent is also lukewarm. If it is and assuming the coolant level is fine, the most likely cause is a bad thermostat. If the air coming from the vent is hot, you may have an issue with the blend door which determines air flow.

Posted on Feb 18, 2011

afarri
  • 1386 Answers

SOURCE: When driving distances of 10

Hello and welcome to FixYa!
Looks like that you lack freon. It's just normal to loose freon for it really does as the a/c operates. As a first course of action, I strongly suggest that you have a freon charge to resolve the problem.
If the problem still persists, I suggest that you take it in for a leak test. There can be a small hole somewhere on the lining and may need to be welded. It can be a worn out expansion valve and thermostat as well. Let's just hope that freon charging resolves it to cut you the cost.
Hope this helps and thank you for using FixYa! Have a good one!

Posted on Aug 27, 2011

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Fogging windows


Heater radiator leak.It is under the windscreen and can blow hot water (vapor) to the glass.Does it slightly smells heated water?Very rare:rain water in the saim compartment as the heater having the same simptoms.Track the problem,ceck coolant level regularly.Cheers,hope u deal it,let others know.

Oct 26, 2013 | Jeep Cars & Trucks

1 Answer

When I turn my heater and defroster on, a bad smell starts and the windows fog up but the air is hot.


This may be due to a bad heater core or dirty core with a plugged water drain, first see if the a/c works. turn it on and see if the air gets cold and if the ac compressor works.

The way the defrost works to keep windows from fogging up is that when the front defroster is tuned on the ac should also be on, on most cars when you go to defrost it will turn ac on automatic. the system then uses hot and cold air to remove the moisture in the air to avoid window fogging. if your a/c is not working then that may cause window to fog, but if you are also getting a smell then the drain that lets out condensation may be plugged and then water builds up and also mold from always being wet and when heat is on you smell that.


i want you to run the defrost and when windows fog up wipe window with hand and see if it is greasy . if it feels oily then you may have a bad heater core, the core leaks coolant out and steam and causing windows to fog up with a flim of grease.

Feb 03, 2013 | 2000 Chevrolet Silverado

1 Answer

My heater is only blowing only cold air


check and make sure you are full of coolant in your radiator/overflow reservoir. This is important!
If you see you are full of coolant and it gets hot once you drive down the road 15 minutes you have a thermostat stuck in the open position.
If that isn't the case, you probably have a faulty heater core plugged up.
Are you leaking coolant anywhere? Do you smell antifreeze? If the heater core is behind the dash you might see water on the floor or your defroster will fog up the windows on a cool day.
I hope this helped you out somewhat. Please let me know what you find!
Larry

Mar 24, 2011 | Ford Expedition Cars & Trucks

2 Answers

I have a dodge 97 dakota, my heater doesnt blow out heat after warming up and being driven, and sometimes i kind of smell antifreeze, when i use the defroster


it sounds as if you have two problems,one the heater core is plugged and two you have a heater core that is leaking.the leak is shown when you use the defroster by the smell and chances are there is a light film of antifreeze on the windsheild.and the plugged heater core is shown by no heat.check the radiator to make sure the coolant level is full and the overflow bottle is at the full level. as a low coolant level in the radiator will cause no heat.with the car warmed up(radiator coolant hot), check the heater hoses at the firewall were they enter the heater core they should be the same temperature from one hose to the other.if the coolant level is up and the hoses are the same temperature then the heater core is plugged.if the coolant temperature is the same from hose to hose but not hot to the touch the thermostat may be weak and needs replacing.either way the heater core will need to be replaced as it is leaking into the heater box assembly

Mar 08, 2011 | 1997 Dodge Dakota

1 Answer

Why my window is fogging whe i turn the heater ?? i recently bought my toyota carina 3 model 1994 but the window is fogging , what should i do?


Make sure the vent system is set to draw air from outside. If it is set to recirculate the same air that's inside the vehicle without drawing fresh air from outside, the resulting humidity that builds up inside the vehicle can fog the windows even when you run the defrost. You can also try opening the windows a bit to get some more air moving inside.
If it still fogs when the vents are set properly, you may have a leaky heater core. The heater core is a small radiator that is located under the dash that the heater system blows air through to heat the inside of your car and provide heat to defrost the windshield. The fog may be coming from the heater core leaking hot coolant steam that's being circulated through the defrost system. If this is so, you will need to replace the heater core.

Jan 07, 2011 | 1997 Toyota Corolla

1 Answer

The windows will not defrost on my 2000 dodge durango 4.7l 4x4 do you think it is the heater core? or should i try flushing the system first?


If the heater core is leaking it will blow steam out onto the windshield fogging it up. Check your coolant level in the radiator. Check for wet carpet near the heater blower motor. Is it blowing hot??

Dec 09, 2010 | 2000 Dodge Durango

1 Answer

Cooling system problems include low coolant and an acrid smell coming through the vents. We filled up the coolant and checked for leaks and there are none. Will this happen again and what is going on.


Do the windows (windshield) fog up for about 2 seconds if you switch the defroster on too? Sounds like you have a leak in the heater core. It's a small radiator located in the heater box inside the cabin of the vehicle. The blower fan blows through it to heat the cabin. If it's leaking or has a hole in it, what you are smelling is antifreeze. You can try a good radiator sealant and if that doesn't work. You'll have to change the heater core. Explorers aren't fun.

Mar 28, 2010 | 1992 Ford Explorer

3 Answers

2000 jeep cherokee does not heat or defrost fan


the oily substance you talk about is antifreeze, your heater core is damaged and leaking in the form of mist and going to your windshield you must replace your heater core in the dash generally behind the glove box.

Feb 05, 2010 | 2000 Jeep Grand Cherokee

1 Answer

Fogging up issues


If you can feel the air from the blower motor blowing up on the windshield it is probably one of two things. Either your heater core has a leak and the anti-freeze mist film is all over the windows or your heater control valve is not working.
Does the heater get hot or can you feel hot air on the windshield? If so your heater core is probably leaking and making steam inside your car.

Dec 22, 2008 | 2001 GMC Yukon XL

Not finding what you are looking for?

Open Questions:

0 Answers

98 Lincoln TC,Cold starts fine ,runs good until warm, then shuts off. No codes,Cranks ok, have spark, PATS ok. No fuel pressure, cant hear fuel pump prime,New Fuel relay. jumped fuel pump - works. I do not hear fuel pump prime up, do not have fuel gauge, but pressing on valve in fuel rail- no pressurized fuel. Fuel regulator seems ok, not leaking / vacuum line dry as a bone. If I let it set for 15 min , it will start up again, but for a few minutes then dies out. If I let it set overnight it starts up perfectly and runs until operating temp is reached then stalls/stumbles, and shuts down. Vacuum is good while cranking, even with no start, Checked Inertia switch in trunk, it is not tripped. I have seen Ford TSB summaries' that mention issues like this , but I am not able to see to description. A point to add, the MAF sensor was cleaned, then I decided to replace it and did not make a difference. I do not have any stored codes, and the PATS is working fine, typical 2 second flash from and once key is inserted a 3 second steady light, then disappears. I have seen the TSB mentioning C103 Connector, it looks fine, I swapped out fuel pump relay with ac relay, still no difference.mention of wires around battery, do not know where to start. in dash service engine light and odometer is normal, seen other posts the say they only have lines, but mine is ok. the start of all of this , I washed engine with regular garden hose, ( not using pressure washer).also in the mean time, rear window defroster stopped working as well, can not say for same reason, but a mention.My problem started after washing engine. this is one of four Panther platform vehicles I owned with exact 4.6l w code engine, which I rinced down before. The only sensor I can think of is Oil pressure , or a corroded wire

Feb 27, 2017 | 1998 Lincoln Town Car

See all 1998 Lincoln Town Car Questions

1998 Lincoln Town Car Logo

180 people viewed this question

Ask a Question

Usually answered in minutes!

Top Lincoln Experts

yadayada
yadayada

Level 3 Expert

77169 Answers

fordexpert

Level 3 Expert

5572 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22258 Answers

Are you a Lincoln Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...